PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV (précédentes versions) → WebDev 19 : affichage d'un jpg dans un champ image
WebDev 19 : affichage d'un jpg dans un champ image
Débuté par CFR, 05 fév. 2017 17:32 - 10 réponses
http://hostimage.webdev.info/avatars/YOAv2WM6bCUA1dD8Nx8h4A
Membre enregistré
6 messages
Posté le 05 février 2017 - 17:32
Bonjour
J'essaie d'afficher un fichier jpg dans un champ image par programmation.
J'ai créé un champ image sur ma page (IMG_Vignette), puis un bouton pour déclencher l'affichage.
Le code du bouton est une simple affectation avec chemin complet du fichier.
IMG_Vignette ="C:\WebDev\Projet\_donnees\CI-000\Fi_clients\nomfichier.jpg"

Lorsque je clique le bouton, il ne se passe rien, simplement une petite icône avec un x dessus.

Il me semble que les paramètres du champ sont corrects...

Quelle est mon erreur ?
http://hostimage.webdev.info/avatars/default.gif
Posté le 05 février 2017 - 23:55
Bonjour

>
> Quelle est mon erreur ?

1. tu ne nous dis pas si c'est du code serveur ou navigateur

2. tu ne nous donnes aucun des paramètres du champ image

3. Tu ne nous dis pas si c'est en test ou déployé

4. tu ne nous dis pas en quel mode tu travaille (classique/awp/php)

5. ...

Cordialement


--
Fabrice Harari
Consultant WinDev, WebDev et WinDev Mobile International

A votre disposition : WXShowroom.com, WXReplication (open source) et
maintenant WXEDM (open source)

Plus d'information sur http://fabriceharari.com
http://hostimage.webdev.info/avatars/YOAv2WM6bCUA1dD8Nx8h4A
Membre enregistré
6 messages
Posté le 06 février 2017 - 22:15
D'accord, désolé pour le manque de précision de ma demande.
Code serveur
C'est en test
AWP

Les paramètres du champ image sont les suivants (mais j'ai essayé plusieurs paramètrages sans succès):
- type statique
- affichage 100%
- aucune transition
- état initial visible
- localiser dans le répertoire _web en code navigateur : décoché
- protection de l'image : décoché
- zoom auto : aucun
- pas de glisser / déplacer
- pas de chargement différé
- pas de liaison
- générer le HTML même lorsque le champs n'est pas visible
http://hostimage.webdev.info/avatars/default.gif
Posté le 07 février 2017 - 10:31
Bonjour


Le 2/6/2017 à 4:15 PM, CFR a écrit :
D'accord, désolé pour le manque de précision de ma demande.
Code serveur


quel code serveur ? Bouton ? Init ? Ajax ou pas ?

C'est en test
AWP

Les paramètres du champ image sont les suivants (mais j'ai essayé
plusieurs paramètrages sans succès):
- type statique
- affichage 100%
- aucune transition
- état initial visible
- localiser dans le répertoire _web en code navigateur : décoché
- protection de l'image : décoché
- zoom auto : aucun
- pas de glisser / déplacer
- pas de chargement différé
- pas de liaison
- générer le HTML même lorsque le champs n'est pas visible


"C:\WebDev\Projet\_donnees\CI-000\Fi_clients\nomfichier.jpg"

Est ce que ton utilisateur web a accès à ce répertoire ? (normalement,
on utilise un sous répertoire de projet_web pour ce genre de choses).

Si tu fais un accès différent au jpg, peux tu le lire depuis le même code ?

Cordialement


--
Fabrice Harari
Consultant WinDev, WebDev et WinDev Mobile International

A votre disposition : WXShowroom.com, WXReplication (open source) et
maintenant WXEDM (open source)

Plus d'information sur http://fabriceharari.com
http://hostimage.webdev.info/avatars/YOAv2WM6bCUA1dD8Nx8h4A
Membre enregistré
6 messages
Posté le 07 février 2017 - 20:37
Fabrice Harari a écrit :
> quel code serveur ? Bouton ? Init ? Ajax ou pas ?
Clic du bouton (pas init), Pas Ajax

"C:\WebDev\Projet\_donnees\CI-000\Fi_clients\nomfichier.jpg"
Est ce que ton utilisateur web a accès à ce répertoire ? (normalement,
on utilise un sous répertoire de projet_web pour ce genre de choses).


L'utilisateur Web y a accès.
J'ai essayé de mettre le fichier dans projet_web sans succès (même effet).
J'ai d'abord mis le chemin complet : "C:\WebDev\Projet\Projet_WEB\nomfichier.jpg"
Ensuite, j'ai essayé juste le nom de fichier, en cochant "localiser dans le répertoire _web en code navigateur"
Toujours rien
http://hostimage.webdev.info/avatars/default.gif
Posté le 07 février 2017 - 21:30
Bonjour

puisque tu changes ton image par code, elle ne devrait logiquement pas
être statique. Passe la en dynamique vitesse maximale, ca devrait aller
mieux

Cordialement

--
Fabrice Harari
Consultant WinDev, WebDev et WinDev Mobile International

A votre disposition : WXShowroom.com, WXReplication (open source) et
maintenant WXEDM (open source)

Plus d'information sur http://fabriceharari.com


Le 2/7/2017 à 2:37 PM, CFR a écrit :
Fabrice Harari a écrit :
quel code serveur ? Bouton ? Init ? Ajax ou pas ?
Clic du bouton (pas init), Pas Ajax


"C:\WebDev\Projet\_donnees\CI-000\Fi_clients\nomfichier.jpg"
Est ce que ton utilisateur web a accès à ce répertoire ? (normalement,
on utilise un sous répertoire de projet_web pour ce genre de choses).

L'utilisateur Web y a accès.
J'ai essayé de mettre le fichier dans projet_web sans succès (même effet).
J'ai d'abord mis le chemin complet :
"C:\WebDev\Projet\Projet_WEB\nomfichier.jpg"
Ensuite, j'ai essayé juste le nom de fichier, en cochant "localiser dans
le répertoire _web en code navigateur"
Toujours rien
http://hostimage.webdev.info/avatars/YOAv2WM6bCUA1dD8Nx8h4A
Membre enregistré
6 messages
Posté le 09 février 2017 - 06:14
Cela ne fonctionne pas si je mets le chemin d'accès complet du fichier, quel que soit l'endroit
Le seul cas où ça fonctionne maintenant, c'est quand j'ai le fichier dans le répertoire Project_Web ET que je coche "localiser dans
le répertoire _web en code navigateur".
Par contre, pour moi c'est important d'utiliser un autre répertoire.
Qu'en penses-tu?
http://hostimage.webdev.info/avatars/default.gif
Posté le 09 février 2017 - 13:10
Bonjour

1. as tu passé l'image en dynamique ?

2. il est normal de n'utiliser QUE des sous répertoires du répertoire
web (problème de droits/sécurité sur le serveur). Placer tes images
n'importe ou ailleurs ne va que créer des problèmes.

Ca sera encore plus STRICT une fois déployé (voire impossible, selon OU
tu déploie)


3. Tu peux par contre mettre tes images dans ta base de données, et ne
plus avoir ces problèmes (c'est légèrement plus lent en affichage)

Cordialement


--
Fabrice Harari
Consultant WinDev, WebDev et WinDev Mobile International

A votre disposition : WXShowroom.com, WXReplication (open source) et
maintenant WXEDM (open source)

Plus d'information sur http://fabriceharari.com


Le 2/9/2017 à 12:14 AM, CFR a écrit :
Cela ne fonctionne pas si je mets le chemin d'accès complet du fichier,
quel que soit l'endroit
Le seul cas où ça fonctionne maintenant, c'est quand j'ai le fichier
dans le répertoire Project_Web ET que je coche "localiser dans
le répertoire _web en code navigateur".
Par contre, pour moi c'est important d'utiliser un autre répertoire.
Qu'en penses-tu?
http://hostimage.webdev.info/avatars/YOAv2WM6bCUA1dD8Nx8h4A
Membre enregistré
6 messages
Posté le 09 février 2017 - 19:51
Oui, l'image est maintenant dynamique.
Je vais faire qq essais ce week-end en mettant les images dans la base de données, mais là aussi j'ai eu des soucis, et je suis revenu à des jpg dans des répertoires.
Je te redis.
En attendant, merci pour l'aide que tu m'as déjà donnée
http://hostimage.webdev.info/avatars/YOAv2WM6bCUA1dD8Nx8h4A
Membre enregistré
6 messages
Posté le 12 février 2017 - 20:15
Hello
J'ai fait qq essais en utilisant fcopiefichier pour mettre l'image dans le répertoire Projet_WEB juste avant d'en avoir besoi et de la supprimer juste après.
ça fonctionne, mais c'est évidemment pas très propre.
En tout cas, le fait que ça fonctionne démontre que ce n'était pas une question de droits.
Finalement, suivant ton conseil, j'ai mis l'image dans mon fichier de données et je l'affiche depuis là avec Fichierverspage.

Encore une fois, merci de ton aide
http://hostimage.webdev.info/avatars/default.gif
Posté le 21 février 2017 - 06:07
Hello CFR,

Pour ma part, je te propose ma méthode pour charger une image.

chemin_image est une chaîne
chemin_image = "Ton lien web de ton image"
HTTPRequête(chemin_image)

monImage = HTTPDonneRésultat()


L'avantage est que tu peux placer ton image n'importe où et y accéder via son lien url.
Perso, je place le lien en BD cela permet de modifier l'image sans devoir monter le site.

A+

Alex