PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV 25 → [%..%] no funciona en Windev 25 Express
[%..%] no funciona en Windev 25 Express
Started by Juan Carlos, Apr., 30 2021 2:04 PM - 2 replies
Registered member
2 messages
Posted on April, 30 2021 - 2:04 PM
Buenos dias,
estoy comenzando la formación en windev y tengo el siguiente ejemplo:
gsBuiltString is string
gsProductName is string = "WINDEV"

// Concatenation
gsBuiltString = gsProductName + "is my go-to development tool!"
Trace("Concatenation: " + gsBuiltString)

// StringBuild
gsBuiltString = StringBuild("%1 is my go-to development tool!", gsProductName)
Trace("StringBuild: " + gsBuiltString)

// Direct input of the variable ([% %] syntax)
gsBuiltString = "[%gsProductName%] is my go-to development tool!"
Trace("Direct input: " + gsBuiltString)

Y el resultado es:
Concatenation: WINDEVis my go-to development tool!
StringBuild: WINDEV is my go-to development tool!
Direct input: [%gsProductName%] is my go-to development tool!

Como ven, la tercera forma toma literalmente los caracteres [%..%].

Alguien sabe por que?

Estoy travajando en Windows 10 64 bit y con WinDev Express

Muchas gracias!!
Registered member
457 messages
Posted on April, 30 2021 - 11:16 PM
Hola. ¿Has comprobado si la opción esta activada en el proyecto en las opciones de compilación? Proyecto->Descripcion->Compilación-> Permitir "[% %] en las cadenas

Rubén
Registered member
2 messages
Posted on May, 01 2021 - 5:42 PM
Hola y muchas gracias!!:D, Es justo lo que tenia que hacer.
Que tengas un exelente fin de semana!gracias: