PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → Off-topic → CALCULATRICE
CALCULATRICE
Started by Jeancy TOUNGOU, Jun., 02 2021 9:11 AM - 2 replies
Registered member
1 message
Posted on June, 02 2021 - 9:11 AM
bonjour,
j'ai créée une calculatrice,mais je n'arrive pas à créer une touche qui peut qu'effacer ou supprimer
que le dernier chiffres.
Pouvez-vous m'aider svp?quels sont les codes sources à utiliser?
Posted on June, 02 2021 - 4:42 PM
Bonjour,
Pour faire ça, j'ai créé un bouton avec un libellé "<-" sur mon pavé de calculatrice.





Sur l'évènement "Clic" des boutons,de la calculatrice, j'appelle une fonction locale qui agit selon le libellé du bouton cliqué : RemplirQuantite(MoiMême..Libellé). En l'occurrence, le CAS ">-" prend la chaine existante, supprime le dernier caractère à droite de cette chaine, puis le renvoie à la zone de saisie/affichage de la valeur prise en compte( sai_quantite). Les valeurs numériques sont transformées en chaine avant traitement, pour pouvoir utiliser la fonction Droite()
PROCÉDURE RemplirQuantite(Valeur est une chaîne)

sQte est une chaîne = SAI_Quantité
rQte est un réel

SELON Valeur
CAS ","
SI ChaîneOccurrence(sQte,Valeur) > 0 ALORS RETOUR
sQte = sQte+Valeur+"0"
gbVirguleSaisie = Vrai
CAS "<-"
sQte = Gauche(sQte,Taille(sQte)-1)
CAS "-/+"
SI ChaîneOccurrence(sQte,"-") > 0 ALORS
sQte = Droite(sQte,Taille(sQte)-1)
SINON
sQte = "-" + sQte
FIN
CAS "C"
sQte = ""
AUTRES CAS
SI gbVirguleSaisie ALORS
rQte = Val(sQte)+(Val(Valeur)/10)
sQte = NumériqueVersChaîne(rQte,"5.1F")
gbVirguleSaisie = Faux
SINON
sQte = sQte+Valeur
FIN
FIN

SAI_Quantité = sQte


Il y a surement mieux à faire, mais ça marche...
Registered member
827 messages
Popularité : +2 (2 votes)
Posted on June, 10 2021 - 5:01 PM
Bonjour,
Uniquement pour le dernier chiffre je ferais quelque comme :
sMaSaisie est chaîne=SAI_Monétaire
nTaille est un entier=Taille(sMaSaisie)-1
SAI_Monétaire=sMaSaisie[1 À nTaille]


--
Thierry TILLIER
Développeur Windev-Webdev
Formation Windev : https://coursdinfo.teachable.com/
Formation bureautique : https://coursdinfo.net
Tuto WINDEV sur ma chaîne Youtube