PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WEBDEV (earlier versions) → [WB26] PHP MYSQL Erreur Accès natif
[WB26] PHP MYSQL Erreur Accès natif
Started by Fred B, Aug., 27 2022 2:04 PM - 1 reply
Posted on August, 27 2022 - 2:04 PM
Bonjour à tous et toutes

je galère avec un premier projet Webdev php et mysql

En local sur le poste de dev :

- installation xampp avec mysql fonctionnel via phpmyadmin OK
- connexion mysql accès natif fonctionnel sur l'analyse OK
- accès aux données directement via WDMap et CCHF OK
- tous les tests WDAdmin OK

et surtout :
- le site à déja fonctionné en mode "déboguer le projet php en mode simulation"
avec accès aux données, HChangeConnexion et HCréationSiInexistant fonctionnels.
par contre si je reste en mode debogage normal : j'obtiens systématiquement une page blanche


Maintenant le problème :

Depuis un redémarrage du PC, impossible de relancer le site en mode "déboguer le projet php en mode simulation"
Cela me met systématiquement le même message alors que ça a fonctionné avant.

Au niveau du code, le HChangeConnexion passe mais l'erreur se produit systématiquement sur HCréationSiInexistant
et forcément si je met en commentaire la ligne, c'est les lignes suivantes d'accès aux données qui plantent.


--------------------------------------------------------------------------
Erreur de l'accès natif MySQL.
Numéro d'erreur = 27

La couche client MySQL n'est probablement pas correctement installée.
Aucune bibliothèque d'accès à MySQL n'a été trouvée, le module libmysql.dll (32 bits) ou une de ses dépendances n'a pas été chargé.

Détail de l'erreur système :

Le module spécifié est introuvable.
(126)

Pile des appels :
Initialisation de session PHP de ------ (), ligne 96

Date : 27/08/2022 13:48:02
Projet : JAUBI_GESTION

Informations supplémentaires :
Code erreur : 73001
Code erreur WD55 : 3001
Code d'erreur système : 126
Message d'erreur système :
Le module spécifié est introuvable.
Module : wd260hf.dll (01F260101d - 26.0.313.5)

Informations de débogage :
IEWDMSQL=9.1
Module=<WDMSQL>
Version=<26.0.62.0>
Fonction (7,28)
EIT_NATIVECODE : <27>
EIT_TYPE_WDFILE : <4097>
EIT_IDCODE : <196620>
--------------------------------------------------------------------------

j'ai refait l'installation de l'accès natif
remis le fichier libmysql.dll dans les répertoires du projet, de l'exe du site, et dans le framework 32 bit de WB26

Sans succès.

Le comble :
Le projet fonctionne très bien une fois déployé sur l'hebergeur.
Mais impossible de faire du développement si je ne peux pas lancer le site sur le poste de dev.

Si vous avez des idées, je suis preneur.
Merci d'avance
Registered member
984 messages
Popularité : +50 (142 votes)
Posted on September, 07 2022 - 3:03 PM
Bonjour,

ça ressemble à un problème de version de la bibliothèque 32/64 bits entre le poste de développement et le serveur. Si c'est le cas le répertoire d'installation de la bibliothèque n'est pas le même (si mes souvenirs sont bons).

--
Thierry TILLIER
Développeur Windev-Webdev
Formation Windev : https://coursdinfo.teachable.com/
Formation bureautique : https://coursdinfo.net
Tuto WINDEV sur ma chaîne Youtube