PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WEBDEV 25 → SQL.TitreCol ne fonctionne pas comme souhaitez
SQL.TitreCol ne fonctionne pas comme souhaitez
Started by Personn02, Aug., 18 2017 11:10 AM - 3 replies
Registered member
9 messages
Posted on August, 18 2017 - 11:10 AM
Bonjour,

Je souhaite récupérer le nom des colonnes d'une requête (en MySQL) pour les afficher dans un tableau ou les traiter dans des variables.
D'après l'aide, voici mon code :

SQLRequete est une chaîne = ""
SQLReqName est une chaîne = "test"

SQLRequete = [
SELECT ID, NOM, DESCRIPTION, DATE, LIBRE1, LIBRE2, LIBRE3, LIBRE4, LIBRE5
FROM test
]
SI SQLExec(SQLRequete,SQLReqName) ALORS
SQLInfoGene(SQLReqName)
SI SQL.NbCol > 0 ALORS
TABLE1.Colonne1..Titre = SQL.TitreCol[1]
TABLE1.Colonne1..Largeur = 100
POUR i = 2 _A_ SQL.NbCol
{"TABLE1.Colonne"+i}..Visible = Vrai
{"TABLE1.Colonne"+i}..Titre = SQL.TitreCol[i]
{"TABLE1.Colonne"+i}..Largeur = 150
FIN
FIN
SQLTable(SQLReqName,TABLE1)
FIN
SQLFerme(SQLReqName)


Mais voici ce que je récupère :






Je ne comprends si cela viens de Webdev ou de mon code.

Quelqu'un a-t-il déjà eu ce problème ou bien quelqu'un voit-il mon (mes) erreur(s) ???

Pour info, le MEME code en WINDEV fonctionne parfaitement...

Merci.
Registered member
9 messages
Posted on October, 03 2017 - 11:11 AM
Une erreur windows empêchait le bon fonctionnement de la couche MySQL.
Une réinstalle de windows à réglé mon problème
Posted on August, 19 2020 - 3:34 PM
Bonjour je dois faire exactement la même chose que vous, sauf que sql.titrecol[i] renvoie ""
a la différence que je réalise un select * et non pas un select <titrecolonne1> <titrecolonne2> etc from

auriez vous une idée par hasard ?





Posted on August, 19 2020 - 3:43 PM
romain a écrit :
Bonjour je dois faire exactement la même chose que vous, sauf que sql.titrecol[i] renvoie ""
a la différence que je réalise un select * et non pas un select <titrecolonne1> <titrecolonne2> etc from

auriez vous une idée par hasard ?







Trouvé !!!!!!!

SQLInfoGene(Requetevisuelavantimport)

était ma solution.
Etant dans une condition elle n'était pas executé !!