PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WEBDEV 24 → Récupérer le nom d'une colonne après une requête
Récupérer le nom d'une colonne après une requête
Started by MICHEL, Oct., 12 2018 5:34 PM - No answer
Registered member
124 messages
Posted on October, 12 2018 - 5:34 PM
Mon projet est en dynamique PHP
Je voudrais, après exécuté une requête, récupérer les noms de champs présents dans le résultat
Je traite cela sans problème sous WinDev je bloque sous WebDev

Je suis parti de l'exemple donné : http://doc.pcsoft.fr/?3072007
J'ai écrit :
LO_RecordSet est une chaîne

SI PAS SQLExec(PC_SQL, LO_RecordSet) ALORS
RENVOYER Faux
SINON
SI Position(PC_SQL, "SELECT", 1,SansCasse+MotComplet+DepuisDébut) = 1 ALORS
SQLInfoGene(LO_RecordSet)
POUR i = 1 _A_ SQL.NbCol
Info(i, SQLLitCol(LO_RecordSet, i))
FIN
FIN
RENVOYER Vrai
FIN



La ligne info me renvoie la valeur de i mais pas le nom du champ.
Je ne vois pas ce qui peut manquer


Merci de vos idées