PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WEBDEV 27 → [WB27] Remplir une ZRList par indirection
[WB27] Remplir une ZRList par indirection
Started by Skatoux, May, 13 2022 11:32 AM - 1 reply
Registered member
3 messages
Posted on May, 13 2022 - 11:32 AM
Bonjour à tous!
J'espère que vous allez bien.

J'envoie aujourd'hui un message sur le forum parce que j'ai une question. Je commence à utiliser les indirections et après avoir lu la documentation, regardé les forums, j'arrive à récupérer les informations d'une ZRList par indirection, ca marche et j'ai bien compris le système.

Mais quand j'essaie de faire l'inverse, plus rien ne fonctionne!
J'essaie d'ajouter une ligne à une ZRList que j'ai sélectionné par indirection et je n'arrête pas d'avoir des erreurs comme celle-ci:
Cette fonction n'est pas disponible pour un élément de type 'entier'.

OU
Cette fonction n'est pas disponible pour un élément de type 'chaîne ANSI'.


Je ne sais pas si vous pouvez m'aider, voici mon code [Et j'ai également essayer .AjouteLigne("texte")]
Je désérialise des données depuis ma base de donnée que j'aimerais mettre dans une ZRListe :
//Création des variables pour le volet
nOccurence est un entier = ONG_Volet..Occurrence

//Création des variables pour la ZRListe
sZRListeNom est une chaîne = "ZR_PointCategorie"

//Obtenir le premier volet disponible
POUR i = 1 À nOccurence
SI ONG_Volet[i].Visible = VRAI ALORS
nNombre = nNombre + 1
FIN
FIN

sNombre est une chaine = nNombre

//Désérialisation
Désérialise(tblChecklist,machines_checklist.checklist_content,psdJSON)
nTaille = tblChecklist..Occurrence

//Ajout des données dans la bonne ZRListe
POUR i = 1 À nTaille
AjouteLigne({(sZRListeNom + sNombre),indChamp},"Test")
FIN


Merci de votre aide !
Cordialement,
Message modified, May, 13 2022 - 11:38 AM
Registered member
3 messages
Posted on May, 13 2022 - 12:47 PM
Problème résolu, je me sens si bête... Tellement bête haha :D

Pour ceux qui veulent la solution, ce n'était pas la fonction "AjouteLigne" mais "ListeAjoute"... Si peu de différence et une erreur si grande. Merci aux personnes qui ont lus!

--
Développeur et Sys.Admin chez V.d.W International
Bon Dev