PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WEBDEV 27 → URL affiche xxx_WEB impossible si www.monsite.com en AWP
URL affiche xxx_WEB impossible si www.monsite.com en AWP
Started by karimou, Nov., 25 2022 4:04 PM - 4 replies
Registered member
69 messages
Popularité : +0 (2 votes)
Posted on November, 25 2022 - 4:04 PM
Bonjour,

Je suis désolé mais j'ai pas trouvé de réponse à ma question donc soit vous avez abandonné car je suis sure que je ne suis pas le seul à avoir se problème soit je suis à côté de la plaque.

Mon problème c'est que j'ai mis un site webdev en ligne et lorsque j'écrit mon site "www.monsite.com"
J'ai erreur de serveur comme si sa n'existe pas et comme c'est pas héberger chez moi j'ai pas de htaccess.

Mais si j'écrit url comme ça "https://www.monsite.com/monprojet_web" là sa va fonctionner.

Je voudrais savoir si le problème vient d'un oublie de moi sur webdev ou que c'est uniquement dans l' htaccess que sa peut se régler?

et si par la même occasion vous avez une solution pour supprimer le "monprojet_web" ce serait cool de votre astuce.

Si jamais j'utilise
ConfigureContexteAWP(ctxDisque, ctxIDURL)


Merci d'avance de votre aide
Registered member
69 messages
Popularité : +0 (2 votes)
Posted on December, 05 2022 - 3:53 PM
Merci d'avance de votre aide
Posted on December, 08 2022 - 3:13 PM
karimou avait écrit le 25/11/2022 :
Bonjour,

Je suis désolé mais j'ai pas trouvé de réponse à ma question donc soit vous
avez abandonné car je suis sure que je ne suis pas le seul à avoir se
problème soit je suis à côté de la plaque.

Mon problème c'est que j'ai mis un site webdev en ligne et lorsque j'écrit
mon site "www.monsite.com"
J'ai erreur de serveur comme si sa n'existe pas et comme c'est pas héberger
chez moi j'ai pas de htaccess.

Mais si j'écrit url comme ça "https://www.monsite.com/monprojet_web" là sa va
fonctionner.

Je voudrais savoir si le problème vient d'un oublie de moi sur webdev ou que
c'est uniquement dans l' htaccess que sa peut se régler?

et si par la même occasion vous avez une solution pour supprimer le
"monprojet_web" ce serait cool de votre astuce.

Si jamais j'utilise
ConfigureContexteAWP(ctxDisque, ctxIDURL)


Merci d'avance de votre aide


bonjour
ça c'est de la config IIS ou Apache
on appelle cela les rep virtuels (iis) ou alias (Apache)
on peut aussi encapsuler ça dans un iframe pour masquer l'url à
rallonge mais maintenant ça c'est verboten.
Il y a aussi l'url rewriting

Bref pas tellement un pb Webdev mais plutôt de la config sur laquelle
un bon hébergeur devrait t'aider

--
Cet e-mail a été vérifié par le logiciel antivirus d'Avast.
www.avast.com
Registered member
1,003 messages
Popularité : +50 (142 votes)
Posted on December, 08 2022 - 6:26 PM
Bonsoir,

Votre serveur c'est IIS ?
si oui, c'est probablement le mappage qui est incorrect, (c'est en tout cas la première chose qui me vient à l'esprit).
Le site virtuel (de IIS) doit pointer sur le répertoire **_WEB et non pas sur _WEB/FR/

Normalement il n'y a pas besoin d'url rewriting pour ça.

--
Thierry TILLIER
Développeur Windev-Webdev
Formation Windev : https://coursdinfo.teachable.com/
Formation bureautique : https://coursdinfo.net
Tuto WINDEV sur ma chaîne Youtube
Registered member
69 messages
Popularité : +0 (2 votes)
Posted on December, 09 2022 - 12:04 PM
Merci de votre aide, Du coup je vais voir avec mon hébergeur.

Bonne journée et vous tiens au courant pour les suivants.