PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV (earlier versions) → [WD23] Crash sans erreur lors du remplissage d'un etat
[WD23] Crash sans erreur lors du remplissage d'un etat
Started by Arnault, Jul., 22 2021 8:48 AM - 2 replies
Posted on July, 22 2021 - 8:48 AM
Bonjour,

j'ai un soucis sur sur un état Windev rempli par programmation. La fenetre qui appelle cet etat affiche un process de production avec des PDF, tous les éléments nécessaire a l'etat sont stocké dans une table puis l'etat est appelé pour imprimer ce process en format PDF.

Le crash est aléatoire, il ne se produit pas tout le temps, il n'y a pas d'erreur et l'application se ferme immédiatement.
Ci-dessous le code du bloc de l'état (qui correspond a une page du PDF):

SI {"FEN_OI_REV_MGT.TABLE_PROCESS"}[c].COL_SNB > 0 ALORS
c += 1
FIN

Link = ""
IMAGE..Valeur = ""
RUB1 = {"FEN_OI_REV_MGT.refeVal"}..Valeur
RUB2 = dateApp[6]
RUB3 = "OI " + {"FEN_OI_REV_MGT.revOi"}..Valeur
RUB4 = "Int. " + {"FEN_OI_REV_MGT.revInt"}..Valeur
RUB5 = "Cus. " + {"FEN_OI_REV_MGT.revCus"}..Valeur
RUB6 = {"FEN_OI_REV_MGT.TABLE_PROCESS"}[c].COL_POS + " - " + {"FEN_OI_REV_MGT.TABLE_PROCESS"}[c].COL_DES
RUB19 = {"FEN_OI_REV_MGT.staOi"}..Valeur
RUB7 = nomApp[1]
RUB13 = dateApp[1]
RUB8 = nomApp[2]
RUB14 = dateApp[2]
RUB9 = nomApp[3]
RUB15 = dateApp[3]
RUB10 = nomApp[4]
RUB16 = dateApp[4]
RUB11 = nomApp[5]
RUB17 = dateApp[5]
RUB12 = nomApp[6]
RUB18 = dateApp[6]
Link = gs_oi_folder + "\" + {"FEN_OI_REV_MGT.TABLE_PROCESS"}[c].COL_IMG
IMAGE..Valeur = Link


Je suis passé en débug, il n'y a pas de soucis, parfois l'état va générer 5 pages du PDF avant de planter et parfois il va crasher sur la premiere page (dans les meme conditions de test).

Quelqu'un aurait-il une idée ?

Merci d'avance
Registered member
346 messages
Posted on July, 26 2021 - 10:08 AM
Bonjour.
Le bloc d'état doit renvoyer soit vrai, soit faux.
Renvoyer vrai : la lecture des données doit continuer
Renvoyer faux : la lecture des données s'arrête
Posted on July, 26 2021 - 1:04 PM
Bonjour,

merci pour la réponse, j'ai effectivement un retour :

Après impression de corps:

c += 1

SI c > nbLigne ALORS
resultat = Faux
SINON
resultat = Vrai
FIN


Lecture des données de "Mon Etat":

RENVOYER resultat


Malheureusement l'etat fait toujours crasher windev (aleatoirement).

Cordialement.