PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV 24 → SelecteurVersEnumeré y a t'il plus simple ?
SelecteurVersEnumeré y a t'il plus simple ?
Started by Olivier, Jan., 08 2019 11:57 AM - 2 replies
Registered member
159 messages
Popularité : +1 (1 vote)
Posted on January, 08 2019 - 11:57 AM
Salut,

Est-il possible de passer d'un sélecteur au type énumération avec lequel il est alimenté ?
J'ai essayé ce code mais je me demande si il n'y a pas plus simple.

eStatut est une Enumération
EnMarche
EnCourse
EnVoiture
EnTrain
EnAvion
FIN

eModeTransport est un eStatut

//---//

Procedure SelecteurVersEnumeré(sStatut est une chaîne)
POUR TOUT eUnStatut de eStatut
SI sStatut ~= eUnStatut ..Nom ALORS
RENVOYER eUnStatut
FIN
FIN
RENVOYER Null
// --- //

eModeTransport = SelecteurVersEnumeré(SEL_Statut)


// Avec SEL_Statut alimenté par eStatut


Bonne journée

--
Cordialement
Olivier DUCTEIL
Registered member
703 messages
Posted on January, 10 2019 - 6:22 PM
Coucou,

Si tu utilise EnumérationDepuisNom ?
// Description de l?énumération
UneEnumération est une Enumération
Valeur1
Valeur2
FIN

o est UneEnumération

// o est affecté avec la valeur "Valeur1"
o = EnumérationDepuisNom(UneEnumération, "Valeur1")

// o est affecté avec la valeur "Valeur2"
o = EnumérationDepuisNom(UneEnumération, "Valeur2")

Reference: https://doc.pcsoft.fr/?1000020769&name=enumerationdepuisnom_fonction

PS: Ne renvoie pas un Null en cas de valeur non trouvé :p
Défaut : Variable optionnelle
    Valeur par défaut à donner à l'énumération si la  n'est pas trouvée.


--
In üs we trust - #92i - #LaPiraterieNestJamaisFinie
Message modified, January, 10 2019 - 6:29 PM
Registered member
159 messages
Popularité : +1 (1 vote)
Posted on January, 11 2019 - 6:30 PM
Bonjour

C'était exactement ça !
Merci.

--
Cordialement
Olivier DUCTEIL