PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV Mobile (earlier versions) → imprimer sur android avec windev mobile 25
imprimer sur android avec windev mobile 25
Started by jupeton, Jul., 17 2021 10:44 PM - 3 replies
Posted on July, 17 2021 - 10:44 PM
bonjour à tous

j'utilise la version 25 de windev mobile et j'expérimente l'impression sur android. mais je n'arrive toujours pas à imprimer.
j'ai le message suivant selon le terminale :
- sur un smartphone Huawei android 10
message "Ce fichier n'a pas pu être ouvert. Vérifiez votre connexion ou réduisez la longueur du nom de fichier"
- sur un SUNMI V2 android 7.1
message "le fichier est inaccessible. vérifiez l'emplacement ou le réseau et essayez à nouveau"

voici le code utilisé
NomFichier est une chaîne = ""

NomFichier = fRepDonnées() + [fSep()] + "BDC.PDF"
iDestination(iPDFGénérique, NomFichier)
iImprimeEtat(ETAT_TicketAvoirs)

// Test de l'existence du fichier
SI fFichierExiste(NomFichier) = Faux ALORS
Erreur("Le fichier PDF n'a pas été généré")
RETOUR
FIN

// Confirmation pour afficher le PDF
SI OuiNon(Oui, "Afficher le bon de commande généré (format PDF) ?") = Oui ALORS
// Affichage du bon de commande généré
LanceAppliAssociée(NomFichier)
SINON
iImprimePDF(NomFichier)
FIN


je compte sur votre aide.
Merci !
Registered member
1,605 messages
Posted on July, 18 2021 - 8:02 PM
Oui en théorie l'état est utilisable pour créer un pdf
Personnellement je n'ai jamais réussi
Cependant j'ai trouvé une méthode de contournement
Qui fonctionne
https://depot.pcsoft.fr/resource.awp…
Posted on July, 20 2021 - 1:33 PM
super !!!
j'ai testé ça marche nickel !!!
merci infiniment !!!!!!!

j'arrive à avoir un aperçu, cependant l'équipement SUNMI V2 que j'utilise a une imprimante embarquée qui n'apparait pas dans la liste des imprimantes. ce qui m'empêche d'imprimer directement.
comment faire ?
Registered member
1,605 messages
Posted on July, 20 2021 - 4:54 PM
Soit tu programme en java
Soit le plus simple est de faire un lance appli associer
https://doc.pcsoft.fr/fr-FR/?3035007
A condition que le logiciel d'impression accepte le PDF