PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV Mobile 24 → gestion des contact sous android
gestion des contact sous android
Started by alezan, Dec., 07 2018 6:28 AM - 9 replies
Registered member
13 messages
Posted on December, 07 2018 - 6:28 AM
Je suis entrain de crée une application pour gérer les contact partager de mon entreprise sur des téléphone Android.
mon but et de pouvoir mettre à jour tous les contacts d"une flotte de téléphone qui aurons l'application .

j'ai déjà créer la 1ere partie de l'application l'utilisateur appui sur un boutons :
cela lance la connexion sur un ftp et télécharge un fichier csv contenant les contact à jours.
cela vient remplir un fichier fic avec les contact. jusque la pas de soucis.

ma question que me conseillez vous pour piloter les contact Android depuis mon fichier fic ?
en gros j'ai besoin de mettre à jour les nom en face des numéro de téléphone et de créer les nouveaux contacts si le numéro n'existe pas

merci de votre aide.
Registered member
13 messages
Posted on December, 07 2018 - 10:46 AM
alors j'ai avancé, avec le code si dessous cela fonction bien et m'ajoute tous les contact , mais avec mon code je ne trouve pas d'astuce pour mettre a jour le nom du contact si le numéro de telephone est déja dans le répertoire et ainsi ne pas l'ajouter en double quand le numéro existe déjà
sContenuFichier = fChargeTexte("export.csv")

POUR TOUT CHAÎNE sLigne de sContenuFichier SEPAREE PAR CRLF
// Traitement de la ligne
//NumCol=3
//CONACT.nom=extraitchaine(sLigne,1,";")
//CONACT.Prenom=extraitchaine(sLigne,2,";")
//CONACT.Téléphone_France=extraitchaine(sLigne,3,";")
//hajoute(conact)

// Variables locales
tContact est un Contact
tTéléphone est un Téléphone

// Identité
tContact.Nom = ExtraitChaîne(sLigne,1,";")
tContact.Prénom = ExtraitChaîne(sLigne,2,";")

// Numéros de téléphone Fixe
SI ExtraitChaîne(sLigne,3,";") <> "" ALORS
tTéléphone..Numéro = ExtraitChaîne(sLigne,3,";")
tTéléphone..Type = telDomicile
Ajoute(tContact.Téléphone, tTéléphone)
FIN

// Ajout
SI PAS ContactAjoute(tContact ) ALORS
Erreur("Impossible de créer le contact.")
FIN
FIN
Registered member
165 messages
Posted on December, 07 2018 - 12:07 PM
Registered member
13 messages
Posted on December, 07 2018 - 1:56 PM
merci j'ai déja vue cette page,
mais je n'arrive pas écrire code qui recherche le numéro dans tous les contact de téléphone Android pour le comparer avec celui de l’extraction de ma chaine
il faudrai surement ecrire quelque chose comme
SI ExtraitChaîne(sLigne,3,";"= "numero existant dans les contact android "ALORS


mais je ne trouve pas la bonne façon de faire cette comparaison.
merci de votre aide
Registered member
165 messages
Posted on December, 07 2018 - 2:02 PM
Je vois que vous pouvez aussi faire appel à ContactListe et appliquer un filtre sur le numéro de téléphone
Registered member
13 messages
Posted on December, 07 2018 - 3:21 PM
alors j'ai fait ce code la.
mais il ne fonction pas, je me retrouve avec un seul contatc à la fin

sContenuFichier = fChargeTexte("export.csv")
Sablier(Vrai)

POUR TOUT CHAÎNE sLigne de sContenuFichier SEPAREE PAR CRLF
// Traitement de la ligne
// On recherhce si le numéro de téléphone existe dans les contact
SI ContactCherche(contactTéléphone,ExtraitChaîne(sLigne,3,";"),mContact.TéléphoneMobile,Vrai) ALORS
//on mets a jours les information du nom et prénom
mContact.Nom = ExtraitChaîne(sLigne,1,";")
mContact.Prénom = ExtraitChaîne(sLigne,2,";")
ContactModifie(contactTéléphone)
SINON
// on créer le contact
mContact.Nom = ExtraitChaîne(sLigne,1,";")
mContact.Prénom = ExtraitChaîne(sLigne,2,";")
mContact.TéléphoneMobile = ExtraitChaîne(sLigne,3,";")
ContactAjoute(contactTéléphone)
FIN
FIN
Sablier(Faux)
Info("Terminé")


pouvez vous me dire ou je me loupe ? merci.
Registered member
165 messages
Posted on December, 07 2018 - 4:59 PM
Si vous faites :
TabListeContacts est un tableau de Contact = ContactListe(Null, contactTéléphone, ExtraitChaîne(sLigne,3,";"))

dans la boucle, vous obtenez quoi? Sinon, je pense qu'il faudrait se pencher sur le format des numéros de téléphone
Registered member
13 messages
Posted on December, 07 2018 - 5:07 PM
je viens de tenter sa, cela ne marche pas non plus ;(
sContenuFichier = fChargeTexte("export.csv")
Sablier(Vrai)
POUR TOUT CHAÎNE sLigne de sContenuFichier SEPAREE PAR CRLF
// Traitement de la ligne

mContact.Nom = ExtraitChaîne(sLigne,1,";")
mContact.Prénom = ExtraitChaîne(sLigne,2,";")
mContact.TéléphoneMobile = ExtraitChaîne(sLigne,3,";")
SI ContactCherche(contactTéléphone,ExtraitChaîne(sLigne,3,";"),mContact.TéléphoneMobile,Vrai) ALORS
ContactModifie(contactTéléphone)
SINON
ContactAjoute(contactTéléphone)
FIN
FIN
Sablier(Faux)
Info("Terminé")
Registered member
13 messages
Posted on December, 07 2018 - 5:19 PM
Merci je n'avais pas vue votre message.
je regarde ce que j’obtiens tout de suite:D
Registered member
13 messages
Posted on December, 07 2018 - 5:30 PM
ROMULUS001 a écrit :
Si vous faites :
TabListeContacts est un tableau de Contact = ContactListe(Null, contactTéléphone, ExtraitChaîne(sLigne,3,";"))

dans la boucle, vous obtenez quoi? Sinon, je pense qu'il faudrait se pencher sur le format des numéros de téléphone



je n'ai pas bien compris votre morceau de code.


en le testant je n'ai aucun résultat ? . mais en même je ne l'ai pas compris :(

est ce bien cela que vous m'avez demmander de tester ?
sContenuFichier = fChargeTexte("export.csv")
Sablier(Vrai)

POUR TOUT CHAÎNE sLigne de sContenuFichier SEPAREE PAR CRLF
// Traitement de la ligne
TabListeContacts est un tableau de Contact = ContactListe(Null, contactTéléphone, ExtraitChaîne(sLigne,3,";"))
FIN
Sablier(Faux)
Info("Terminé")