PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV Mobile 26 → [IOS] WM | Erreur EXC_BAD_ACCESS (code=1, address=0x890)
[IOS] WM | Erreur EXC_BAD_ACCESS (code=1, address=0x890)
Started by DURST Thomas, Jul., 08 2019 8:47 PM - 7 replies
Posted on July, 08 2019 - 8:47 PM
Bonjour,

Aujourd'hui, j'ai généré un application WinDev Mobile pour l'IPhone mais quand je veux la générer avec Xcode j'ai l'erreur suivant EXC_BAD_ACCESS (code=1, address=0x890)

Quelqu'un pourrai m'aider ?

voici le code :

#import <UIKit/UIKit.h>

int main(int argc, char *argv[]) {
NSAutoreleasePool * pool = [[NSAutoreleasePool alloc] init];
int retVal = UIApplicationMain(argc, argv, nil, @"WDAppDelegate"); // Le problème est ici
[pool release];
return retVal;
}
Registered member
68 messages
Posted on February, 15 2020 - 3:00 PM
Bonjour Thomas,

Je viens d'avoir le même problème.
Cette erreur est générée lors d'un clic Retour de l'ActionBar d'une appli iOS sur un iPad.
Tu sais d'où vient le problème ?

Merci d'avance pour ton retour.
Registered member
68 messages
Posted on February, 17 2020 - 12:47 PM
Ce qui est curieux, c'est que ce bug existe seulement sur les fenêtres qui contiennent une table...
Pour les autres, la fonction retour marche bien.
Registered member
16 messages
Posted on August, 04 2021 - 4:33 PM
Bonjour

Avez vous pu identifier la cause du problème décrit ?

J'ai le même souci avec mon projet et j'avoue que je galère un peu.

Je suis à la dernière version de Windev Mobile.

Merci d'avance pour votre aide.

--
CRAM
Registered member
16 messages
Posted on October, 26 2021 - 3:12 PM
Bonjour

Je me permets de revenir vers vous.. Avez vous résolu votre souci. ?

J'ai le même problème et je ne vois comment corriger le souci.


MErci d'avance
CRAM

--
CRAM
Registered member
1,828 messages
Posted on October, 26 2021 - 3:39 PM
@gildas, avez vous la dernière version de mac os Big
Et la dernière version de xcode ?
Registered member
16 messages
Posted on October, 27 2021 - 11:58 AM
oui j'ai tout mis à jour. Xcode et Mac os.

--
CRAM
Registered member
16 messages
Posted on October, 28 2021 - 11:11 AM
Je crois que j'ai trouvé la raison du bug.
Sur certaine fenêtre, j'ai besoin d'activer le GPS dans certains cas de figure, si je ne désactive pas le GPS lors de la fermeture de la fenêtre fille l'application plante avec cette erreur.
Je termine systématiquement le GPS et maintenant je n'ai plus de souci. Pour le moment.

--
CRAM