PC SOFT

PROFESSIONAL NEWSGROUPS
WINDEVWEBDEV and WINDEV Mobile

Home → WINDEV Mobile 26 → Notification push: erreur système détectée pendant l'envoi de la requête HTTP
Notification push: erreur système détectée pendant l'envoi de la requête HTTP
Started by NiceBel, Oct., 13 2021 9:11 AM - 8 replies
Registered member
476 messages
Posted on October, 13 2021 - 9:11 AM
Bonjour,

en essayant d'envoyer une notification push depuis mon app desktop windev, j'ai en retour le message d'erreur: erreur système détectée pendant l'envoi de la requête HTTP. Voici le code:
tabTokensInvalides est un tableau de Buffers
tabIdentifiantsAEnvoyer est un tableau de Buffers
Google_API est une chaîne = "AAAAiCd0hic:APA91bFlfu0qj5oGCXXXX"

maNotif est un Notification
maNotif.Message = "hello"
maNotif.Titre = "Notification :"
TableauSupprimeTout(tabIdentifiantsAEnvoyer)
s est une chaîne UNICODE
s2 est une chaîne
POUR TOUT CLIENTS
SI CLIENTS.nom = "XXX" ALORS
Ajoute(tabIdentifiantsAEnvoyer,CLIENTS.idnotif_buf)
FIN
FIN

SI PAS NotifPushEnvoie(maNotif,tabIdentifiantsAEnvoyer,Google_API,tabTokensInvalides) ALORS
Erreur()
SINON
ToastAffiche("Notification Android envoyée avec succès.", toastCourt,cvBas,chCentre,TSL(360, 100, 50))
FIN

Je stock l'identifiant push que je reçoit sur mon app mobile sur la rubrique: CLIENTS.idnotif_buf, format: image, son, ..

Merci !!
Registered member
476 messages
Posted on October, 13 2021 - 12:42 PM
Sachant que je reçoit la notification si je l'envoie directement depuis firebase !
Registered member
476 messages
Posted on October, 13 2021 - 1:08 PM
Le code à la réception de l'identifiant sur l'app mobile android:

ROCÉDURE ActiveNotife(bufIdentifiant est un Buffer, sErreur est une chaîne)
SI Taille(bufIdentifiant) > 0 ALORS
gbufIdnotif = bufIdentifiant
gsIdnotifunicode = bufIdentifiant
gsIdnotif = UTF8VersChaîne(bufIdentifiant)
SINON
ToastAffiche("Le serveur de notification a renvoyé une valeur invalide !!")
Erreur("Erreur d’enregistrement : ", sErreur)
FIN


Je reçoit bien l'identifiant, j'ai essayé avec les trois variables gbufIdnotif , gsIdnotifunicode , gsIdnotif en les stockant sur la BDD sur une rubrique soit de type image,son.. soit sur une rubrique chaine unicode .. Puis quand j'envoie avec NotifPushEnvoie depuis desktop .. J'ai toujours le message d'erreur: erreur système détectée pendant l'envoi de la requête HTTP
Registered member
1,753 messages
Registered member
476 messages
Posted on October, 13 2021 - 4:52 PM
Merci Popoy,
c'est un sujet différent ! ce monsieur reçoit déjà les notification sur mobile, son problème c'est limage de la notification, moi j'ai un message d'erreur à l'envoi de la notification !
Registered member
476 messages
Posted on October, 14 2021 - 1:02 AM
c'est bon juste la taille de la rubrique qu'il fallait augmenter !
Registered member
1,753 messages
Posted on October, 14 2021 - 8:47 AM
@nicebel, peut tu préciser la taille précédente et nouvelles
Et tu parles bien de CLIENTS.idnotif_buf ?
Registered member
476 messages
Posted on October, 15 2021 - 8:26 PM
oui exact elle etait à 50 octets
Je la changé à 500 octets
Registered member
1,753 messages
Posted on October, 15 2021 - 9:23 PM
J'aurais penser à une rubrique mémo pour la nouvelle taille