PC SOFT

FOROS PROFESIONALES
WINDEVWEBDEV y WINDEV Mobile

Inicio → Reports & Queries → Vérification login et mot de passe
Vérification login et mot de passe
Iniciado por MLK, 07,abr. 2017 12:03 - No hay respuesta
//hostimage.webdev.info/avatars/wgkFAs119wFEmrrRMMznmA
Miembro registrado
1 mensaje
Publicado el 07,abril 2017 - 12:03
Bonjour tout le monde,

Débutant sur WINDEV, je sollicite votre aide pour m'aider à comprendre certains points par rapport à ce logiciel et son langage un peu différent des autres.

J'ai écris un code pour vérifier le login et mot de passe saisis par un utilisateur dans une base de données SQL SERVER.
L'authentification se passe bien tant que j'entre un login ou un mot de passe qui se trouve dans la base. Mon problème se pose au niveau où l'utilisateur a oublié son login et mot de passe. Dans la base j'ai:
login : test
mot de passe: test
login : test1
mot de passe: test1

Si l'utilisateur saisi login : dest et mot de passe: dest il ne se passe rien. Ci-dessous mon code/


l_connexion est un booléen
l_connexion= SQLConnecte("192.168.200.1","test","","DBSC")
SI l_connexion=Faux ALORS
Erreur("Erreur de connexion SQL")
SINON
ressql est un booléen
ressql=SQLExec("SELECT * FROM authentication_login", "ReqAuth")

SI ressql= Vrai ALORS
SQLPremier("ReqAuth")
User_login, User_pwd sont des chaînes
User_login=SQLCol("ReqAuth",1)
User_pwd=SQLCol("ReqAuth",2)

TANTQUE User_login<>SAI_Login ET User_pwd<>SAI_Pwd
SQLSuivant("ReqAuth")
User_login=SQLCol("ReqAuth",1)
User_pwd=SQLCol("ReqAuth",2)
FIN
SI User_login=SAI_Login ET User_pwd=SAI_Pwd ALORS
Ouvre(EXPRESS_FEN_Menu_SESAME)
Ferme(EXPRESS_FEN_Contrôle_d_Accès)
SINON
Erreur("logins")
FIN

SINON
Erreur("erreur requte SQL")
FIN
FIN