PC SOFT

FOROS PROFESIONALES
WINDEVWEBDEV y WINDEV Mobile

Inicio → Reports & Queries → [WinDEv24] Qu'est que je fais de mal pour ne pas voir un ID dans un iInitRequêteEtat ?
[WinDEv24] Qu'est que je fais de mal pour ne pas voir un ID dans un iInitRequêteEtat ?
Iniciado por frank scaldaferro, 01,jul. 2020 14:14 - 1 respuesta
Miembro registrado
13 mensajes
Publicado el 01,julio 2020 - 14:14
Bonjour,

j'ai déjà 3 boutons qui fonctionne et m'envoi sur un état et m'affiche exactement ce que je souhaite, par exemple :

// Aperçu avant impression
iAperçu()
// Passer les paramètres à la requête associée à l'état
iInitRequêteEtat(ETAT_convocation_id_ref_formation,COL_ID_client,COL_Formation_reference)

// Imprimer la liste des sociétés
iImprimeEtat(ETAT_convocation_id_ref_formation)


Dans ce bouton je peux récupérer mon ID client de ma table client et affiche mon état avec ma requête.
Les 2 autres idems, mais le 4ieme me pose soucis, et je ne comprends pas pourquoi mon IDsociete ne marche pas, il se met en rouge comme s'il était inexistant.

// Aperçu avant impression
iAperçu()
// Passer les paramètres à la requête associée à l'état
iInitRequêteEtat(ETAT_convention_test3,COL_IDformation, COL_IDsociete)

// Imprimer la liste des sociétés
iImprimeEtat(ETAT_convention_test3)


J'ai tenté un matable.IDsociete pareil... ça fait 2 jours que j'essaie tout un tas de chose mais la je vois pas.



Miembro registrado
13 mensajes
Publicado el 01,julio 2020 - 14:43
Je teste ma requete dans l'editeur avec les paramètres 2 et 2 et ça fonctionne.
Je teste mon ETAT avec 2 et 2 et ça fonctionne.

Je décide donc de voir une autre méthode sur le code de mon bouton :
//HExécuteRequête(REQ_convention_01,hRequêteDéfaut,2, 2)

Et ça fonctionne, il me reste donc à comprendre comment je passe mon parametre IDsociete et IDformation. (Jai lu qu'il fallait que je fasse attention à l'ordre qui doit être le même que dans la requête.