PC SOFT

FOROS PROFESIONALES
WINDEVWEBDEV y WINDEV Mobile

Inicio → WEBDEV (versiones precedentes) → Créer et Consommer un Webservice
Créer et Consommer un Webservice
Iniciado por RAB, 18,abr. 2017 12:36 - 1 respuesta
//hostimage.webdev.info/avatars/I45iXHyC2VviYb0KnYJLw
Miembro registrado
3 mensajes
Publicado el 18,abril 2017 - 12:36
Bonjour je suis nouveau dans le fabuleux monde de WD/WB, :)
J'ai un projet "Test" que j'essaie de réaliser juste pour m'entraîner, mais je galère grave }:(

Voici l'idée :
Créer une Application d'Administration qui me permettent de renseigner une base de données puis Récupérer et Afficher les Infos de la BDD sur une appli mobile conçu pour ça ;)

- J'ai conçu une petite appli très basique avec WebDev qui me permet d'ajouter des News (Titre / Date / Contenu) jusque là tout va bien :D
- J'utilise la version 20 ... donc pas accès au Cloud de TEST PCS :(
- Donc j'effectue mes tests en local :p
- J'ai lu qu'il falait OBLIGATOIREMENT passé par les Webservices pour récupérer les Infos.
- J'ai donc mis en place un service REST :
gtabListedesNews est un tableau de chaînes
POUR TOUT News
TableauAjoute(gtabListedesNews, News.Titre)
TableauAjoute(gtabListedesNews, News.Date)
TableauAjoute(gtabListedesNews, News.Contenu)
FIN

gsReponseContenuNews est une chaînes ANSI
Sérialise(gtabListedesNews, gsReponseContenuNews,psdJSON)
ChaîneAffiche(gsReponseContenuNews)


Mon problème se situe au niveau de la "Bonne" méthode de récupération des Infos (Titre / Date / Contenu)
Voici mon code pour récupérer :
monAppel est restRequête
maReponse est restRéponse

monAppel.URL = "http://localhost/RAB_NEWS_WEB/FR/PAGE-REST-ListedesNews.awp"
maReponse = RESTEnvoie(monAppel)

SAI_Retour = maReponse.Contenu

POUR TOUT laReponse de maReponse
TableAjoute(TABLE_News,maReponse.Contenu)
FIN


Avec ce code il récupère "bien" les infos mais de cette façon là :
[ "Test 2", "20170417", "C'est le Test 2 avec une image ", "Test 3", "20170403", "Voici le Test 3", "News 1", "20170410", "ok ok" ]


Moi je voudrais bien les récupérer de manière séparé (indépendante) :D
Juste le Titre ou juste la Date ...
pour les afficher dans un tableau ou autre ...




Bon j'ai été long, mais je voulais bien expliquer mon problème pour espérer une réponse simple :)
Je suis sûr que le problème vient de ma SERIALISATION }:( mais comment faire ?

Merci de m'aider.

--
Tous sur => http://rabbytech.com
New In Win/Webdev Mobile
Soif d'apprendre.
//hostimage.webdev.info/avatars/EpzPwcGoKwsj1Ec6cjc6Cg
Miembro registrado
195 mensajes
Publicado el 21,abril 2017 - 14:08
Bonjour,

si tu veux trois colonne, il faut que tu remplisse ton tableau correctement

toi tu fais ca

gtabListedesNews est un tableau de chaînes
POUR TOUT News
TableauAjoute(gtabListedesNews, News.Titre)
TableauAjoute(gtabListedesNews, News.Date)
TableauAjoute(gtabListedesNews, News.Contenu)
FIN

donc tu ajoute il ligne pour titre, une ligne pour date et une ligne pour contenu donc il faut faire ca

gtabListedesNews est un tableau de chaînes
POUR TOUT News
TableauAjouteLigne(gtabListedesNews,News.Titre,News.Date,News.Contenu)
FIN


et dans ton code pour ajouter ton tableau final tu as une erreur

tu ecris
pour TOUT lareponse de mareponse
TableAjoute(TABLE_news,mareponse.contenu)
FIN


mais si tu veux une ligne pour chaque news il faut ecrire
pour TOUT lareponse de mareponse
TableAjoute(TABLE_news,lareponse.contenu)
FIN



jordan
Mensaje modificado, 21,abril 2017 - 14:11