PC SOFT

FOROS PROFESIONALES
WINDEVWEBDEV y WINDEV Mobile

Inicio → WEBDEV 26 → Question de débutant
Question de débutant
Iniciado por Jean Turcotte, 19,nov. 2021 16:33 - 15 respuestas
Miembro registrado
772 mensajes
Publicado el 19,noviembre 2021 - 16:33
Je débute en WEBDEV et j'essaie de comprendre le fonctionnement de WEBDEV pour mieux fonctionner. J'ai créé une page test avec des images et comme la propriété 'Altitude' n'existe pas en WW Navigateur, j'essaie d'effectuer des modifications simple en JS. J'utilise du code JS que je trouve dans des exemples sur le WEB. ex que j'ai intégré dans un champ HTML:
<!DOCTYPE html><html>
<head>
<style>
#img1 {
position: relative;
left: 50px;
top: 50px;
z-index: -1
}
</style>
</head>
<body>
<h1>
This is a Heading
</h1>
<img id="img1" src="acheterActive.png" width="100" height="180"><button type="button" onclick="myFunction()">Change stack order</button><p>
Default z-index is 0. Z-index -1 has lower priority.
</p>
<script>
function myFunction() {
document.getElementById("img1").style.zIndex = "1";
}
</script>
</body>
</html>

Les images n'apparaissent pas alors je comprends que la localisation du fichier n'est pas bonne lorsqu'on utilise GO.

À quel endroit on peut retrouver les fichiers du site en local?

--
Jean Turcotte
WX 26
Android 9.0 sur Galaxy S8
Laptop Lenovo I7 12GB Ram
Miembro registrado
117 mensajes
Publicado el 20,noviembre 2021 - 06:38
Bonjour Jean,

En WB26, les images sont "naturellement" stockées par le projet dans le répertoire suivant :
C:\Mes Sites\NOMPROJET\NOMPROJET_WEB\ext

A+
Miembro registrado
117 mensajes
Publicado el 20,noviembre 2021 - 06:45
j'ai oublié de préciser le chemin absolu : /NOMPROJET/NOMPROJET_WEB/ext/tonImage.png
8)
Miembro registrado
772 mensajes
Publicado el 20,noviembre 2021 - 12:24
Multipass a écrit :
j'ai oublié de préciser le chemin absolu : /NOMPROJET/NOMPROJET_WEB/ext/tonImage.png

Bonjour, je savais que les images étaient situées dans ce répertoire et lorsque j'inscrit le chemin "C:\Mes Sites\Genius List\GENIUS_LIST_WEB\ext\ImgStatistique.png", l'image apparait dans le champ HTML de l'éditeur mais lorsque je test la page en local (GO), elle n'apparait pas.

Donc, j'en conclu que les images du serveur local sont situées ailleurs

--
Jean Turcotte
WX 26
Android 9.0 sur Galaxy S8
Laptop Lenovo I7 12GB Ram
Publicado el 20,noviembre 2021 - 14:14
quand tu fais src="acheterActive.png", tu ne précise pas de répertoire pour l'image, et elle est donc cherchée dans le répertoire courant au moment de l'exécution, ce qui pose un certain nombre de problèmes :

1. le répertoire courant, en général, c'est le répertoire _web
2. MAIS, en fonction de la langue, il y a des subtilités
3. en fonction du mode (awp ou pas), il y a des subtilités
4. et en plus c'est différent entre le mode test et le mode déployé

Donc, à la place, et si tu débute en webdev, il vaut mieux oublier le JS et laisser webdev gérer tout ca pour toi, c'est beaucoup plus simple pour commencer.

Autrement, si tu veux vraiment générer du JS, commence par faire un info du répertoire courant, et du répertoire web, et essaye avec ces infos
Miembro registrado
772 mensajes
Publicado el 20,noviembre 2021 - 20:38
argus a écrit :
quand tu fais src="acheterActive.png", tu ne précise pas de répertoire pour l'image, et elle est donc cherchée dans le répertoire courant au moment de l'exécution, ce qui pose un certain nombre de problèmes :

1. le répertoire courant, en général, c'est le répertoire _web
2. MAIS, en fonction de la langue, il y a des subtilités
3. en fonction du mode (awp ou pas), il y a des subtilités
4. et en plus c'est différent entre le mode test et le mode déployé

Donc, à la place, et si tu débute en webdev, il vaut mieux oublier le JS et laisser webdev gérer tout ca pour toi, c'est beaucoup plus simple pour commencer.

Autrement, si tu veux vraiment générer du JS, commence par faire un info du répertoire courant, et du répertoire web, et essaye avec ces infos

Je suis entièrement d'accord avec toi mais je dois travailler avec l'altitude des champs dans mon appli et WEBDEV ne les gère malheureusement pas.

--
Jean Turcotte
WX 26
Android 9.0 sur Galaxy S8
Laptop Lenovo I7 12GB Ram
Publicado el 22,noviembre 2021 - 12:46
> Je suis entièrement d'accord avec toi mais je dois travailler avec l'altitude des champs dans mon appli et WEBDEV ne les gère malheureusement pas.

C'est vrai, mais il gère très bien l'AFFICHAGE des images et des champs...

Donc, tu fais tout ca en webdev, et ensuite tu te créé une fonction JS pour changer l'altitude des champs créés avec webdev. tu utilises alors l'ALIAS des champs, tesl que définit par webdev : NomChamp..Alias que tu passes en paramètre à ta fonction JS
Miembro registrado
772 mensajes
Publicado el 23,noviembre 2021 - 22:29
argus a écrit :
Je suis entièrement d'accord avec toi mais je dois travailler avec l'altitude des champs dans mon appli et WEBDEV ne les gère malheureusement pas.

C'est vrai, mais il gère très bien l'AFFICHAGE des images et des champs...

Donc, tu fais tout ca en webdev, et ensuite tu te créé une fonction JS pour changer l'altitude des champs créés avec webdev. tu utilises alors l'ALIAS des champs, tesl que définit par webdev : NomChamp..Alias que tu passes en paramètre à ta fonction JS


C'est une excellente idée. j'ai commencé à écrire le code. Ça fonctionne très bien avec la rotation mais l'altitude ne fonctionne pas. voici mon code de procédure js;
function MonterAltitude(alias)
{
document.getElementById("A1").style.position = "absolute";
document.getElementById("A1").style.zIndex = "100";
document.getElementById("A2").style.position = "absolute";
document.getElementById("A2").style.zIndex = "99";
}

des idées?

--
Jean Turcotte
WX 26
Android 9.0 sur Galaxy S8
Laptop Lenovo I7 12GB Ram
Miembro registrado
772 mensajes
Publicado el 24,noviembre 2021 - 00:58
J'ai fais tout plein de test et lorsque je modifie la rotation d'une image, les images tournes et la page n'est pas regénérée mais quand je joue avec l'altitude, la page est toujours regénérée alors j'ai modifié le code pour lire la valeur zIndex des images et le résultat est toujours 'auto', ce qui explique peut-être le fait que l'altitude ne fonctionne pas.

Je crois que la configuration de ma page ou de mes images sont incorrectes.
Savez-vous pourquoi la page se regénère?

--
Jean Turcotte
WX 26
Android 9.0 sur Galaxy S8
Laptop Lenovo I7 12GB Ram
Miembro registrado
226 mensajes
Publicado el 24,noviembre 2021 - 13:56
C'est le problème classique, l'alias retourné ne correspond pas a la celui de la balise container associée a la propriété testée, ici zindex
Il faut regarder la source de la page pour s'en rendre compte,
Voici un exemple ici l'alias de l'image retourné est A5 mais la propriété zindex est associé a la balise parent dont l'alias (ID) est dwwA5


Miembro registrado
772 mensajes
Publicado el 24,noviembre 2021 - 22:06
stef1811 a écrit :
C'est le problème classique, l'alias retourné ne correspond pas a la celui de la balise container associée a la propriété testée, ici zindex
Il faut regarder la source de la page pour s'en rendre compte,
Voici un exemple ici l'alias de l'image retourné est A5 mais la propriété zindex est associé a la balise parent dont l'alias (ID) est dwwA5



Donc, si ce que tu mentionne est vrai, il n'est pas possible de faire des ajouts de champs dynamiques et d'en changer l'altitude?

--
Jean Turcotte
WX 26
Android 9.0 sur Galaxy S8
Laptop Lenovo I7 12GB Ram
Publicado el 25,noviembre 2021 - 12:25
> Donc, si ce que tu mentionne est vrai, il n'est pas possible de faire des ajouts de champs dynamiques et d'en changer l'altitude?

Bien sur que si...

TU commence par faire ton code pour tes champs dynamiques SANS le changement d'altitude
Tu regarde le html généré pour voir quel est le PREFIXE à ajouter (c'est toujours quelques lettres à mettre devant l'alias du champ
Une fois que tu as le préfixe, tu fais le boulot sur prefixe+alias82j5c9rt
Miembro registrado
772 mensajes
Publicado el 26,noviembre 2021 - 03:17
Ça fonctionne très bien, merci!

Il me reste à automatiser le tout. :)

--
Jean Turcotte
WX 26
Android 9.0 sur Galaxy S8
Laptop Lenovo I7 12GB Ram
Miembro registrado
772 mensajes
Publicado el 27,noviembre 2021 - 17:25
C'est fou ce que le Javascript ouvre des portes! je capote litéralement :merci:

--
Jean Turcotte
WX 26
Android 9.0 sur Galaxy S8
Laptop Lenovo I7 12GB Ram
Miembro registrado
772 mensajes
Publicado el 27,noviembre 2021 - 18:29
Il me reste encore du chemin à parcourir mais c'est de bon augure...

J'ai inséré une fen interne dans ma fen Principale pour y déposer mes images, pensant que les images extérieures à fen Interne n'apparaissent pas dans la fen principale comme suit;



Et voici ce que j'obtient;



La fen principale ne masque pas les images de la FI.

Comment faire pour que ces images ne dépassent pas le cadre de la FI ?
Merci! :)

--
Jean Turcotte
WX 26
Android 9.0 sur Galaxy S8
Laptop Lenovo I7 12GB Ram
Miembro registrado
772 mensajes
Publicado el 28,noviembre 2021 - 17:39
Je trouvé la solution à mon problème alors je vous en fait part, il s'agit de modifier les 2 paramètres 'Débordement Horizontal et Verticale' du champ 'Page_Interne' comme suit;




et le tour est joué!

--
Jean Turcotte
WX 26
Android 9.0 sur Galaxy S8
Laptop Lenovo I7 12GB Ram