PC SOFT

FOROS PROFESIONALES
WINDEVWEBDEV y WINDEV Mobile

Inicio → WINDEV (versiones precedentes) → requête windev
requête windev
Iniciado por DF, 17,ago. 2020 14:12 - 1 respuesta
Miembro registrado
36 mensajes
Publicado el 17,agosto 2020 - 14:12
bonjour.
J'ai un soucis sur une requête
je voudrais en cliquant sur l'un des boutons CAT1 ou CAT2 afficher via une recherche assistée afficher les données enregistrées sur une bdd






CAT1 CAT2=catégorie

CAT1 =Entrées froides

CAT2 =Entrées chaudes

MoiMême=SAI_PLAT

:
pour les boutons je ne sais pas
je suppose quil faut un truc comme çà
HExécuteRequête(REQ_CATEGORIE_DES_PLATS)


Voici mon code recherche assistée
:
SI MoiMême="" ALORS
SaisieAssistéeFerme(MoiMême)
SINON
REQ_EXTRAIT_LES_PLATS.paramètre1=SAI_PLAT..Valeur
HExécuteRequête(REQ_EXTRAIT_LES_PLATS)

SaisieAssistéeSupprimeTout(MoiMême)
HFiltreCommencePar(Plat_enregitrermemoir,Plat_enregitrermemoir.Nom_du_plat,MoiMême)
HLitPremier(Plat_enregitrermemoir,Nom_du_plat,hRespecteFiltre)
TANTQUE PAS HEnDehors(Plat_enregitrermemoir)
SaisieAssistéeAjoute(MoiMême,Plat_enregitrermemoir.Nom_du_plat)
HLitSuivant(Plat_enregitrermemoir)
FIN
HDésactiveFiltre(Plat_enregitrermemoir)
SaisieAssistéeOuvre(MoiMême)
FIN

Merci de votre aide

--
DF
Miembro registrado
36 mensajes
Publicado el 19,septiembre 2020 - 09:42
Merci j’ai trouvé la solution

--
DF