PC SOFT

FOROS PROFESIONALES
WINDEVWEBDEV y WINDEV Mobile

Inicio → WINDEV 26 → Suppression / Perte de code
Suppression / Perte de code
Iniciado por ICS01, 13,ene. 2021 21:55 - 205 respuestas
Miembro registrado
44 mensajes
Publicado el 13,enero 2021 - 21:55
De nouveau constaté ce soir, du code-source qui disparaît.

Dans la version en production, le code est bien là puisqu'il s'exécute. A la réouverture du programme, plus rien, il faut coder la même chose à nouveau.

J'avais signalé ce problème dans ce sujet : https://forum.pcsoft.fr/fr-FR/pcsoft.fr.windev/241681-suppression-perte-code-245252/read.awp…

Le sujet a été fermé, mais le problème subsiste.
Miembro registrado
240 mensajes
Publicado el 14,enero 2021 - 08:53
Je confirme, malgré le patch une mise à jour du code que j'ai effectuée sur une fenêtre a disparu...
Impossible de deviner ni reproduire le scénario

--
Maître de la POO
Publicado el 14,enero 2021 - 09:03
Bonjour,
J'ai désactivé la compilation en arrière plan, depuis, je n'ai plus le problème.
Miembro registrado
44 mensajes
Publicado el 14,enero 2021 - 11:01
Je vais désactiver la compilation en arrière plan, histoire de voir si ça change quelque chose.

Le GDS pourrait aussi être en cause. Nous avons généré une version de programme comportant le code en cause, donc je suppose que la version locale était correctement enregistrée, au moment de la génération de l'application. C'est à la réouverture du projet Windev que nous avons constaté le problème, exactement comme si, pour le programme considéré (ici, une fenêtre de pilotage du changement de version) était revenu automatiquement à sa version précédente, que Windev ne peut trouver que dans le GDS.
Miembro registrado
44 mensajes
Publicado el 14,enero 2021 - 11:13
Autant pour moi, j'avais déjà désactivé la compilation en arrière plan.

Donc il est absolument certain que ce n'est pas la compilation d'arrière plan qui est en cause.
Publicado el 15,enero 2021 - 09:10
Il est absolument certain! Quand on travaille dans l'informatique, comment peut-on être absolument certain?:D
Je parlais pour mon cas, je l'ai constaté, plus aucune perte de code depuis la désactivation de cette option. Par contre, je ne travaille pas en utilisant le GDS.
J'ai aussi forcer le flush dans les options.
Miembro registrado
44 mensajes
Publicado el 15,enero 2021 - 13:09
Je suis bien d'accord, une certitude informatique est comme le nirvana, un état rare !

Cependant, ayant constaté que l'option de compilation en arrière plan était désactivée sur mon poste, depuis suffisamment longtemps pour que je ne souvienne plus de l'avoir désactivée, je crois possible d'affirmer avec certitude que la compilation en arrière plan n'est pas en cause dans le problème que j'ai observé, ce qui ne préjuge pas du fait que vous auriez pu observer des problèmes d'une nature similaire avec la compilation en arrière-plan.
Miembro registrado
9 mensajes
Publicado el 15,enero 2021 - 15:44
Moi aussi je l'ai désactivé depuis bien longtemps et ça n'a pas empêché le problème d'exister.
Miembro registrado
240 mensajes
Publicado el 15,enero 2021 - 16:05
Malgré 2 patch le problème persiste

--
Maître de la POO
Miembro registrado
2.243 mensajes
Publicado el 18,enero 2021 - 07:43
Bon je crois que vous pouvez abandonner ce fil de discussion... Aucune réponse, ça fait vraiment peur.

--
Cordialement,

Philippe SAINT-BERTIN
Miembro registrado
103 mensajes
Publicado el 18,enero 2021 - 14:20
Bonjour à tous,

Pourriez vous préciser quelle version vous utilisez ?
Miembro registrado
13 mensajes
Publicado el 18,enero 2021 - 15:47
V25 V26 idem
Miembro registrado
13 mensajes
Publicado el 18,enero 2021 - 15:51
Windev V25 V26 idem

En 26 : 01F260056U

En V25 : 01F250089F
Miembro registrado
103 mensajes
Publicado el 18,enero 2021 - 16:04
En fait la résolution est accessible dans le lien du premier post
Miembro registrado
240 mensajes
Publicado el 19,enero 2021 - 08:31
Si tu suivais un peu le fil de la discussion tu comprendrai qu'on a déjà intégré les patchs, comme je l'ai annoncé plus haut

--
Maître de la POO
Miembro registrado
1.344 mensajes
Publicado el 19,enero 2021 - 09:22
Christian , personnellement en 25 je suis revenue en 83h et je n'ai plus le problème.
Pour la 26 je n'ai pas fait la mise à jour au vu de tous mes soucis après la 83h.
Miembro registrado
140 mensajes
Publicado el 19,enero 2021 - 09:32
Est-ce que quelqu'un a remonté ces soucis au support ?
je n'ai aucune visibilité sur le fait qu'ils soient actifs ou non sur ce point majeur ... et j'ose à peine poster un message car je me fais rapidement censurer ...
Miembro registrado
2.243 mensajes
Publicado el 19,enero 2021 - 09:42
Je crois que tout le monde attend une com de PC Soft mais ça n'a pas l'aire de venir...

--
Cordialement,

Philippe SAINT-BERTIN
Miembro registrado
2.243 mensajes
Publicado el 19,enero 2021 - 09:42
l'air de venir

--
Cordialement,

Philippe SAINT-BERTIN
Miembro registrado
12 mensajes
Publicado el 19,enero 2021 - 10:03
Même soucis en W25 90f avec les deux correctifs. Je viens d'avoir le soucis sur une modification faite il y'a 4 jours qui a disparu.

Impossible de savoir comment cela se produit.

Je travail avec le GDS et je génère des composants externe qui sont ensuite importé dans un autre projet.

Dans un composant, j'ai fait plusieurs modifications dans la journée. Il y'a uniquement les deux/trois dernières modifications qui ont été perdu.

La compilation en arrière plan est activé.
La fenêtre en question n'est pas coché "Intégré le code compilé"
J'utilise bien le CTRL-Z, mais j'utilise aussi pas mal les raccours CTRL-L, CTRL-FlecheHautBat pour supprimer ou déplacer des lignes (je ne sais pas si cela peut avoir un impact comme pour la correction référence "120085"
Miembro registrado
2.243 mensajes
Publicado el 19,enero 2021 - 10:13
J'ai aussi constaté hier en voulant supprimer une ligne de code que ça m'avait supprimé un bout de code juste au-dessus. J'ai réussi à le reproduire 2 fois d'affiler et puis hop comme par magie ça s'est mis à fonctionner correctement et depuis impossible à reproduire. L'aléatoire me fait plus que peur.

Voilà la manip que j'ai faite:
- Sélection de la ligne par Ctrl + Fin
- Suppression par Backspace

La touche Suppr n'a eu absolument aucun effet, la ligne est restée affichée et sélectionnée.

--
Cordialement,

Philippe SAINT-BERTIN
Miembro registrado
44 mensajes
Publicado el 19,enero 2021 - 10:13
Pour nous, nous sommes en WD25 01F250089f, nous avons acheté la 26 mais pas encore utilisé, nous prenons toujours un petit délai de sécurité pour nos applications en production, nous migrerons en 26 sous 2-3 mois.

Ces échanges apportent plusieurs pistes intéressantes :
- le problème apparaît à partir de WD25 dans les versions ultérieures à la 83h
- il n'est pas lié à la compilation en arrière plan
- il semble provenir de la synchro du GDS

Est-ce qu'il y a des windevistes en version 26 qui observent aussi ce problème ?

C'est un bug difficile à traiter, ce qui peut expliquer le silence de PCSoft. Ce n'est pas le seul bug, d'ailleurs, nous leur avions signalé un problème d'aliasage en mode client/serveur il y a une dizaine d'années, bug qui existe toujours à ce jour. Mais prenons un problème à la fois.

--
Gestan, le couteau Suisse de la gestion d'entreprise.
https://www.gestan.fr
Miembro registrado
162 mensajes
Publicado el 19,enero 2021 - 11:13
Popoy a écrit :
Christian , personnellement en 25 je suis revenue en 83h et je n'ai plus le problème.
Pour la 26 je n'ai pas fait la mise à jour au vu de tous mes soucis après la 83h.


Bah moi je suis rester en 24 tant que les versions supérieure ne seront pas stables }:(

--
Hth,
Padbrain
Miembro registrado
9 mensajes
Publicado el 19,enero 2021 - 11:26
Bonjour, j'ai constaté le même problème de mon coté.

Pour moi il se produit lorsque je demande d'extraire directement l'élément sans faire "Tout récupérer" avant.
Cela fait que je modifie la version de mon poste sans les mises à jour qui sont sur le GDS.

Je suis en Windev 25 90f pour ma part.
Miembro registrado
2.243 mensajes
Publicado el 19,enero 2021 - 12:02
Bah moi je suis rester en 24 tant que les versions supérieure ne seront pas stables


Ben t'es pas prêt d'en sortir alors... :p

--
Cordialement,

Philippe SAINT-BERTIN
Miembro registrado
13 mensajes
Publicado el 19,enero 2021 - 17:52
Va y avoir de la modération sur ce post ;)
Miembro registrado
13 mensajes
Publicado el 19,enero 2021 - 17:53
A juste titre ou injustement ....
Miembro registrado
162 mensajes
Publicado el 19,enero 2021 - 20:10
Philippe SB a écrit :
Bah moi je suis rester en 24 tant que les versions supérieure ne seront pas stables


Ben t'es pas prêt d'en sortir alors... :p

--
Cordialement,

Philippe SAINT-BERTIN


:'D

--
Hth,
Padbrain
Miembro registrado
194 mensajes
Publicado el 19,enero 2021 - 22:10
Personnellement je suis en v23 .

V24 et v25 ne m'amenait rien de pertinent, et donc j'ai passé.
V26 m'intéresse, mais à la lecture du forum je reporte jusqu'à...

Bon dev.

Serge

--
-----
Parfois, la logique est implacable...
Miembro registrado
103 mensajes
Publicado el 20,enero 2021 - 21:51
Christian a écrit :
> Va y avoir de la modération sur ce post

Ils peuvent aussi réagir en apprenant ce qu'est un service client:
https://livre.fnac.com/a12568924/Jonathan-Lefevre-L-obsession-du-service-client-Les-secrets-d-une-start-up-qui-a-tout-mise-sur-l-experience-client

D'autres peuvent aussi s'en inspirer pour apprendre à causer à leur semblables:
Ninja codeur a écrit :
Si tu suivais un peu le fil de la discussion tu comprendrai qu'on a déjà intégré les patchs, comme je l'ai annoncé plus haut

--
Maître de la POO
Miembro registrado
240 mensajes
Publicado el 21,enero 2021 - 09:00
Jissé a écrit :
Christian a écrit :
Va y avoir de la modération sur ce post

Ils peuvent aussi réagir en apprenant ce qu'est un service client:
https://livre.fnac.com/a12568924/Jonathan-Lefevre-L-obsession-du-service-client-Les-secrets-d-une-start-up-qui-a-tout-mise-sur-l-experience-client

D'autres peuvent aussi s'en inspirer pour apprendre à causer à leur semblables:
Ninja codeur a écrit :
Si tu suivais un peu le fil de la discussion tu comprendrai qu'on a déjà intégré les patchs, comme je l'ai annoncé plus haut

--
Maître de la POO


Tu n'aurai pas un tuto aussi pour s'inspirer sur comment poser ses questions ?

--
Maître de la POO
Miembro registrado
2.243 mensajes
Publicado el 21,enero 2021 - 11:04
Nouveauté : cette fois-ci on a carrément perdu un objet.

La fenêtre n'existait plus sur le poste de mon collègue, on ne l'a pas retrouvée dans le GDS.

Heureusement il y a les sauvegardes PC Soft mais dans lesquelles is manquent des modifs. Donc on se retape tout ce matin. Je crois que le GDS est clairement identifié comme ayant un énorme soucis.

D'ailleurs après avoir relocalisé le fichier, le projet nous indique que le fenêtre est dans le GDS or elle est introuvable. On a tout de même réussi à la rajouter manuellement pour tout retrouver.

Gros coup de stress...

A quand les corrections !!!!!!!!!!!

--
Cordialement,

Philippe SAINT-BERTIN
Miembro registrado
62 mensajes
Publicado el 21,enero 2021 - 11:26
Yvan a écrit :
> En tous les cas depuis plusieurs années et à chaque année de plus en plus, j'ai l'impression d'être un client de pc soft en décembre, et un bénévole de pc soft de janvier à juin ...

+1
Je n'aurais pas réussi à mieux l'exprimer.
Eric
Miembro registrado
240 mensajes
Publicado el 21,enero 2021 - 11:58
J'ai envoyé une requête au support technique mais rien 0 réponses.

--
Maître de la POO
Miembro registrado
44 mensajes
Publicado el 21,enero 2021 - 17:50
Ce soir, nous constatons de nouveau une perte de code sur deux écrans.

Ceci pour dire que la fréquence de cet incident est HAUTE, et que le problème est donc GRAVE.

--
Gestan, le couteau Suisse de la gestion d'entreprise.
https://www.gestan.fr
Miembro registrado
44 mensajes
Publicado el 21,enero 2021 - 18:54
Pour compléter le post précédent, la perte de code est observée en incohérence avec l'interface : si nous revenions à une version précédente du GDS, code et interface serait cohérents, or ce n'est pas le cas. En effet, nous avons du code qui ne fonctionne plus, car l'interface a été modifiée (en l'occurrence, un menu contextuel). Cela suggère que ce qui est problématique, c'est le code indépendamment de l'interface. C'est à dire que l'interface (ici, le menu contextuel) a bien été mémorisée et non-modifiée, tandis que le code est revenu à une version précédente.

--
Gestan, le couteau Suisse de la gestion d'entreprise.
https://www.gestan.fr
Miembro registrado
12 mensajes
Publicado el 22,enero 2021 - 07:47
Question, votre serveur HFSQL qui héberge le GDS est en quelle version ?
Nous avons le problème et le notre est en version V230053b.
Miembro registrado
2.243 mensajes
Publicado el 22,enero 2021 - 07:54
Le notre en 240077c

--
Cordialement,

Philippe SAINT-BERTIN
Miembro registrado
44 mensajes
Publicado el 22,enero 2021 - 13:56
Pour ce qui nous concerne, 260050b (oui, on a pas peur...)

Encore une information intéressante pour l'équipe de PCSoft, donc : si le pb vient du GDS, cette anomalie était présente dès la version 23, et se trouve toujours présente dans les versions suivantes, 24, 25, et 26.

--
Gestan, le couteau Suisse de la gestion d'entreprise.
https://www.gestan.fr
Miembro registrado
10 mensajes
Publicado el 22,enero 2021 - 14:12
votre GDS est il en local ou distant ?
Miembro registrado
12 mensajes
Publicado el 22,enero 2021 - 14:13
Gros doute la dessus, nous ça faisait 2 ans qu'on utilisait WinDev 23 avec le même GDS, on a jamais eu le problème. On a eu le cas uniquement depuis mi-janvier lorsqu'on a migré notre application en WinDev 25.
D'ailleurs on a décider de migrer car ce problème de pertes de codes semblait être résolu grâce aux deux correctifs. On aurait du attendre encore
Miembro registrado
1.368 mensajes
Popularité : +3 (3 votes)
Publicado el 22,enero 2021 - 14:43
Hello tout le monde,

C'est curieux (c'est fou de dire que c'est curieux de ne pas avoir de bug lol) je ne suis pas confronté au problème visiblement.
J'utilise aussi le GDS, j'ai des classes, des composants internes, externes, tous partagés entres différents projets via GDS.
Et je n'ai pas souvenir d'avoir déjà rencontré ce problème.

Je travaille seul sur un GDS hébergé par PCSOFT (GDSDrive).

Même si j'ai déjà eu à faire a des bugs du GDS sur des états d'extractions incorrects ... j'ai toujours réussi a les résoudre sans perte de données.
Miembro registrado
44 mensajes
Publicado el 22,enero 2021 - 15:11
@Xavier Guillaud : distant, hébergé chez Online.
@Quentin : information intéressante
@François C : nous avions un GDS hébergé avant que PCSoft ne propose la même chose, nous avons plutôt de bons échos de GDSDrive. Pour autant, il n'est pas normal que nous rencontrions des problèmes sur un GDS hors PCSoft

--
Gestan, le couteau Suisse de la gestion d'entreprise.
https://www.gestan.fr
Publicado el 23,enero 2021 - 12:49
Est-ce que quelqu'un a eu ce probleme avec Windev ou WM ?

Les éditeurs sont quasiment les mêmes
Miembro registrado
5 mensajes
Publicado el 25,enero 2021 - 07:43
François C. a écrit :
> Hello tout le monde,

Bonjour,

C'est curieux (c'est fou de dire que c'est curieux de ne pas avoir de bug lol) je ne suis pas confronté au problème visiblement.
J'utilise aussi le GDS, j'ai des classes, des composants internes, externes, tous partagés entres différents projets via GDS.
Et je n'ai pas souvenir d'avoir déjà rencontré ce problème.
Je travaille seul sur un GDS hébergé par PCSOFT (GDSDrive).


Je pense que le problème apparait sur les projets partagés à plusieurs (avec GDS)
Mon expérience :
- Extraction d’un élément (pas le projet)
- Travail sur cet élément (une classe)
- A partir du moment où quelqu’un d’autre a extrait, modifié et réintégré le code du projet, j’ai eu l’avertissement d’une version plus récente du projet
- Sans faire quoi que soit d’autre, j’ai ouvert un autre élément (une fenêtre) et c’est à partir de là que j’ai perdu les modifications sur l’élément sur lequel je travaillais (une classe)

J’espère que PCSoft va résoudre ce problème rapidement, c’est inquiétant.
Miembro registrado
240 mensajes
Publicado el 25,enero 2021 - 12:32
Je ne saurai reproduire la procédure mais en arrivant ce matin au poste je constate une anomalie sur mon application, j'ouvre le code d'une de mes procédures de classes et devinez ? Mes conditions d’exécution rajouter samedi ont disparu... Je suis sous windev25 avec les 2 patchs et l'update 4

--
Maître de la POO
Miembro registrado
62 mensajes
Publicado el 25,enero 2021 - 13:30
On peut downgrader de 25 en 15 ?
ça commence à faire peur...
;(
Miembro registrado
44 mensajes
Publicado el 25,enero 2021 - 20:34
Constatation de ce soir : on peut perdre le code, mais pas l'effet !

Sur un écran, j'ai perdu le code de modification que j'avais mis dans un interrupteur. Mais au Go de fenêtre ou de projet, le code-fantôme est exécuté quand même !

La recompilation simple de la fenêtre (Code->Compiler la fenêtre) ne suffit pas. Il faut remettre à blanc la ligne qui est déjà blanche pour que la recompilation soit effectuée et fasse effet.

C'est chaud !

--
Gestan, le couteau Suisse de la gestion d'entreprise.
https://www.gestan.fr
Miembro registrado
2.243 mensajes
Publicado el 27,enero 2021 - 11:06
Est-ce que quelqu'un a plus d'infos ? Je pense que ça devient urgent !!!

--
Cordialement,

Philippe SAINT-BERTIN
Miembro registrado
240 mensajes
Publicado el 27,enero 2021 - 11:13
Je pense que nous devons envoyer des requêtes au support technique en masse.

--
Maître de la POO
Miembro registrado
788 mensajes
Popularité : +2 (2 votes)
Publicado el 27,enero 2021 - 11:33
Bonjour,

J'ai faits quelques petits projets (création) avec la 26, accès à des BD, fichier INI... et sans GDS.. rien de sorcier. Ouverts et modifiés à maintes reprises sans constater ce problème.
Je me pose donc la question suivante :
Toutes vos constatations sont sur des projets que vous avez migrés vers la 26 ou avez-vous la même constatation d'un nouveau projet placé dans le GDS ?
(J'ai relu les posts et je n'ai pas vu cette info, sauf erreur de ma part).

--
Thierry TILLIER
Développeur Windev-Webdev
Formation Windev : https://coursdinfo.teachable.com/
Formation bureautique : https://coursdinfo.net
Tuto WINDEV sur ma chaîne Youtube
Miembro registrado
10 mensajes
Publicado el 27,enero 2021 - 11:38
Je n'ai pas la 26, le problème existe sur des projets migrés de 23 à 25 et sur des projets créés directement en 25.
Mais je pense que cet problème intervient depuis la version 90f voir celle juste avant, je n'avais jamais eu ce problème avec la 83H
Miembro registrado
240 mensajes
Publicado el 27,enero 2021 - 11:49
THIERRY TILLIER a écrit :
Bonjour,

J'ai faits quelques petits projets (création) avec la 26, accès à des BD, fichier INI... et sans GDS.. rien de sorcier. Ouverts et modifiés à maintes reprises sans constater ce problème.
Je me pose donc la question suivante :
Toutes vos constatations sont sur des projets que vous avez migrés vers la 26 ou avez-vous la même constatation d'un nouveau projet placé dans le GDS ?
(J'ai relu les posts et je n'ai pas vu cette info, sauf erreur de ma part).

--
Thierry TILLIER
Développeur Windev-Webdev
Formation Windev : https://coursdinfo.teachable.com/
Formation bureautique : https://coursdinfo.net
Tuto WINDEV sur ma chaîne Youtube


Tu penses vraiment si c’était aussi simple a reproduire PC soft n'aurai pas fixé ce bug depuis un bon bout de temps ?

--
Maître de la POO
Miembro registrado
788 mensajes
Popularité : +2 (2 votes)
Publicado el 27,enero 2021 - 12:39
@Ninja codeur comme a votre habitude, vos courtoises réponses à mes questions sont sans intérêts.

--
Thierry TILLIER
Développeur Windev-Webdev
Formation Windev : https://coursdinfo.teachable.com/
Formation bureautique : https://coursdinfo.net
Tuto WINDEV sur ma chaîne Youtube
Miembro registrado
240 mensajes
Publicado el 27,enero 2021 - 12:52
@THIERRY TILLIER Je me force à espérer que la réponse soit non en tout cas.

--
Maître de la POO
Miembro registrado
44 mensajes
Publicado el 27,enero 2021 - 19:31
@ThierryTillier pour ce qui nous concerne, tous nos projets ont été migrés de versions plus anciennes de Windev.

--
Gestan, le couteau Suisse de la gestion d'entreprise.
https://www.gestan.fr
Miembro registrado
103 mensajes
Publicado el 27,enero 2021 - 21:29
@ThierryTillier : pour ma part projet WEBDEV migré de 23 à 25 (90f) avec utilisation GDS
Pas d'expérience nouveau projet (WD ou WB)
Miembro registrado
180 mensajes
Publicado el 27,enero 2021 - 21:58
Bonjour,
J'ai déjà eu le soucis également...
Par contre, j'ai trouvé une solution qui fonctionne, depuis que je le fais je n'ai plus le soucis.
Lorsque je quitte le projet je lance "REPARER LE PROJET" çà re-sauvegarde l'ensemble des sources.
Personnellement, cela ne me dérange pas (enfin presque...) car je reste la journée sur le même projet, je ne change pas 50 fois de projet dans la journée.
Voilà...
Bonne soirée...
Olivier

--
Miembro registrado
180 mensajes
Publicado el 27,enero 2021 - 22:08
Avec la dernière mise à jour de la 26, je ne sais pas si le soucis est toujours présent ou pas !
Vu que je fais "réparer le projet" systématiquement, je n'ai plus le soucis.
Bonne soirée.

--
Publicado el 28,enero 2021 - 08:02
Bonjour,

Je constate également la perte de code, je ne travaille ni avec le GDS, ni avec le groupware utilisateur.
Miembro registrado
103 mensajes
Publicado el 29,enero 2021 - 15:52
@ICS01 "Sur un écran, j'ai perdu le code de modification que j'avais mis dans un interrupteur. Mais au Go de fenêtre ou de projet, le code-fantôme est exécuté quand même ! "

WEBDEV 25 90f avec patch 120085
Sans avoir "perdu" le code parce que je l'ai moi-même supprimé je constate que l'effet du code est toujours là !
Cas très simple d'une apparition d'un bouton "valider" sur modification d'un champs de saisie.
J'ai supprimé le "BTN_Valider..visible = vrai" mais le bouton apparait toujours, même après avoir tenté des "BTN_Valider..visible = faux" à divers endroits.
Il y a donc bien du code "fantôme" !
Ca fout la trouille !
Requête au ST
Miembro registrado
44 mensajes
Publicado el 29,enero 2021 - 22:44
@Olivier : peut-être que PCSoft va nous dire si la piste "Réparer le projet" est pertinente en attendant la correction ?

@Jissé : effectivement, ce n'est pas rassurant, mais si vous avez pu reproduire et faire une requête au ST, la correction va arriver vite.

--
Gestan, le couteau Suisse de la gestion d'entreprise.
https://www.gestan.fr
Miembro registrado
2.243 mensajes
Publicado el 03,febrero 2021 - 09:48
1 semaine après est-ce que quelqu'un a eu des infos ?

--
Cordialement,

Philippe SAINT-BERTIN
Miembro registrado
13 mensajes
Publicado el 03,febrero 2021 - 09:54
Grosse semaine depuis 13 Janvier ;)
Le ST doit bosser dessus avec toutes les précisions et exemples passés au ST...
On espère une réponse, quelque soit celle-ci pour nous rassurer j'espère.
Miembro registrado
103 mensajes
Publicado el 03,febrero 2021 - 14:31
J'ai eu une réponse du ST 1er février à qui je me suis plaint qui me dit
-que tous les cas connus qu'ils ont pu reproduire ou identifier ont été corrigés v25 v26.
-que sur le forum beaucoup de cas correspondrait au cas connus : (CTRL+Z et éléments avec code compilé intégré).
-qu'il faut des éléments précis pour déterminer la cause des problèmes persistant (ce que je pense avoir fait mais on ne m'en a pas demandé plus... pour me répondre d'utiliser les sauvegardes automatique ou de réinitialiser le contexte du projet en supprimant
"<NomProjet>.ENV" et le sous répertoire "<NomProjet>.CPL" .

Tout va bien madame la marquise.

Pour mon problème (code fantôme), j'ai recréé mon bouton et ses 2 lignes de code.
Pour éviter de mettre en cause mes facultés mentales je fait une impression dossier après une modif d'une page (pour les pertes de code), je n'ai pas confiance dans les sauvegardes automatique.
Pour l'avenir, une question bien d'actualité: quel est le bénéfice/risque de passer à la 26 ?
Miembro registrado
2.243 mensajes
Publicado el 03,febrero 2021 - 14:59
ou à migrer sur une autre techno ???

--
Cordialement,

Philippe SAINT-BERTIN