PC SOFT

FOROS PROFESIONALES
WINDEVWEBDEV y WINDEV Mobile

Inicio → WINDEV Mobile (versiones precedentes) → imprimer sur android avec windev mobile 25
imprimer sur android avec windev mobile 25
Iniciado por jupeton, 17,jul. 2021 21:44 - 3 respuestas
Publicado el 17,julio 2021 - 21:44
bonjour à tous

j'utilise la version 25 de windev mobile et j'expérimente l'impression sur android. mais je n'arrive toujours pas à imprimer.
j'ai le message suivant selon le terminale :
- sur un smartphone Huawei android 10
message "Ce fichier n'a pas pu être ouvert. Vérifiez votre connexion ou réduisez la longueur du nom de fichier"
- sur un SUNMI V2 android 7.1
message "le fichier est inaccessible. vérifiez l'emplacement ou le réseau et essayez à nouveau"

voici le code utilisé
NomFichier est une chaîne = ""

NomFichier = fRepDonnées() + [fSep()] + "BDC.PDF"
iDestination(iPDFGénérique, NomFichier)
iImprimeEtat(ETAT_TicketAvoirs)

// Test de l'existence du fichier
SI fFichierExiste(NomFichier) = Faux ALORS
Erreur("Le fichier PDF n'a pas été généré")
RETOUR
FIN

// Confirmation pour afficher le PDF
SI OuiNon(Oui, "Afficher le bon de commande généré (format PDF) ?") = Oui ALORS
// Affichage du bon de commande généré
LanceAppliAssociée(NomFichier)
SINON
iImprimePDF(NomFichier)
FIN


je compte sur votre aide.
Merci !
Miembro registrado
1.700 mensajes
Publicado el 18,julio 2021 - 19:02
Oui en théorie l'état est utilisable pour créer un pdf
Personnellement je n'ai jamais réussi
Cependant j'ai trouvé une méthode de contournement
Qui fonctionne
https://depot.pcsoft.fr/resource.awp…
Publicado el 20,julio 2021 - 12:33
super !!!
j'ai testé ça marche nickel !!!
merci infiniment !!!!!!!

j'arrive à avoir un aperçu, cependant l'équipement SUNMI V2 que j'utilise a une imprimante embarquée qui n'apparait pas dans la liste des imprimantes. ce qui m'empêche d'imprimer directement.
comment faire ?
Miembro registrado
1.700 mensajes
Publicado el 20,julio 2021 - 15:54
Soit tu programme en java
Soit le plus simple est de faire un lance appli associer
https://doc.pcsoft.fr/fr-FR/?3035007
A condition que le logiciel d'impression accepte le PDF