PC SOFT

FOROS PROFESIONALES
WINDEVWEBDEV y WINDEV Mobile

Inicio → WINDEV Mobile 26 → Liste fichier du répertoire photo
Liste fichier du répertoire photo
Iniciado por Stéphane D., 24,nov. 2021 14:32 - 4 respuestas
Miembro registrado
127 mensajes
Publicado el 24,noviembre 2021 - 14:32
Bonjour à tous,
Je voudrais énumérer la liste des photos prise sur la carte SD de la tablette.
Voici mon bout de code :
UnFichier, ResListeFichier, monChemin sont des chaînes

monChemin = SysRepStockageExterne(2,ssePublic)+"/DCM/Camera/"
Info(monChemin) //J'ai bien /storage/5C2F-EC2B/DCM/Camera

ResListeFichier = fListeFichier(gsRepLocalEncours)

Info(ResListeFichier) //La liste est vide

POUR TOUTE chaîne UnFichier de ResListeFichier SEPAREE PAR RC
Info(UnFichier)
FIN

Si quelqu'un pouvez m'orienter
Je suis en version 25.
Merci d'avance de votre aide.

--
Stéphane.
Miembro registrado
127 mensajes
Publicado el 24,noviembre 2021 - 14:34
Dsl j'ai bien mis cela :
monChemin = SysRepStockageExterne(2,ssePublic)+"/DCM/Camera/"
Info(monChemin) //J'ai bien /storage/5C2F-EC2B/DCM/Camera

ResListeFichier = fListeFichier(monChemin)

Info(ResListeFichier) //La liste est vide

POUR TOUTE chaîne UnFichier de ResListeFichier SEPAREE PAR RC
Info(UnFichier)
FIN


--
Stéphane.
Publicado el 25,noviembre 2021 - 11:13
Bonjour,

Vous ne précisez pas sur quelle version d'Android est exécuté votre code.
Sachez qu'il existe de nouvelles restrictions depuis Android 10, je vous invite à aller consulter cette page : https://doc.pcsoft.fr/fr-fr/?1000021793&name=sysrepstockageexterne_fonction (Gestion des fichiers et de leur emplacement).

Cordialement,
Miembro registrado
127 mensajes
Publicado el 25,noviembre 2021 - 16:16
Bonjour Aurélie,
Je vous remercie de votre réponse.
Je vais aller voir votre lien, et je suis en version 25.

--
Stéphane.
Miembro registrado
127 mensajes
Publicado el 25,noviembre 2021 - 16:44
Je suis trop...
J'ai juste oublié un I pour le répertoire DCIM et non pas DCM....

--
Stéphane.