PC SOFT

FOROS PROFESIONALES
WINDEVWEBDEV y WINDEV Mobile

Inicio → WINDEV Mobile 23 → [WM23]/[WD23] SocketWrite
[WM23]/[WD23] SocketWrite
Iniciado por ARV, 11,feb. 2019 22:52 - 3 respuestas
Miembro registrado
292 mensajes
Publicado el 11,febrero 2019 - 22:52
Hi all

I have this issue

I have a project on Mobile in Android I changed the config of my project to be Ansi only just like the PC for default.

I want to send a socket to a service on windows, but the info doesn't get to what I want.

ok I send the info like 114+A
on my DB it's like 1+
and if it's a project from PC to my service it works pretty well.

I know it's about this things of Ansi and Unicode but I change my project of Android to be all of Ansi and still doesn't work.

any idea?

--
Best Regards
ARV
Publicado el 14,febrero 2019 - 17:33
ARV,

In Project Explorer, right click on Project, and click on Project Description.
Go to Languages.
In Character set for ANSI Configuration, select <ANSI>.

See if that helps.

Jim
Miembro registrado
292 mensajes
Publicado el 14,febrero 2019 - 18:06
Hi Jim

Thanks for your reply

I already did this before everything else and still doesn't work.

I figure it out that it has to be with the string I want to use, for somereason even tought My project it's on Ansi on both PC and Android still doesn't work properly

the string it's this:
ººº

Before I find this error my project on Android was on Unicode and PC on Ansi so I send the socket from Android to PC converting my string no ansi something like

SocetWrite(Name,UnicodeToAnsi("ººº"))

and it works cool also on my socketRead on Android I do the same transfer AnsiToUnicode and works great.
But if both from project config are on Ansi this still doesn't work.
I can't use the convert function because the string it's on Ansi

so I don't know why this is failing.

thanks!

--
Best Regards
ARV
Publicado el 18,febrero 2019 - 18:50
ARV,

Try using a buffer when writing.
I'm writing and reading to a device not a server.
I am sending everything back and forth in a buffer. (Hex)

Jim