PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 24 → WX - Webservice Example com autenticação
WX - Webservice Example com autenticação
Débuté par BOLLER ADRIANO, 26 juil. 2016 02:36 - Aucune réponse
Membre enregistré
2 962 messages
Popularité : +89 (91 votes)
Posté le 26 juillet 2016 - 02:36
Prezados,

Segue exemplo de um Webservice Simples para ser usado como modelo em seus projetos:





Exemplo Webservice Server:

//server <----------------------------------- codigo no global da procedure "SETA VERMELHA"
arr_Resultados is array of string
DeclareWebserviceContext(arr_Resultados) //Principal funcao que declara webservice//




// Résumé : <indiquez ici ce que fait la procédure>
// Syntaxe :
//[ <Résultat> = ] Sum (<sLogin>, <sPass>, <sN1>, <sN2>)
//
// Paramètres :
// sLogin : <indiquez ici le rôle de sLogin>
// sPass : <indiquez ici le rôle de sPass>
// sN1 : <indiquez ici le rôle de sN1>
// sN2 : <indiquez ici le rôle de sN2>
// Valeur de retour :
// Type indéterminé : // Aucune
//
// Exemple :
// Indiquez ici un exemple d'utilisation.
//
Procedure Sum(sLogin,sPass,sN1,sN2)
SI Auth(sLogin,sPass) ALORS
RENVOYER Crypte(Val(Uncrypt(sN1,"Webservice_Adriano"))+Val(Uncrypt(sN2,"Webservice_Adriano")),"Webservice_Adriano")
SINON
RENVOYER "error"
FIN




Procedure Auth(sLogin,sPass)
SI (SansEspace(Uncrypt(sLogin,"Webservice_Adriano")) = "user") ET (SansEspace(Uncrypt(sPass,"Webservice_Adriano")) = "pass") ALORS
RENVOYER Vrai
SINON
RENVOYER Faux
FIN




Exemplo Webservice Cliente:









sUser est une chaîne = SAI_user
sPass est une chaîne = SAI_Pass
n1 est une chaîne = SAI_n1
n2 est une chaîne = SAI_N2
A1 est un Auth
A1Response est un AuthResponse
SAI_Pass1 = Crypte(SansEspace(sPass),"Webservice_Adriano")
SAI_user1 = Crypte(SansEspace(sUser),"Webservice_Adriano")
SAI_n3 = Crypte(SansEspace(n1),"Webservice_Adriano")
SAI_N4 = Crypte(SansEspace(n2),"Webservice_Adriano")

A1.sLogin = Crypte(SansEspace(sUser),"Webservice_Adriano")
A1.sPass = Crypte(SansEspace(sPass),"Webservice_Adriano")

A1Response = Auth(A1)

SELON A1Response.AuthResult
CAS Vrai
B2 est un Sum
B2Response est un SumResponse
B2.sLogin = Crypte(SansEspace(sUser),"Webservice_Adriano")
B2.sPass = Crypte(SansEspace(sPass),"Webservice_Adriano")
B2.sN1 = Crypte(SansEspace(n1),"Webservice_Adriano")
B2.sN2 = Crypte(SansEspace(n2),"Webservice_Adriano")

B2Response = Sum(B2)
Info(Uncrypt(B2Response.SumResult,"Webservice_Adriano"))
CAS Faux
Info("Error IN Auth please contact sys Admin")
AUTRE CAS

FIN


Bons estudos

--
Adriano José Boller
______________________________________________
Consultor e Representante Oficial da
PcSoft no Brasil
+55 (41) 9949 1800
adrianoboller@gmail.com
skype: adrianoboller
http://wxinformatica.com.br/
Message modifié, 26 juillet 2016 - 02:41