PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 25 → [%..%] no funciona en Windev 25 Express
[%..%] no funciona en Windev 25 Express
Débuté par Juan Carlos, 30 avr. 2021 14:04 - 2 réponses
Membre enregistré
2 messages
Posté le 30 avril 2021 - 14:04
Buenos dias,
estoy comenzando la formación en windev y tengo el siguiente ejemplo:
gsBuiltString is string
gsProductName is string = "WINDEV"

// Concatenation
gsBuiltString = gsProductName + "is my go-to development tool!"
Trace("Concatenation: " + gsBuiltString)

// StringBuild
gsBuiltString = StringBuild("%1 is my go-to development tool!", gsProductName)
Trace("StringBuild: " + gsBuiltString)

// Direct input of the variable ([% %] syntax)
gsBuiltString = "[%gsProductName%] is my go-to development tool!"
Trace("Direct input: " + gsBuiltString)

Y el resultado es:
Concatenation: WINDEVis my go-to development tool!
StringBuild: WINDEV is my go-to development tool!
Direct input: [%gsProductName%] is my go-to development tool!

Como ven, la tercera forma toma literalmente los caracteres [%..%].

Alguien sabe por que?

Estoy travajando en Windows 10 64 bit y con WinDev Express

Muchas gracias!!
Membre enregistré
456 messages
Posté le 30 avril 2021 - 23:16
Hola. ¿Has comprobado si la opción esta activada en el proyecto en las opciones de compilación? Proyecto->Descripcion->Compilación-> Permitir "[% %] en las cadenas

Rubén
Membre enregistré
2 messages
Posté le 01 mai 2021 - 17:42
Hola y muchas gracias!!:D, Es justo lo que tenia que hacer.
Que tengas un exelente fin de semana!gracias: