PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV (précédentes versions) → PROBLEME DANS MON CODE WEBDEV
PROBLEME DANS MON CODE WEBDEV
Débuté par Guillaume, 01 juin 2018 12:01 - 3 réponses
Posté le 01 juin 2018 - 12:01
Bonjour à tous,

J'ai besoin d'aide. Débutant en webdev, je suis confronté un problème. J'ai une base de données sur un serveur Distant sur lequel j'ai installé HyperfileSQL CS.


Voici:

Dans le code du projet, j'ai :

MaConnexion est une Connexion

gpNomServeur = INILit("SERVEUR","NOM SERVEUR","",gpNomFichierConnexion)

gpNomUserDB = INILit("SERVEUR","USER","",gpNomFichierConnexion)
gpNomSourceBD = INILit("SERVEUR","BD","",gpNomFichierConnexion)
gpMotPasse = INILit("SERVEUR","PASSE","",gpNomFichierConnexion)
gpPort = INILit("SERVEUR","PORT","",gpNomFichierConnexion)

//-- Description de la connexion
MaConnexion..Utilisateur = gpNomUserDB
MaConnexion..MotDePasse = gpMotPasse
MaConnexion..Serveur = SansEspace(gpNomServeur)+":"+SansEspace(gpPort)
MaConnexion..BaseDeDonnées = gpNomSourceBD

MaConnexion..Provider = hAccèsHFClientServeur
MaConnexion..Accès = hOLectureEcriture
MaConnexion..InfosEtendues = "Infos étendues"
MaConnexion..OptionsCurseur = hCurseurClient

ENSUITE JE FAIS :

//--Ouverture de la connexion
SI HOuvreConnexion(MaConnexion) ALORS

SI HChangeConnexion("*",MaConnexion) ALORS

HPasse("*",gPasseFic)

HCréationSiInexistant("*")

Utilise(PAGE_CONNEXION)

SINON
Info("L'affectation des fichers à la connexion n'a pas pu se faire !")
RETOUR
FIN
SINON
Info("La connexion avec le serveur n'a pas pu être établie !")
RETOUR
FIN

**--------------------------
PAGE_CONNEXION comprends un champ CMB_LOGIN qui charge la liste des utilisateurs du fichier UTILISATEURS.

Quand je lance le projet voici le message que je reçois :



Le champ 'CMB_LOGIN' n'a pas pu s'initialiser, car il a rencontré l'erreur HFSQL suivante :
=============================
Mot de passe incorrect pour le fichier <UTILISATEURS>.


SI JE FAIS MAL QUELQUE CHOSE, DITES LE MOI. JE SÈCHE COMPLÈTEMENT.
Membre enregistré
388 messages
Posté le 02 juin 2018 - 12:40
Bonjour,

Pourquoi decrivez vous une connexion par programmation au lieu d'utiliser les connexions dans l'analyse ?

Jordan
Posté le 02 juin 2018 - 14:44
Bjr,

Dans plusieurs postes j'ai vu que c'est ce qu'il fallait faire.

merci pour la réponse.
Membre enregistré
388 messages
Posté le 05 juin 2018 - 16:23
Dans l'analyse, si tu renseigne bien toutes les informations, vous pourrez tester tout de suite si ca fonctionne ou pas