PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV (précédentes versions) → enchainer code serveur et code navigateur
enchainer code serveur et code navigateur
Débuté par SylvainF, 25 juin 2018 14:24 - 2 réponses
Posté le 25 juin 2018 - 14:24
Bonjour,
Je suis débutant sur WebDev et je cherche à réaliser une sorte de plan (image de fond tout simplement) sur lequel se situe du matériel. Je souhaite maintenant ajouter un champ de saisie qui, s'il contient un nom de matériel valide, provoque un changement de position de la page sur cet élément.

Pour l'instant j'ai un code bouton (click serveur) qui appelle une procédure globale :

PROCEDURE RechercheChamp(uneSaisie, unePage)
pageChamps est une chaîne
i est un entier = 1
BOUCLE
pageChamps = EnumèreChamp(unePage, i) //énumèrechamp fonction serveur
SI pageChamps = uneSaisie OU pageChamps = "" ALORS
SORTIR
FIN
i++
FIN
RENVOYER pageChamps

je souhaite maintenant dans la partie navigateur de mon bouton récupérer ce que renvoi cette procédure dans une variable et appeler pagePosition(la_page, la_variable) qui est du code navigateur

J'ai eu beau lire tous les topics et docs sur les liaisons entre code serveur et navigateur et je ne suis pas parvenu à obtenir quelque chose qui marche. Quelqu'un aurait-il une idée s'il vous plait ?
Membre enregistré
45 messages
Posté le 17 juillet 2018 - 12:39
Bonjour Sylvain,

As-tu essayé de traiter toute l'opération en code navigateur et en plaçant le code serveur dans une procédure Ajax ?
Regarde l'aide WB sur AjaxExécute()

Tu peux aussi utiliser un bouton en mode Ajax avec un champ de saisie invisible que tu renseignes en code serveur et dont tu récupères la valeur en code navigateur.

A+
Message modifié, 17 juillet 2018 - 12:40
Posté le 18 juillet 2018 - 16:34
Bonjour,
Merci pour ta réponse, en effet c'est d'AjaxExécute dont j'avais besoin.
Merci encore