PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV 23 → [WB17] Bloquer backspace
[WB17] Bloquer backspace
Débuté par simoes, 12 fév. 2013 17:52 - 1 réponse
Posté le 12 février 2013 - 17:52
Bonjour,
Je recherche un moyen d'empêcher l'action retour quand l'on clique sur la touche backspace. j'ai déjà coché "Empêcher le retour sur cette page par le bouton "Précédent" du navigateur" sur les page ainsi que dans la description du projet.
Quelqu'un aurais une idée ?

merci d'avance.
Posté le 09 juillet 2018 - 15:05
Bonjour,
Le post est un peut vieux, mais j'ai eu le même problème que toi, j'ai trouvé la solution en faisant ainsi :

Déclaration dans le Onload de la page
JSEvénement(proc_annulerBackSPACE, jsEvénementDocument, jsEvénementKeyDown)

Au niveau de la procédure j'intercepte l'évènement et je vérifie qu'il ne soit pas dans un champ de saisie :

PROCEDURE proc_annulerBackSPACE(pclEvenementJS est un objet dynamique <utile>)
sNomElement est une chaîne = pclEvenementJS.target
SELON pclEvenementJS.keyCode
CAS 8 // BackSpace
SI pclEvenementJS.target.localName = "body" OR pclEvenementJS.target.nodeName = "BODY" ALORS
JSInterruptionEvénement(pclEvenementJS,jsInterruptionEvénementAction)
FIN
AUTRE CAS
FIN