PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV 22 → Boucle lors de l'envoi d'email
Boucle lors de l'envoi d'email
Débuté par BLANDINE / BRESSUIRE, 19 mai 2017 12:38 - Aucune réponse
//hostimage.webdev.info/avatars/RcLTQRuROfXDe1BBqtHmw
Membre enregistré
17 messages
Posté le 19 mai 2017 - 12:38
Bonjour,

J'ai un site Web sur lequel je peux faire une demande d'information envoyée par mail. Quand j'exécute mon site en GO depuis WebDev, tout fonctionne. Quand j'exécute mon site en déploiement, l'envoi du mail boucle.

Voici mon code :

MessageMailContact est une chaîne
MaSession est un EmailSessionSMTP
Mail est un Email

SI (SansEspace(SAI_Nom) <> "") ET (SansEspace(SAI_Mail) <> "") ALORS
MessageMailContact = "CONTACT SITE INTERNET"+CR+CR
SELON SEL_Civilite
CAS 1 : MessageMailContact = MessageMailContact + "M. "
CAS 2 : MessageMailContact = MessageMailContact + "Mme "
CAS 3 : MessageMailContact = MessageMailContact + "Mlle "
FIN
MessageMailContact = MessageMailContact + SansEspace(SAI_Nom) + Espace + SansEspace(SAI_Prenom) + CR + SansEspace(SAI_Adresse) + CR + SansEspace(SAI_CP) + Espace + SansEspace(SAI_Ville) + CR + CR + "Tél. " + SansEspace(SAI_Tel) + " Portable " + SansEspace(SAI_Portable) + CR + CR + "E-Mail : " + SansEspace(SAI_Mail) + CR + CR + "--------------------------------------------------" + CR + CR + "Message :" + CR + CR + SansEspace(SAI_Message)
MaSession..AdresseServeur = "smtp.host.fr"
MaSession..Asynchrone = emailSynchrone
MaSession..MotDePasse = MotDePasseMessagerie
MaSession..Nom = IdentifiantMessagerie
MaSession..Option = optionSSL
MaSession..Port = 465
//Ouverture de la session
SI PAS EmailOuvreSession(MaSession) ALORS
Info ("Connexion perdu " + ErreurInfo())
SINON
Mail.Expediteur = SansEspace(SAI_Mail)
Mail.Message = MessageMailContact
Mail.Sujet = "Demande d'information"
Mail.Destinataire[1] = IdentifiantMessagerie
//Envoie de l'émail
SI PAS EmailEnvoieMessage(MaSession,Mail) ALORS
Info ("Erreur d'envoi : " + ErreurInfo())
SINON
Info ("Mail envoyé avec succès")
FIN
//Fermeture de la session
EmailFermeSession(MaSession)
FIN
FIN

Quelqu'un pourrait-il me guider à ce sujet ?

Merci