PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV 23 → 12, ERR_NO_WWADMIN sous Centos 7
12, ERR_NO_WWADMIN sous Centos 7
Débuté par KAKUM, 06 mai 2018 20:46 - 3 réponses
Membre enregistré
2 messages
Posté le 06 mai 2018 - 20:46
Bonjour chers Développeurs, J'ai intallé le serveur d'application webdev 10 CNX sous Centos 7, j'ai suivi le tuto d'installation sous linux, après installation complète, lorsque dans mon url je tape :'http://127.0.0.1/WD230AWP/WD230AWP/version' , j'obtiens le résultat normalement. Mais les autres liens à savoir ( 'http://127.0.0.1/WD230AWP/WD230AWP/connect/WDAdminWeb230' et 'http://127.0.0.1/WDAdminWeb230') renvoient une erreur dont le code est "12, ERR_NO_WWADMIN" avec pour détails : Le service d'administration de WEBDEV (wd230admind) n'a pas été lancé ...invalid argument(22).
Je ne vois pas comment lancer ce service, dans les paquets installé sous CENTOS 7, il y a WEBDEV23.service qui tourne normalement.

Si vous avez une solution, elle m'aidera
Cordialement, Merci
Membre enregistré
164 messages
Posté le 15 mai 2018 - 09:24
bonjour,

désolé, je n'ai pas de solution à ton problème, juste deux idées à tester si cela peut te faire avancer :

dans la console :
/etc/init.d/WebDev23 restart

pstree


Le second doit te signaler wdadmind230 dans les processus en cours

bonne chance
Christophe
Membre enregistré
2 messages
Posté le 16 mai 2018 - 21:49
Bonjour chers developpeurs, en rapport avec l'erreur 12, ERR NO WWADMIN, apache sous centos 7, Un ingenieur de PCSOFT m'a filé une idée en proposant de désactiver PrivateTmp d'apache, C'est ainsi que j'ai murie l'idée dont l'aplication a été positive.
Avant toute chose, se rassurer que tout est bien configuré(updates, paquets supplementaires, ftp server, librairies(qtwebkit), serveur web Apache, activation du mode CGI sous apache, serveur d'application webdev), en suite...
1. En mode root, création du repertoire httpd.service.d
#mkdir /etc/systemd/system/httpd.service.d
2. En mode root, création du fichier nopt.conf
#nano /etc/systemd/system/httpd.service.d/nopt.conf
3. En mode root, modification du fichier nopt.conf par l'ajoute de "[Service]"
#echo "[Service]" > /etc/systemd/system/httpd.service.d/nopt.conf
4. En mode root, ajouter la ligne "PrivateTmp=false" de la manière suivante
#echo "PrivateTmp=false" >> /etc/systemd/system/httpd.service.d/nopt.conf
5. Redemarrage des services
# systemctl daemon-reload
#systemctl restart httpd
Avec ça, l'administration webdev est opérationnelle.
J'espère que vous en tirerez profit...
Coordialement, Daudet KAKUM
Posté le 13 septembre 2018 - 17:07
Merci beaucoup, cela a fonctionné sur mon serveur en Centos 7.