PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV 23 → Upload et renommage de fichier - Lettre de motivation & CV
Upload et renommage de fichier - Lettre de motivation & CV
Débuté par Deadly974_35, 07 juin 2018 11:56 - 2 réponses
Membre enregistré
2 messages
Posté le 07 juin 2018 - 11:56
Bonjour,

Alors voilà ce que je voulais faire c'était que lorsqu'un apprentis sur le site internet de pré-inscription BTS que je réalise, upload des documents tel que CV et Lettre de Motivation, que le nom de ces documents soit renommé en "CV.pdf" et "LettreDeMotivation.pdf".

Voilà mon code:

POUR nIndice=1 À UPL_Upload..Occurrence
sNomFichier = UploadCopieFichier(UPL_Upload,fRepDonnées(),"",nIndice)

HRAZ(Fichier)
HAttacheMémo(Fichier,Document, ComplèteRep(fRepDonnées())+ sNomFichier)
Fichier.IDApprentis = Apprentis.IDApprentis
Fichier.Nom_document = sNomFichier
HAjoute(Fichier)
fOuvre(ComplèteRep(fRepDonnées())+ sNomFichier)
SI fNomFichier(Fichier.Nom_document) <> "LettreDeMotivation.pdf" ALORS
fRenomme(ComplèteRep(fRepDonnées())+ sNomFichier,ComplèteRep(fRepDonnées())+ "LettreDeMotivation.pdf")
SINON SI fNomFichier(Fichier.Nom_document) <> "CV.pdf" ALORS
fRenomme (ComplèteRep(fRepDonnées()) + sNomFichier, ComplèteRep(fRepDonnées()) + "CV.pdf")
FIN
FIN


Seulement voilà quand j'exécute mon code, et bien il ne renomme pas mes fichiers, pouvez m'aidez svp ?
Membre enregistré
361 messages
Posté le 07 juin 2018 - 12:04
Bonjour,

Il faut mettre le nom du fichier dans le UploadCopieFichier

UploadCopieFichier(UPL_Upload,fRepDonnées(),"LettreDeMotivation.pdf",nIndice)


Avec les conditions adéquates.

--
https://www.cedvano.com
Membre enregistré
2 messages
Posté le 07 juin 2018 - 17:07
Du coup j'ai fais autrement vu que la où je suis parti ça allait me bloqué sachant que je veux mettre une lettre de motivation et un CV du même nom pour tous sauf leur numéros d'identifiant qui est rattaché après le nom du fichier (exemple: "Lettredemotivation08.pdf")

J'ai réussi à générer le fichier sauf que webdev indique que mon fichier est introuvable.

Voici mon code:

sNomFichierLDM est une chaîne= fExtraitChemin("Lettre_de_motivation" + Apprentis.IDApprentis, fFichier + fExtension)
sNomFichierCV est une chaîne = fExtraitChemin("CV" + Apprentis.IDApprentis, fFichier + fExtension)

SI SAI_Lettre_de_motivation <> "" ALORS
UploadCopieFichier(SAI_Lettre_de_motivation,fRepDonnées(), sNomFichierLDM )
HAttacheMémo(Fichier,Document,ComplèteRep(fRepDonnées())+ sNomFichierLDM )
Fichier.IDApprentis = Apprentis.IDApprentis
Fichier.Nom_document = sNomFichierLDM
FIN


SI SAI_CV <> "" ALORS
UploadCopieFichier(SAI_CV,fRepDonnées(), sNomFichierCV)
HAttacheMémo(Fichier,Document,ComplèteRep(fRepDonnées())+ sNomFichierCV)
Fichier.IDApprentis = Apprentis.IDApprentis
Fichier.Nom_document = sNomFichierCV

FIN

PageVersFichier()
HEnregistre(Fichier)
PageAffiche(PAGE_AjouterDoc)