PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV 23 → Deployer site php sur wamp
Deployer site php sur wamp
Débuté par Basturk, 07 juin 2018 17:37 - 8 réponses
Membre enregistré
69 messages
Posté le 07 juin 2018 - 17:37
Bonjour les amis.

Habitué à travailler sur windev plus que webdev, je me trouve confronter un problème (cf dans le titre): Comment déployer mon projet sous webdev (j'ai choisi l'option php) sur wamp ?

j'ai copié le repertoire 'FR' de mon projet dans le repertoire 'www' de wamp. Et là j'ai une erreur à la page index du genre
Parse error: syntax error, unexpected '=' in C:\wamp64\www\FR\index.php on line 97


Pourtant quand je fais un 'GO' depuis webdev (configuré avec iis) tout marche bien.


Quelqu'un a une idée de la raison de cette erreur ?

--
Il y a 10 types de personnes: ceux qui comprennent le binaire et les autres.
Membre enregistré
69 messages
Posté le 07 juin 2018 - 18:03
J'avance dans mes réflexions, même si ça semble se compliquer davantage. :o

j'ai en effet remarqué que quand j'active "déboguer l'élément PHP en mode simulation" et fait un "GO", il n'y a aucun problème. Mais si je désactive ce mode alors j'ai des erreurs.

J'ai raté quelque chose ?

Merci d'avance.:)

--
Il y a 10 types de personnes: ceux qui comprennent le binaire et les autres.
Membre enregistré
101 messages
Posté le 08 juin 2018 - 09:26
Bonjour,

Désolé de ne pas pouvoir répondre à votre question, cependant moi aussi, je développe un projet PHP mais avec IIS. Ma question est la suivante. Avez-vous dû configurer quelque chose pour faire tourner votre projet sous ISS ? Ca fait bien 2 jours que je bloque là-dessus...
Membre enregistré
9 messages
Posté le 08 juin 2018 - 09:35
anonyme a écrit :
Bonjour,

Désolé de ne pas pouvoir répondre à votre question, cependant moi aussi, je développe un projet PHP mais avec IIS. Ma question est la suivante. Avez-vous dû configurer quelque chose pour faire tourner votre projet sous ISS ? Ca fait bien 2 jours que je bloque là-dessus...


Il faut installer le moteur PHP CGIsur IIS

--
https://fekwx.com | La meilleur communauté WX
Membre enregistré
101 messages
Posté le 08 juin 2018 - 10:22
Bonjour Manim,

S' il s' agit de mapper Php-Cgi dans IIS, je l' ai déjà fait.
http://pasteall.org/pic/show.php…

Hélas, ça ne m' a pas beaucoup avancé...
Membre enregistré
101 messages
Posté le 11 juin 2018 - 09:06
Up s' il vous plait.
Membre enregistré
101 messages
Posté le 20 juin 2018 - 14:09
Rebonjour,

Quelqu' un pour m' aider ?

Merci.
Posté le 20 juin 2018 - 19:18
Bonsoir,
Tous marche, mais j'ai préféré mettre Apache et non IIS, mais si tu peux tu parametre les 2 en changeant les ports Je l'ai fait avec XAMPP en 5 min
Membre enregistré
101 messages
Posté le 22 juin 2018 - 10:13
Rebonjour,

Quelqu' un pour m' aider ?

Merci.