PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV 23 → iImprimeEtat sur serveur linux
iImprimeEtat sur serveur linux
Débuté par Multipass, 26 juin 2018 07:46 - 4 réponses
Membre enregistré
45 messages
Posté le 26 juin 2018 - 07:46
Bonjour à tous,

Je marche sur le chemin d'un site WB23 hébergé sur un ubuntu server 16.04. Je dois reconnaître que c'est très formateur, mais quelle perte de temps...

Je butte sur l'envoi d'un mail au format HTML basé sur un état basique. Tout fonctionne nickel en test mais une fois déployé, le mail arrive vide car le fichier HTML n'est pas généré.

Mon code :
iDestination(iHTMLGénérique,sFichierHTML) //
iImprimeEtat(ETAT_test)

Ce n'est pas un problème de droit car je peux créer le répertoire pour l'opération et des tests avec iDestination(iPDF, sFichierHTML) fonctionnent.

Faut-il une librairie particulière pour imprimer dans un fichier HTML ?
Y'a-t-il une incompatibilité entre la fonction iDestination(iHTML... et l'OS du serveur ?
ou faut-il que je change de lunettes car j'ai loupé un truc écrit bien gros dans l'aide en ligne...

Merci d'avance pour vos pistes !
Bon dèv à tous
Alain
Membre enregistré
232 messages
Popularité : +1 (1 vote)
Posté le 11 juillet 2018 - 16:10
Bonjour Alain,

Vu le nombre de réponses, j'espère que tu as pu te débrouiller seul comme un grand !
De mon côté je ne peux pas grand chose car comme beaucoup d'autres, le monde Unix et moi, sans être fâchés, nous sommes quelque peu séparés ! :) Sinon, c'est un problème qui est peut-être préférable de soumettre au ST ;)

Bon dev !

--
René MALKA
Membre enregistré
515 messages
Popularité : +3 (5 votes)
Posté le 29 juillet 2018 - 21:37
Bonsoir
En version 20 cela ne fonctionnait déjà pas (pdf oui)
Membre enregistré
45 messages
Posté le 30 juillet 2018 - 12:21
Bonsoir Philippe et Merci de porter ton attention sur ce sujet.

A noter que le ST que j'ai contacté n'a pas fait avancer le schmilblik : aucun rapprochement avec des problèmes connus...

Toi qui semble avoir une grosse expérience sous linux, as-tu rencontré des problèmes avec les polices TrueType qui visiblement ne sont pas gérées (car substituées) sous Ubuntu serveur 16.04 ?

Merci
A+
Membre enregistré
515 messages
Popularité : +3 (5 votes)
Posté le 30 juillet 2018 - 12:36
Bonjour
Désolé je n'ai pas de réponse à cette question