PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV 24 → Lenteur table internet explorer
Lenteur table internet explorer
Débuté par Nic, 11 fév. 2019 11:49 - 7 réponses
Posté le 11 février 2019 - 11:49
Bonjour,

j'ai une table Ajax qui contient 34 colonnes et qui est renseignée par programmation avec 200 à 300 lignes.

Sous Firefox et Chrome ma table s'affiche en 1 à 2 secondes. Sous explorer j'attends entre 30s et 1 min avant qu'elle ne s'affiche. De plus lorsque je scroll avec l’ascenseur vertical de la table sous IE c'est inexploitable, tout est lent, si je veux entrer en saisie dans la table idem, c'est très lent.

Vous auriez une explication ? (suis en Webdev23)

Merci
Membre enregistré
108 messages
Posté le 11 février 2019 - 18:34
Bonjour Nic,

Serait il possible que vous ayez une "extension" antivirus associée a IE et non aux autres browser qui ralentirait l'affichage.

juste une idee

cordialement,

--
Xavier
Posté le 12 février 2019 - 09:14
Bonjour,

non pas d'extension.

J'ai parcouru un peu le forum j'ai pu voir que je n'étais le seul dans ce cas et que ca pourrait etre du aux tables AJAX.
Membre enregistré
223 messages
Posté le 12 février 2019 - 10:17
Bonjour, je pense que c'est normal, vu que IE n'est plus à jour concernant les technologies web, je pense que l'idéal serait de faire appel au champ réglette.
Membre enregistré
108 messages
Posté le 12 février 2019 - 10:54
Bonjour,

Nic vous dites que votre champ table est renseigne par programmation.
Vous pourriez vous faire un test en le renseignant par variable.
Au lieu de remplir la table directement vous remplissez une variable tableau (definit en global de votre page) qui sera elle associée au champs table.
Cette methode presente de nombreux avantages, dont la vitesse d'affichage.
La lenteur IE pourrait etre reduite par cette methode.

Bonne chance.

Cordialement,
Xavier

--
Xavier
Membre enregistré
399 messages
Popularité : +2 (2 votes)
Posté le 12 février 2019 - 14:12
Bonjour,

Dans la fenêtre description du projet, onglet Avancé, si vous choisissez html edge dans la norme HTML, est-ce que cela ne résout pas le problème?
Membre enregistré
2 messages
Posté le 12 février 2019 - 14:27
Bonjour,
J'ai le même problème, mais en plus les filtres de ma table on un "background-color : black;" je ne voit rien du tout et impossible de trouver ou modifier le style du petit menu contextuel des filtres.
Si quelqu’un sais comment le modifier, merci d'avance.
Cordialement,
Matthieu
Posté le 14 février 2019 - 11:13
Bonjour,

merci pour vos retours, je vais tester ca dès que possible, je reviendrais vers vous alors.

Cdt