PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV 27 → SERVEUR WEBDEV LINUX UBUNTU PROBLEMES DE PDF
SERVEUR WEBDEV LINUX UBUNTU PROBLEMES DE PDF
Débuté par patagon, 01 mar. 2020 17:38 - 7 réponses
Posté le 01 mars 2020 - 17:38
J'ai un serveur Web version 25 installé sur UBUNTU 18.04
Lors de l'exécution d'un état, les lettres n'apparaissent pas correctement dans le fichier

Image PDF linux:






le même document imprimé à l'aide du serveur de développement Windows:






En même temps, sur le serveur Linux si j'utilise dans champ upload: Variable Image=dChargeImage(UPL_Upload,imgConvertir) avec pdf ça ne marche pas (si j'utilise un fichier jpg, ça marche parfaitement.)

Quelqu'un a-t-il détecté ce problème?
Membre enregistré
22 messages
Popularité : +7 (7 votes)
Posté le 16 avril 2020 - 10:21
Hello,

Pour résoudre ton problème, il te faut installer les fontes ci-dessous.

sudo apt-get install xfonts-utils
sudo apt-get install libfreetype6-dev
sudo apt-get install xfonts-utils
sudo apt-get install libfreetype6


Meilleures salutations et bon Dev
Bernard Vésy
Posté le 16 avril 2020 - 15:52
Les polices sont déjà installées sur le système mais le problème persiste.

Le problème de chargement de PDF dans Serveur Linux semble être qu'il s'agit d'une erreur PCSOFT qui, je l'espère, sera résolue dans les futures mises à jour (dans la dernière, le problème persiste) .....

Merci de toute façon....:)
Membre enregistré
13 messages
Popularité : +1 (1 vote)
Posté le 25 juillet 2020 - 19:16
hello bernard, hello patagon,

j'ai eu le même gendre de souci

serveur linux debian v8.0 serveur d'application v250089_f chez online.





ma résolution : utilisation de la police courrier new dans mes états.
je sais, je sais, c'est moche mais cela fonctionne sur mon serveur dédié


je vais quand même ouvrir un "request" chez pcsoft



merci :merci:
Membre enregistré
13 messages
Popularité : +1 (1 vote)
Posté le 27 juillet 2020 - 10:47
hello,


ma solution de contournement :

mon site est avec option pas de retour arrière navigateur au niveau du projet

sur les bouton/image qui visualisent les pdfs (commande fichier FichierAffiche(sNomFich,typeMimePDF, SAI_Ref_Piece + ".pdf") ou
FichierAffiche(gCheminPieces,"application/unknown", SAI_Ref_Piece + ".pdf") )





j'ai mis ouvrir dans un nouvel onglet comme ca sur ios (iphone ipad) cela montre l'image en pdf et le bouton retour arrière navigateur marche

bonne lecture
Posté le 27 juillet 2020 - 12:27
Nous avons finalement changé le serveur webdev en Windows.
Tous les problèmes sont résolus ...
Membre enregistré
1 message
Posté le 28 août 2022 - 15:35
Hello,

Nous avons le même problème avec Webdev 26 sous Linux Oracle 8.5. Est-ce que l'installation des fonts sous Linux a pu vous permettre de résoudre le problème ? Ou faut-il mettre un serveur Windows pour un bon fonctionnement ?




Membre enregistré
78 messages
Popularité : +1 (1 vote)
Posté le 30 août 2022 - 09:37
Bonjour,

c'est un vieux problème. Nous avons finalement opté pour un serveur Windows (2019). Et si vous en avez le choix, il semble préférable de privilégier IIS à Apache pour bénéficier "naturellement" par exemple du serveur WebSockets de PC SOFT... même si ce n'est pas vraiment "naturel" pour un administrateur réseau Linux de choisir IIS à la place d'Apache :D

Cordialement. Gilles