PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WEBDEV 26 → Webdev / Accés Oracle OleDb/Odbc
Webdev / Accés Oracle OleDb/Odbc
Débuté par Sam, 13 jan. 2021 15:44 - 1 réponse
Posté le 13 janvier 2021 - 15:44
Bonjour,

N'ayant pas d'accès natif pour WB25, j'ai crée 2 connexions dans mon analyse une avec 'Oracle (Oracle Provider for OLE DB)) la seconde avec 'Accès ODBC par OLEDB'.

Dans les 2 cas, le test des connexions est réussi (bouton 'Tester' au niveau de la description de la connexion dans l'analyse).
L'accès à mes données par WDSql fonctionne, j'accède aux données désirées.

Pourtant, il m'est impossible de m'y connecter par programmation via les commandes suivantes :

//Ole DB
SI PAS HOuvreConnexion(MaConnexion1) ALORS
Erreur(HErreurInfo())
FIN
ou
//ODBC
SI PAS HOuvreConnexion(MaConnexion2) ALORS
Erreur(HErreurInfo())
FIN

Je précise que la source de données utilisées pour la connexion ODBC fonctionne aussi indépendamment de webdev (a la création de la source de données sous windows, je clique sur 'Tester', la connexion se fait également sans problème).

J'utilise WebDev25 (64 bits) sous W10 (64 bits) et un client Oracle (64 bits).

A noter que pour la même connexion (MaConnexion1) et le même code de connexion, ça fonctionne sans soucis en WD22.

Je connais bien windev mais débute sur WebDev ... mais pour ce qui est des connexions, je ne vois pas ce que ca peut changer !?

Merci de votre aide car là, je sèche totalement malgré des tas de tests et essais
Membre enregistré
695 messages
Popularité : +2 (2 votes)
Posté le 14 janvier 2021 - 18:40
Bonjour,
Les fonction Hxx ne sont possibles qu'avec un accès natif, si je ne me trompe.
Il faut plutôt utiliser SQLConnecte.

--
Thierry TILLIER
Développeur Windev-Webdev
Formation Windev : https://coursdinfo.teachable.com/
Formation bureautique : https://coursdinfo.net
Tuto WINDEV sur ma chaîne Youtube