PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV (précédentes versions) → probleme : restauration de la base de données
probleme : restauration de la base de données
Débuté par dev, 11 mai 2017 14:47 - Aucune réponse
Membre enregistré
1 message
Posté le 11 mai 2017 - 14:47
bonjour ,
je suis un débutant sur windev, j'ai crée un code de restauration de ma base ci-dessous, quand je lance la restauration , zipextraittout ne marche pas . quand je deploi un autre repertoire dans la fonction , il fait extraction dans ce dernier .

aide svp , c urgent .

code :

Datesauv est une chaîne

Datesauv=DateVersChaîne(DateDuJour,"jj_mm_aaaa")

// Déclaration et initialisation des variables
sNomRépertoire est une chaîne
NomArchive est une chaîne = "Données du " +Datesauv +".wdz"
CodeErreurCréation est un entier
CodeErreurAjout est un entier
CodeErreurExtrait est un entier

// Création d'une archive



REPERTOIRE1=fSélecteur("","Sélection d'un répertoire","Sélectionnez le répertoire ainsi que le fichier de la sauvegarde effectuée .",...
"*.wdz", "wdz", fselOuvre+fselExiste)



mainte_chaine="Restauration de la base des données "

SI REPERTOIRE1 <> "" ALORS
HFerme("*.*")


SI zipOuvre(NomArchive,REPERTOIRE1)=0 ALORS


CodeErreurExtrait = zipExtraitTout (NomArchive,zipDisque)

// Affichage du message d'erreur si les fichiers n'ont pas été extraits

SI CodeErreurExtrait = 0 ALORS
Info("Restauration de la base des données terminée avec succès !")

mainte=0
GR_sauvegarde..Etat=Grisé
HOuvre("*")


SINON // extrac
//Erreur("Erreur d'accès au fichier "+ComplèteRep(REPERTOIRE1)+"Archive.wdz !")
Erreur("Erreur d'accès au fichier "+REPERTOIRE1 +"!")

RETOUR
FIN // extrac
zipFerme(NomArchive)



SINON

Erreur("Erreur d'accès au fichier "+NomArchive +"!")
FIN
SINON

Erreur("Cliquer sur parcourir pour sélectionner un répertoire et la base de données à restaurer de type wdz ")

FIN