PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV (précédentes versions) → Erreur interne à la DLL WDHF en utilisant HFiltre
Erreur interne à la DLL WDHF en utilisant HFiltre
Débuté par David, 16 mai 2018 09:33 - Aucune réponse
Posté le 16 mai 2018 - 09:33
Bonjour,
Nous rencontrons un plantage, non systématique, d'une application en clientèle avec le message suivant:


Erreur à la ligne 64 du traitement Procédure locale llControleDeclaration.
Vous avez appelé la fonction HFiltre.
Erreur interne à la DLL WDHF.

----- Informations techniques -----

Projet : Dubus_Standard_BR_2015

Appel WL :
Traitement de 'Procédure locale llControleDeclaration' (Menu_Principal.PROCEDURE.llControleDeclaration), ligne 64, thread 0
Fonction 'HFiltre', syntaxe 3

Que s'est-il passé ?
Erreur interne à la DLL WDHF.

Code erreur : 70199
Niveau : erreur fatale (EL_FATAL)
Code erreur WD55 : 199

Dump de l'erreur du module 'WD180HF.DLL' (18.0.106.0).
Identifiant des informations détaillées (.err) : 72326
Informations de débogage :
##InternalError##
Fonction (7,31)
Informations supplémentaires :
EIT_LOGICALTABLENAME : <DEFGROUPE>
EIT_PILEWL :
Procédure locale llControleDeclaration (Menu_Principal.PROCEDURE.llControleDeclaration), ligne 64
Procédure globale bool_ppPrepareProgramme (Postprocesseur commun.bool_ppPrepareProgramme), ligne 114

D'ou peut provenir le problème ?



Extrait de code provoquant le plantage :
POUR TOUT OPERATION AVEC "IDPIECE="+NumériqueVersChaîne(PIECE.IDPIECE,"d")
sCle = HFiltre(DEFGROUPE,"NOM_GROUPE='"+OPERATION.NOM_OPERATION+"' ET ACTIF_SUR_PROFILS~]'#"+BARRE.NOM_PROFIL+"#'") //LIGNE PROVOQUANT LE PLANTAGE
SI sCle<>"" ALORS
HLitPremier(DEFGROUPE,sCle,hRespecteFiltre)
SI PAS HEnDehors(DEFGROUPE) ALORS
//Traitement N°1
SINON
//Traitement N°2
FIN
SI PAS HDésactiveFiltre(DEFGROUPE) ALORS Erreur("Filtre DEFGROUPE non désactivé")
FIN
HDésactiveFiltre(OPERATION)


OPERATION.NOM_OPERATION et BARRE.NOM_PROFIL sont des chaines de caractères et sont testées avec des simples quotes dans la condition de sélection.

Merci pour vos réponses