PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV (précédentes versions) → [WD20] NotifPushEnvoie marche toujours bien avec firebase?
[WD20] NotifPushEnvoie marche toujours bien avec firebase?
Débuté par NiceBel, 13 oct. 2021 13:16 - 1 réponse
Membre enregistré
476 messages
Posté le 13 octobre 2021 - 13:16
Bonjour,
en essayant d'envoyer une notification push depuis mon app desktop windev, j'ai en retour le message d'erreur: erreur système détectée pendant l'envoi de la requête HTTP. Voici le code:
tabTokensInvalides est un tableau de Buffers
tabIdentifiantsAEnvoyer est un tableau de Buffers
Google_API est une chaîne = "AAAAiCd0hic:APA91bFlfu0qj5oGCXXXX"

maNotif est un Notification
maNotif.Message = "hello"
maNotif.Titre = "Notification :"
TableauSupprimeTout(tabIdentifiantsAEnvoyer)
s est une chaîne UNICODE
s2 est une chaîne
POUR TOUT CLIENTS
SI CLIENTS.nom = "XXX" ALORS
Ajoute(tabIdentifiantsAEnvoyer,CLIENTS.idnotif_buf)
FIN
FIN

SI PAS NotifPushEnvoie(maNotif,tabIdentifiantsAEnvoyer,Google_API,tabTokensInvalides) ALORS
Erreur()
SINON
ToastAffiche("Notification Android envoyée avec succès.", toastCourt,cvBas,chCentre,TSL(360, 100, 50))
FIN


Je stock l'identifiant push que je reçoit sur mon app mobile sur la rubrique: CLIENTS.idnotif_buf, format: image, son, ..

Merci !!
Membre enregistré
476 messages
Posté le 14 octobre 2021 - 01:03
c'est bon juste la taille de la rubrique qu'il fallait augmenter !
Normalement WD20 ne fonctionne qu'avec gcm et pas fcm !