PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV (précédentes versions) → Affichage mail avant envoi
Affichage mail avant envoi
Débuté par Cédric DSMRS, 06 mai 2022 10:55 - Aucune réponse
Membre enregistré
2 messages
Posté le 06 mai 2022 - 10:55
Bonjour à tous,

Voila, j'ai un problème que je n'arrive pas à résoudre.
Je souhaite préparer un mail via différentes actions sur mon appli WD, mais que ce mail ne s'envoie pas automatiquement via la fonction EmailEnvoieMessage

Mes postes sont tous équipés d'Outlook (Soit version O365 ou 2016).

J'arrive bien à générer le mail et l'envoyer automatiquement via Outlook, mais je n'arrive pas à "stopper" cet envoi automatique pour que l'utilisateur puisse ajouter des informations avant envoi (genre une copie d'un contact de son carnet d'adresse, etc.).

Sur le doc (https://doc.pcsoft.fr/?3032005&verdisp=190), il est indiquer l'option <Résultat> = EmailEnvoieMessage(<Id session> [, <Email> [, <Afficher> [, <Type>]]]) avec Afficher à Vrai pour affichier la boite de dialogue avant envoi (on parle bien de la fenêtre de mail?)

Le code ci-dessous fonctionne mais envoie le mail automatiquement
gnIdSession = EmailOuvreSession("")
// ***********************************************
// Code fonctionnel pour la génération du mail
// ...
// ***********************************************
SI PAS EmailEnvoieMessage(gnIdSession) ALORS
Erreur ("Impossible d'envoyer le message", ErreurInfo(errMessage))
FIN


Le code ci-dessous ne fonctionne pas et me dit que ma session est invalide
gnIdSession = EmailOuvreSession(OutlookProfilDéfaut())
// ***********************************************
// Code fonctionnel pour la génération du mail
// ...
// ***********************************************
SI PAS EmailEnvoieMessage(gnIdSession) ALORS
Erreur ("Impossible d'envoyer le message", ErreurInfo(errMessage))
FIN


Le code ci-dessous ne fonctionne pas et me dit "Impossible d'ouvrir une session asynchrone car le spooler de mail n'est pas actif"
MaSession est emailSessionOutlook
MaSession.nom = "Outlook"
gnIdSession = EmailOuvreSession(MaSession)
// ***********************************************
// Code fonctionnel pour la génération du mail
// ...
// ***********************************************
SI PAS EmailEnvoieMessage(gnIdSession) ALORS
Erreur ("Impossible d'envoyer le message", ErreurInfo(errMessage))
FIN


La seule solution que j'ai trouvé est d'utiliser la fonction EmailOuvreMessagerie() mais celle-ci ne me permet pas de mettre des fichiers joints.

Je tourne en rond, donc si quelqu'un peut me venir en aide, je suis preneur! ;)
Message modifié, 06 mai 2022 - 10:56