PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV (précédentes versions) → GglConnecte comment vérifier la validité du token ?
GglConnecte comment vérifier la validité du token ?
Débuté par Anthony, 20 mai 2022 10:51 - Aucune réponse
Membre enregistré
64 messages
Popularité : +1 (1 vote)
Posté le 20 mai 2022 - 10:51
Bonjour,

J'utilise la fonction GglConnecte afin de de me connecter à mon agenda et effectuer les changements demandés.
Je suis de temps en temps (voir souvent) dans l'obligation de redonner l'autorisation pour accéder au compte alors que je stocke dans un fichier xml la connexion. Je pense qu'il y a un problème de validité de token, là est ma question, comment en utilsant GglConnecte puis-je vérifier la validité du token ?

J'ai bien essayé d'intégrer ces conseilles =>
https://blogs.pcsoft.fr/fr/conserver-token-connexion-oauth-2-reutiliser/281474976711024/read.awp


Mais je ne vois pas comment cela peut être intégré avec la fonction GglConnecte qui utilise déjà Aouth2...

Je vous remercie par avance de votre aide sur ce sujet ! :merci:
soit sFichierPersistanceAuth = ComplèteRep(fRepExe()) + "Google.xml"
// Si connexion déjà effectuée
SI fFichierExiste(sFichierPersistanceAuth) ALORS
// Restauration de la connexion
soit bufDésérialise = fChargeBuffer(sFichierPersistanceAuth)
Désérialise(Cnx, bufDésérialise, psdXML)
SINON
// Nouvelle connexion
Cnx.Email = gsMonEmail
Cnx.ClientID = gsMonClientID
Cnx.ClientSecret = gsMonClientSecret
FIN

SI GglConnecte(Cnx, gglServiceAgenda) ALORS
// Sauvegarde de la connexion pour réutilisation future
bufSérialise est un Buffer
Sérialise(Cnx, bufSérialise, psdXML)
fSauveBuffer(sFichierPersistanceAuth, bufSérialise)
RENVOYER VRAI
SINON
RENVOYER FAUX
FIN