PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 25 → Web Service Client HTTPS - erreur 100138
Web Service Client HTTPS - erreur 100138
Débuté par soli, 05 juin 2014 12:14 - 13 réponses
Membre enregistré
29 messages
Posté le 05 juin 2014 - 12:14
Bonjour,

J'essaye d'utiliser le webservice mailgun.com pour envoyer des emails ...
J'utilise donc les méthodes HTTPCréeFormulaire, etc...

Mais HTTPEnvoieFormulaire me renvoit une erreur 100138 ... Impossible de savoir à quoi cela correspond.

Quelqu'un a déjà utilisé mailgun.com pour l'envoi d'email ?

Merci pour votre aide
Posté le 05 juin 2014 - 13:43
Bonjour,
As-tu essayé d'ignorer l'erreur ?

HTTP.IgnoreErreur = 100138
Posté le 05 juin 2014 - 14:14
Bonjour Olivier

je viens de googler "erreur 100138" et je suis tombé immédiatement (2ème
réponse) sur l'aide de windev qui comporte un commentaire utilisateur :

Si vous obtenez une erreur 100138 / 12057 à l'éxécution
Cette erreur survient lors de l'utilisation de services en HTTPS.

Il faut décocher dans les options internet explorer le paramètre
"Vérifier la révocation des certificats serveur*" ( Options internet,
onglet Avancé, branche Sécurité )


Il y aussi d'autres résultats possibles

Google est ton ami

Cordialement


--
Fabrice Harari
Consultant WinDev, WebDev et WinDev Mobile International

NOUVEAU: WXShowroom.com est disponible : Montrez vos projets !
Plus d'information sur http://fabriceharari.com


On 6/5/2014 4:14 AM, soli wrote:
> erreur 100138
Membre enregistré
29 messages
Posté le 05 juin 2014 - 14:38
Cela ne semble avoir aucun effet !?

C'est une url du style : https://<user>:<pass>@api.mailgun.net/v2/... que j'essaye d'attaquer ...
Membre enregistré
29 messages
Posté le 05 juin 2014 - 14:45
@Fabrice, oui google est mon ami aussi ... et j'ai déjà essayé de décocher cette option ... sans succès également
Posté le 05 juin 2014 - 16:12
Essaye d'appeler l'url https://api.mailgun.net/v2/ et de spécifier le user/pass dans les paramètres du HTTTPEnvoieFormulaire
Posté le 07 juillet 2014 - 13:55
essaye avec
HTTP.IgnoreErreur = 63 (cela fonctionne pour moi)
Posté le 14 novembre 2014 - 16:06
Bonjour,

avez-vous résolu votre problème ? J'ai la même erreur que vous, et HTTP.IgnoreErreur ne donne rien quelle que soit la constante passée...

Merci
Posté le 04 décembre 2014 - 10:52
Bonjour,

Est-ce que quelqu'un a réussi à résoudre le problème de l'erreur 100138, svp ?

Je rencontre cette erreur avec une requête HTTPS.
J'ai essayé sur plusieurs Windows (XP, Vista, 8.1) Toujours la même erreur...

Merci.

Sébastien
Membre enregistré
71 messages
Posté le 12 juillet 2017 - 16:35
Bonjour,

Avez vous résolu votre problème?
Je le constate sur Webdev 22 avec un RESTEnvoie

merci de votre retour
Membre enregistré
71 messages
Posté le 12 juillet 2017 - 17:19
Je me réponds: Problème de proxy ...
Membre enregistré
24 messages
Posté le 03 mai 2018 - 13:17
bonjour Jeremie MARCHAND

tu peux preciser un peu comment tu t'es débarassé du blème, j'ai essayer avec "Proxy(NetAdresseIP())" avant le RestEnvoie()
ça ne marche tjrs pas avec https
Membre enregistré
71 messages
Posté le 04 mai 2018 - 10:28
Bonjour,

J'ai seulement changer de réseau pour tester mes web services, je n'ai pas modifier mon code.
Le réseau avec lequel je testais devais avoir un proxy qui me bloquait les requête.

Cdlt,
Posté le 21 décembre 2018 - 16:23
Pour compléter les réponses, j'ai résolu ce problème en augmentant la durée du HTTPTIMEOUT