PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 24 → Problème pour envoyer des mails avec gmail
Problème pour envoyer des mails avec gmail
Débuté par Jennifer Broyer, 31 aoû. 2017 14:48 - 68 réponses
Posté le 31 août 2017 - 14:48
Bonjour,
Nous utilisons la fonction EmailOuvreSession() pour pouvoir envoyer des mails depuis une application développé en windev 22.
Jusqu'à maintenant aucun problème, on paramètre la session SMTP.


Mais quelques temps une cliente me signale un problème lorsqu'elle essaye d'envoyer des mails avec une adresse mail gmail, la session ne s'ouve pas et renvoi l'erreur suivante :
code erreur = 101002
message de l'erreur = "des erreurs de sécurité ont été détectées pendant la mise en place de la commuhnication
détail de l'erreur système : la signature du certificat ne peut pas etre verifiée"

Pourtant l'adresse mail est juste ainsi que tous les autres paramètres.
Voici ce qui est passé en paramètres pour ouvrir la session :
gSessionSMTP est une EmailSessionSMTP
gSessionSMTP..AdresseServeur="smtp.gmail.com"
gSessionSMTP..Nom= "****@gmail.com"
gSessionSMTP..MotDePasse= ***** //mot de passe du compte gmail
gSessionSMTP..Port=587
gSessionSMTP..Option = emailOptionSécuriséTLS

// 10 secondes pour le time out
EmailChangeTimeOut(10)

bOuvresession est un booléen=EmailOuvreSession(gSessionSMTP)

Je ne comprends pas car pour beaucoup d'autres clients qui ont un compte gmail, tout fonctionne parfaitement mais pas pour cette cliente qui est sous windows xp. Je ne sais pas si cela à de l'importance.

Merci d'avance pour votre aide.

Jennifer
Posté le 01 septembre 2017 - 15:06
Bonjour,
nous rencontrons des problèmes équivalents depuis plusieurs jour avec des boites mail gérées par google (gmail ou gsuite)
avec le retour suivant : Une chaine de certificats a été traitée mais s'est terminée par un certificat racine qui n'est pas approuvé par le fournisseur d'approbation"

il s'agit d'un pb complètement aléatoire car certain mail ne passant pas vont passer quelques minutes plus tard
pas de pb avec d'autre smtp

si quelqu'un avait une piste, une solution

par avance Merci
Vero
Posté le 01 septembre 2017 - 17:47
J'ai également ce message qui apparait chez d'autres clients qui utilise également un compte gmail pour faire partir leur mail depuis l'application :
Code erreu = 101000
"Le mécanisme de sécurité du WLangage a détecté une erreur système.
Détail de l'erreur système : Une chaîne de certificats a été traitée mais
s’est terminée par un certificat racine qui n’est pas approuvé par le
fournisseur d’approbation."
Membre enregistré
55 messages
Posté le 01 septembre 2017 - 21:18
J'ai le même message que vous et je ne comprends pas pourquoi ce blocage apparaît d'un coup ?
Membre enregistré
30 messages
Posté le 02 septembre 2017 - 10:53
Bonjour. J ai egalement le meme probleme chez certain de mes client mais pas chez moi. Apparement blocage de certain fournisseur d acces.
Membre enregistré
247 messages
Posté le 04 septembre 2017 - 11:09
Bonjour,

Je rencontre également le même problème depuis fin Aout.
Une solution ?

--
Baptiste CLOART
Freelance
b.cloart@blv-tech.com
06.88.74.80.65
www.linkedin.com/in/cloart
www.blv-tech.com
Posté le 04 septembre 2017 - 15:34
Bonjour,

Cela me rassure de voir que je ne suis pas la seule à avoir des erreurs lors de l'envoi de mails avec gmail.

Depuis mon dernier message, j'ai eu d'autres clientes qui ont également eu ce message d'erreur :
Code erreur = 101000
"Le mécanisme de sécurité du WLangage a détecté une erreur système.Détail de l'erreur système : Une chaîne de certificats a été traitée mais s’est terminée par un certificat racine qui n’est pas approuvé par le fournisseur d’approbation."

A l'inverse, une cliente qui m'avait signalé un problème, ne rencontre plus : ce qui monte, en effet, que c'est aléatoire.
J'ai envoyé un message au support technique de PC Soft. Leur réponse se limite à :
"Si le problème est apparu il y a une semaine sans modifications de votre part alors le problème n'est pas lié à votre programme. Le message d'erreur le confirme. Le problème ici est lié à votre certificat, celui-ci n'est certainement plus valide. Il vous faut contacter l'administrateur de ce serveur afin qu'il vérifie/réinstalle ce certificat.

Je vous souhaite de bons développements. "

Donc ça ne nous aide pas.

Dans Gmail, le paramètre "Autoriser les applications moins sécurisées" est bien activé.

Y-a-t-il d'autres endroits où on peut donner des autorisations dans le paramétrage de Gmail ?

Merci d'avance pour votre aide !
Jennifer
Membre enregistré
34 messages
Posté le 05 septembre 2017 - 22:41
Bonjour,
Idem pour moi. J'ai remarqué que le problème se présentait à partir de 16h ?!
Membre enregistré
1 809 messages
Posté le 06 septembre 2017 - 05:13
Bonjour,

Ca ne vient pas de ceci ? https://support.google.com/a/answer/6180220…
--
Cordialement,

Philippe SAINT-BERTIN
Géode Informatique
Message modifié, 06 septembre 2017 - 05:17
Posté le 06 septembre 2017 - 09:04
Bonjour
J'ai ce type de problème chez mes clients et j'ai réussi à m'en sortir en paramétrant le compte Gmail de façon a ce le compte accepte les applications moins sécurisées.
depuis cela fonctionne .
Membre enregistré
247 messages
Posté le 06 septembre 2017 - 11:48
Bonjour,

Chez moi le paramètre est déjà activer. Et le problème est quand même présent.





--
Baptiste CLOART
Freelance
b.cloart@blv-tech.com
06.88.74.80.65
www.linkedin.com/in/cloart
www.blv-tech.com
Posté le 08 septembre 2017 - 15:38
Idem pour moi, ce paramètre est déjà activé.
Et j'ai de plus en plus de clients qui sont concernés par le pb.
Membre enregistré
247 messages
Posté le 08 septembre 2017 - 17:42
Bonjour,

J'ai apparemment résolu le problème sur les comptes Gsuite en modifiant l'adresse du serveur SMTP par :
smtp-relay.gmail.com

J'ai également changer le serveur SMTP dans les paramètre de compte Gsuite.

--
Baptiste CLOART
Freelance
b.cloart@blv-tech.com
06.88.74.80.65
www.linkedin.com/in/cloart
www.blv-tech.com
Membre enregistré
4 messages
Posté le 09 septembre 2017 - 15:39
Bonjour,

Même problème de mon côté et n'ayant pas trouvé comment utiliser smtp-relay.gmail.com dans les paramètres Gsuite, j'ai codé une classe en C# que j'ai importé comme assemblage .Net pour envoyer les emails et ne plus utiliser les fonctions WLanguage d'envoi d'emails.

Pour le moment plus de soucis...
Membre enregistré
2 messages
Posté le 02 octobre 2017 - 04:43
J'ai eu le même soucis fin Aout début Septembre, et puis tout est rentré dans l'ordre sans aucune modification de ma part si ce n'est l'installation de divers certificats recommandés lors de mes recherches (Mais je précise que cela n'avait eu aucun effet).

Et puis voilà que depuis hier, ça recommence.

Si quelqu'un a une solution elle sera la bienvenue, en attendant, lors de l’échec d'un envoi, je renvoie depuis un autre compte et surtout un autre fournisseur.
Membre enregistré
125 messages
Posté le 02 octobre 2017 - 11:29
Bonjour,
Même soucis chez nous, que ce soit en WINDEV ou en WEBDEV, via le serveur 2012S ou en local.
Sur tous les comptes GMAIL.
Donc difficile de croire que c'est un problème de configuration de nos certificats, seuls les produits WD et WB sont en cause, bien que nous soyons en v22 Update 4.
Par contre dans notre bon vieux Outlook, les comptes marchent ...
Le problème était apparu en effet en fin d'après midi, puis s'était calmé et maintenant depuis quelques jours c'est toute la journée.
Je précise que nous ne faisons que lire les mails en POP ou IMAP, pas d'envoi.

bResultat est un booléen
cMaSession est une EmailSessionPOP3
cMaSession.AdresseServeur="pop.gmail.com"
cMaSession.MotDePasse="secret"
cMaSession.Nom="xxxx@gmail.com"
cMaSession.Option=optionSSL
cMaSession.Port=995
bResultat= EmailOuvreSession(cMaSession)

Session POP3 : la connexion a échoué. Le serveur ne répond pas.
Le mécanisme de sécurité du WLangage a détecté une erreur système.
Détail de l'erreur système : Une chaîne de certificats a été traitée mais s’est terminée par un certificat racine qui n’est pas approuvé par le fournisseur d’approbation.
Posté le 02 octobre 2017 - 12:06
Bonjour,
Le support technique de PCSoft est au courant et ils sont en train de travailler dessus.
Donc à moins d'attendre le correctif ou de passer par un service spécialisé de Relai-smtp il n' y a pas vraiment d'autres solutions.
Membre enregistré
125 messages
Posté le 02 octobre 2017 - 13:14
Bonjour DAVY,
Certes mais cela fait déjà au moins 15 jours que le problème est apparu.
Et un service de relais smtp n'a aucune influence sur la lecture en pop ou imap ...
Donc il y a urgence !
François
Posté le 02 octobre 2017 - 15:06
Bonjour avant de lancer le emailouvresession , vous pouvez rajouter l'instruction

HTTP.IgnoreErreur = httpIgnoreCertificatExpiré

Pour ma part cela a résolu mon problème.
Membre enregistré
23 messages
Popularité : +1 (1 vote)
Posté le 02 octobre 2017 - 15:25
Bonjour,
Pb soulevé ce matin par un de nos clients (envoi de mails via le smtp de gmail) et solutionné en activant la validation en 2 étapes dans Google et en générant un nouveau mot de passe pour les applications de messagerie. :)

--
otto.matic@outlook.fr
Membre enregistré
125 messages
Posté le 02 octobre 2017 - 16:04
PCSOFT vient de me répondre que l'incident a été enregistré avec la référence 104 970
Posté le 02 octobre 2017 - 16:07
Le 2 octobre 2017 à 13:25, dans
<news:20177575b5437faab3b866717ec7a03062d8@news.pcsoft.fr>, OttoMatic
nous disait :

Pb soulevé ce matin par un de nos clients (envoi de mails via le smtp
de gmail) et solutionné en activant la validation en 2 étapes dans
Google et en générant un nouveau mot de passe pour les applications
de messagerie. :)


Il est possible d'avoir un peu plus de précisions sur la marche à suivre
?

Merci d'avance.

--
Eric
Membre enregistré
23 messages
Popularité : +1 (1 vote)
Posté le 02 octobre 2017 - 17:40
Dans votre compte Google :
1- Aller à Connexion et sécurité -> Activer Validation en deux étapes. Suivre le processus..
2- Quand on revient une 2eme fois sur Connexion et sécurité, un nouveau menu s'affiche en bas de Validation en 2 étapes : "Mots de passe d'application".
3- Dans ce nouveau menu, Sélectionner Messagerie + Ordinateur Windows. Un nouveau mot de passe de 16 car va être généré.
C'est ce nouveau mot de passe qu'il faudra utiliser dans votre code windev à la place de votre mot de passe gmail habituel.
--
otto.matic@outlook.fr
Message modifié, 02 octobre 2017 - 17:46
Membre enregistré
23 messages
Popularité : +1 (1 vote)
Posté le 02 octobre 2017 - 17:41



















--
otto.matic@outlook.fr
Posté le 02 octobre 2017 - 18:42
Le 2 octobre 2017 à 15:40, dans
<news:20179f8a4887c7e6efc9566403feaf89464a@news.pcsoft.fr>, OttoMatic
nous disait :

Dans votre compte Google :
1- Aller à Connexion et sécurité -> Activer Validation en deux étapes. Suivre le processus..
2- Quand on revient une 2eme fois sur Connexion et sécurité, un nouveau menu s'affiche en bas de Validation en 2 étapes : "Mots de passe d'application".
3- Dans ce nouveau menu, Sélectionner Messagerie + Ordinateur Windows. Un nouveau mot de passe de 16 car va être généré.
C'est ce nouveau mot de passe qu'il faudra utiliser dans votre code windev à la place de votre mot de passe gmail habituel.


Merci de ces précisions. En revanche, cela oblige-t-il le client à
reparamétrer son accès à Gmail depuis, par exemple, son téléphone
portable ?

--
Eric
Posté le 03 octobre 2017 - 05:34
Roland a écrit :
Bonjour avant de lancer le emailouvresession , vous pouvez rajouter l'instruction

HTTP.IgnoreErreur = httpIgnoreCertificatExpiré

Pour ma part cela a résolu mon problème.


Juste pour vous tenir au courant, cela n'a rien changé du tout
Posté le 03 octobre 2017 - 05:36
OttoMatic a écrit :
Bonjour,
Pb soulevé ce matin par un de nos clients (envoi de mails via le smtp de gmail) et solutionné en activant la validation en 2 étapes dans Google et en générant un nouveau mot de passe pour les applications de messagerie. :)

--
otto.matic@outlook.fr


Testé et malheureusement ce n'est toujours pas la solution. Ceci étant, le problème est toujours aléatoire car certains emails sont bien envoyés avec gmail et d'autres tombent en erreur.
Posté le 03 octobre 2017 - 10:59
Bonjour,

Avez vous essayé de mettre à jour les certificats suivants ?
https://pki.google.com/ ->Google Internet Authority G2
https://pki.goog/

Cordialement.
Posté le 03 octobre 2017 - 11:20
Bonjour,

De mon côté c'est à jour, mais ça ne fonctionne toujours pas.

Cordialement
Membre enregistré
23 messages
Popularité : +1 (1 vote)
Posté le 03 octobre 2017 - 11:29
Bon mauvaise surprise pour moi ce matin. Ma methode ne fonctionne plus.. :(
J'etais parti sur la création d'une dll C#...
Mais bonne nouvelle : Un tweet de Guillame Bayle nous apprend la solution. Testée et fonctionnelle cette fois !! :
https://twitter.com/GuillaumeBayle
Il suffit de rajouter l'instruction :
EmailParamètre(emailParamètreMode,1)

--
otto.matic@outlook.fr
Message modifié, 03 octobre 2017 - 11:34
Membre enregistré
55 messages
Posté le 03 octobre 2017 - 11:32
Bonjour,

Depuis fin Aout, Google a déployé un nouveau certificat : Google Internet Authority G3. Malheureusement, l’API Windows utilisée pour la vérification du certificat ne valide pas ce certificat.

Le déploiement de ce certificat est en cours et c’est ce qui rend aléatoire l’erreur de connexion. Cela dépend du serveur auquel vous vous connectez.

Afin d’éviter cette erreur, je vous conseille de changer le mode de gestion des emails. La commande EMailParamétre() permet de changer ce mode et ainsi de ne plus utiliser l’API Windows qui bloque ce certificat.
Voici le code à ajouter avant la connexion :

// Activation de l'implémentation multi-plateforme
EmailParamètre(emailParamètreMode, 1)


--
Loïc HAMEL (Twitter : @HAMELLoic)
Support Technique PC SOFT
Posté le 03 octobre 2017 - 12:07
Bonjour,

Sauf qu'en WEBDEV EmailParamètres() n'est pas dispo ... Que faire ?
Posté le 03 octobre 2017 - 13:13
Loic a écrit :
Bonjour,

Depuis fin Aout, Google a déployé un nouveau certificat : Google Internet Authority G3. Malheureusement, l’API Windows utilisée pour la vérification du certificat ne valide pas ce certificat.

Le déploiement de ce certificat est en cours et c’est ce qui rend aléatoire l’erreur de connexion. Cela dépend du serveur auquel vous vous connectez.

Afin d’éviter cette erreur, je vous conseille de changer le mode de gestion des emails. La commande EMailParamétre() permet de changer ce mode et ainsi de ne plus utiliser l’API Windows qui bloque ce certificat.
Voici le code à ajouter avant la connexion :

// Activation de l'implémentation multi-plateforme
EmailParamètre(emailParamètreMode, 1)


--
Loïc HAMEL (Twitter : @HAMELLoic)
Support Technique PC SOFT


Bonjour,

Seul bémol, cette commande n'est pas dispo sous webdev.
Membre enregistré
55 messages
Posté le 03 octobre 2017 - 13:45
Re-Bonjour,

Pour WEBDEV, la solution passe par l’installation d’un certificat spécifique en local. Nous sommes en cours de test du certificat Google supplémentaire.
Envoyez une demande au Support Technique Gratuit qui vous répondra dès que la solution sera validée.

--
Loïc HAMEL (Twitter : @HAMELLoic)
Support Technique PC SOFT
Membre enregistré
7 messages
Posté le 03 octobre 2017 - 17:03
Bonjour,

Quel certificat serait à installer ? Auriez-vous une marche à suivre pour mettre cela en place ?

Cordialement,
Lucas GILHARD
Membre enregistré
247 messages
Posté le 03 octobre 2017 - 22:17
Maintenant ont nous dit que le problème et connu depuis Fin Aout chez PC Soft....
Plusieurs sujets ont étaientt ouvert sur le forum pour ce problème. Aucun suivi pas le ST sur le forum....
Mes clients non pas pu envoyer leurs factures pendants 3 jours a cause de ce problème ! ( que j'ai du contourné seul )
Lors de mon appel au ST PC Soft,le technicien m'a littéralement pris pour un aliéné pour mon problème de "Mail qui s'envoyer/S’envoie pas aléatoirement à certaines heures.")

Je comprend que le problème ne viens pas de Windev en lui même. Mais il serait bon de signalé les problèmes de ce type par des Newsletters.

}:( }:( }:(

--
Baptiste CLOART
Freelance
b.cloart@blv-tech.com
06.88.74.80.65
www.linkedin.com/in/cloart
www.blv-tech.com
Membre enregistré
55 messages
Posté le 04 octobre 2017 - 09:07
Bonjour,

Dans le cas de WEBDEV, un nouveau module est disponible sur demande depuis notre site internet à l’adresse suivante :

https://stg.webdev.info/publicationSt_WEB/FR/miseajourst.awp

Ce module permet l’utilisation de EmailParamètre depuis WEBDEV.

--
Loïc HAMEL (Twitter : @HAMELLoic)
Support Technique PC SOFT
Membre enregistré
4 messages
Posté le 04 octobre 2017 - 10:49
Loic a écrit :
Bonjour,

Dans le cas de WEBDEV, un nouveau module est disponible sur demande depuis notre site internet à l’adresse suivante :

https://stg.webdev.info/publicationSt_WEB/FR/miseajourst.awp

Ce module permet l’utilisation de EmailParamètre depuis WEBDEV.

--
Loïc HAMEL (Twitter : @HAMELLoic)
Support Technique PC SOFT


Malheureusement pour ceux qui sont encore en version antérieure à la v22, pas de module ! On fait comment ?

Heureusement, ma dll en C# que j'utilise depuis début septembre m'a bien sauvée la vie et le problème ne se reproduit plus.
Message modifié, 04 octobre 2017 - 10:50
Posté le 04 octobre 2017 - 11:14
Merci Loic, je confirme, ça marche ! EmailOuvreSession() ne génère plus d'erreur avec gmail.
Bon cela a été un peu long le temps de charger l'update 5, puis le patch.
L'essentiel c'est que cela fonctionne.
Merci pour votre réactivité, on aimerait que cela le soit aussi pour des tickets ouverts depuis 3 ans ...
Membre enregistré
3 messages
Posté le 04 octobre 2017 - 15:40
Bonjour,

Savez-vous si un correctif sera proposé en version 21 pour la fonction EmailParametre ?
Cordialement
Membre enregistré
55 messages
Posté le 04 octobre 2017 - 17:00
Bonjour

Les acteurs majeurs dans ce domaine font évoluer sans cesse leurs solutions (Google, Apple, Microsoft, Firefox, etc…). Nous nous efforçons à PC SOFT d'intégrer ses évolutions pour vous rendre transparent tous ces soucis de compatibilité. Tous les jours nos équipes mettent en place des corrections et des contournements pour que malgré les changements de comportement des outils externes, vous n’ayez pas à reprendre vos projets.

Malheureusement, il est devenu impossible pour nous de reporter systématiquement les modifications dans les versions antérieures de WINDEV ou WEBDEV et WINDEV Mobile.

Il est important d’être à jour de nos produits pour bénéficier de cette veille technologique.

--
Loïc HAMEL (Twitter : @HAMELLoic)
Support Technique PC SOFT
Membre enregistré
21 messages
Posté le 05 octobre 2017 - 09:12
Bonjour,

et techniquement, qu'est ce qu'il reste pour les logiciels avec les précédentes versions ? A t on trouvé une solution utilisable ou il faut dire aux utilisateur, tout sauf gmail ? Il est impensable de transférer facilement une appli en 22 en claquant des doigts. La migration oui, mais il faut refaire les tests, et là il faut du temps. Apres bien sur chacun peut chercher de son coté mais une perte de temps pour tous. Ne réinventons pas la roue sur des détails technique comme ca.

Pour PCSOFT, Je pense que pour la 21 au minimum on devrait avoir techniquement un patch. Une aplli migré en 21 fin d'année dernière ne sera pas migré de suite en 22. (ca ne solutionne pas tout les pb , je sais pour les appli en 20 et autre (et j'en ai), mais ca c'est les developpeurs qui vont devoir imaginer et réinventé ou contourné)

Merci
Membre enregistré
151 messages
Posté le 05 octobre 2017 - 09:35
Pas cool pour les utilisateurs des précèdentes versions de windev.... :o
Membre enregistré
23 messages
Popularité : +1 (1 vote)
Posté le 05 octobre 2017 - 10:43
La solution pour ne plus être dépendant des hypothétiques maj de pcsoft et réagir rapidement à tout aléa est de créer ses propres bibliothèques .net (Visual Studio Community 2017 est gratuit..)
Dans le cas présent, ça prend au plus 15 mn à générer sa dll.

--
otto.matic@outlook.fr
Posté le 16 octobre 2017 - 08:49
Les envois de mails se font à présent depuis Windev, mais nous avons des procédures stockées qui font partir les mails en automatique (pour du rappel de rendez-vous par exemple) et là la procédure EmailParamètre() n'est pas disponible et ça ne marche toujours pas, toujours la même erreur :
Le mécanisme de sécurité du WLangage a détecté une erreur système.<\r><\n>Détail de l'erreur système : Une chaîne de certificats a été traitée mais s’est terminée par un certificat racine qui n’est pas approuvé par le fournisseur d’approbation.<\r><\n>



Certains d'entre vous ont-ils trouvé une solution pour webdev ou pour les procédures stockées ?

Merci d'avance.

Jennifer
Membre enregistré
57 messages
Popularité : +1 (1 vote)
Posté le 16 octobre 2017 - 15:08
OttoMatic a écrit :
La solution pour ne plus être dépendant des hypothétiques maj de pcsoft et réagir rapidement à tout aléa est de créer ses propres bibliothèques .net (Visual Studio Community 2017 est gratuit..)
Dans le cas présent, ça prend au plus 15 mn à générer sa dll.

--
otto.matic@outlook.fr



Bonjour,

donc le sav de pcsoft n'a pas 15 mn ?
Membre enregistré
3 messages
Posté le 18 octobre 2017 - 12:08
Nous avons effectué la migration de la 21 à la 22 et ajouté EmailParamètre(emailParamètreMode,1).
Plus de problème pour les envois SMTP.

En revanche, nous avons toujours un problème avec IMAP. La connexion s'effectue bien, mais au moment de parcourir les emails (boucle POUR TOUT) nous avons une erreur fatale UID FETCH :

Erreur à la ligne 21 du traitement Clic sur BTN_Test.
La dernière réponse du serveur IMAP est : 
<* 1 FETCH (UID 94967 BODY[] {5619}


L'erreur a un comportement aléatoire comme le soucis évoqué ici en SMTP.
Le code de test concerné :

sessionIMAP est un emailSessionIMAP
sessionIMAP.Nom = "monemail"
sessionIMAP.MotDePasse = "monpassword"
sessionIMAP.AdresseServeur = "imap.gmail.com"
sessionIMAP.Port = 993
sessionIMAP.Option = optionSSL

EmailParamètre(emailParamètreMode,1)

SI EmailOuvreSession(sessionIMAP) = Faux ALORS
Erreur(ErreurInfo(errMessage))
RETOUR
FIN

SI EmailChangeDossier(sessionIMAP, "INBOX") = Faux ALORS
Erreur(ErreurInfo(errMessage))
RETOUR
FIN


POUR TOUT monEmail de sessionIMAP // ICI ERREUR FATALE FETCH UID
sSujet est une chaîne = monEmail.Sujet
FIN
Message modifié, 18 octobre 2017 - 12:09
Membre enregistré
247 messages
Posté le 23 octobre 2017 - 10:50
Bonjour,

Pour ceux qui non pas WinDev22 et qui sont obliger de passer par une adresse Gmail pour l'envoi de leurs mails.
Merci de me contacter par mail. J'ai une solution.

--
Baptiste CLOART
Freelance
b.cloart@blv-tech.com
06.88.74.80.65
www.linkedin.com/in/cloart
www.blv-tech.com
Membre enregistré
30 messages
Posté le 23 octobre 2017 - 14:17
Le mieux est de partager votre solution. Cordialement
Membre enregistré
23 messages
Popularité : +1 (1 vote)
Posté le 24 octobre 2017 - 10:40
Bonjour,
Pour ceux que ça peut intéresser, je vous partage ma petite bibliothèque .net (explications dans le lisezmoi.txt)

https://www.dropbox.com/sh/3piw5900ip91n5n/AADvsFevDvnk2FKq0n6LGhWVa…

--
otto.matic@outlook.fr
Membre enregistré
23 messages
Popularité : +1 (1 vote)
Posté le 31 octobre 2017 - 10:52
DLL modifiée pour fonctionner en dehors de gmail avec l'ajout de l'authentification :

//Authentification
MonMail.Security = MailClass._None
//MonMail.Security = MailClass._Auto
//MonMail.Security = MailClass._SslOnConnect
//MonMail.Security = MailClass._StartTls
//MonMail.Security = MailClass._StartTlsWhenAvailable

--
otto.matic@outlook.fr
Membre enregistré
247 messages
Posté le 31 octobre 2017 - 19:24
Bonjour,

Voici mon Outil d'envoi mail pour Gmail avec les versions antérieur de Windev 22 :
https://drive.google.com/file/d/0B-z4ZkJaUw5OUHlBSy15RXJsNk0/view?usp=sharing


Vidéo explicative :


--
Baptiste CLOART
Freelance
b.cloart@blv-tech.com
06.88.74.80.65
www.linkedin.com/in/cloart
www.blv-tech.com
Membre enregistré
88 messages
Posté le 01 novembre 2017 - 10:23
Bonjour Baptiste,

Merci pour ta contribution.

Est ce que ta solution fonctionne avec toutes les versions de Windev, notamment avec la 19 ?

Cdl
Membre enregistré
247 messages
Posté le 02 novembre 2017 - 08:25
Sylvain RICAU a écrit :
Bonjour Baptiste,
Merci pour ta contribution.
Est ce que ta solution fonctionne avec toutes les versions de Windev, notamment avec la 19 ?
Cdl


Oui.

--
Baptiste CLOART
Freelance
b.cloart@blv-tech.com
06.88.74.80.65
www.linkedin.com/in/cloart
www.blv-tech.com
Membre enregistré
193 messages
Posté le 03 novembre 2017 - 09:35
OttoMatic a écrit :
Bonjour,
Pour ceux que ça peut intéresser, je vous partage ma petite bibliothèque .net (explications dans le lisezmoi.txt)

https://www.dropbox.com/sh/3piw5900ip91n5n/AADvsFevDvnk2FKq0n6LGhWVa…

--
otto.matic@outlook.fr


Bonjour,
merci mais ce serait bien d'avoir la source , par habitude on évite de mettre des dll venant d'ailleurs sans être sûr de leur fonction exact .
Membre enregistré
23 messages
Popularité : +1 (1 vote)
Posté le 03 novembre 2017 - 15:19
Bonjour,
Totalement d'accord avec vous au sujet des dlls externes :)
Je mets régulièrement mon source à jour. Vous êtes surement tombé à un moment où j'ai dû supprimé l'ancienne version pour y déposer la nouvelle.
Je travaille actuellement sur l'ajout du pilotage de Outlook pour voir si je n'ai pas les même soucis qu'avec l'automation de Windev que j'utilisais jusque là.
:merci:

--
otto.matic@outlook.fr
Message modifié, 03 novembre 2017 - 15:25
Membre enregistré
49 messages
Posté le 03 novembre 2017 - 15:41
Bonjour,
est-ce que ça serait possible d'avoir le code pour éviter d'avoir un .exe à lancer ?

J'explique : mon souci est que j'ai fait un web services pour pouvoir envoyer des mails. Plusieurs appli différente Windev envoie les paramètres du mail (objet, message, expéditeur, PJ...) et c'est le web services qui envoie. Je ne suis pas sure d'avoir les droits sur le serveur pour lancer un .exe.
Merci
Membre enregistré
247 messages
Posté le 03 novembre 2017 - 18:05
meumeu321 a écrit :
Bonjour,
est-ce que ça serait possible d'avoir le code pour éviter d'avoir un .exe à lancer ?

J'explique : mon souci est que j'ai fait un web services pour pouvoir envoyer des mails. Plusieurs appli différente Windev envoie les paramètres du mail (objet, message, expéditeur, PJ...) et c'est le web services qui envoie. Je ne suis pas sure d'avoir les droits sur le serveur pour lancer un .exe.
Merci


A quoi bon ci tu n'est pas en WinDev 22 ?

--
Baptiste CLOART
Freelance
b.cloart@blv-tech.com
06.88.74.80.65
www.linkedin.com/in/cloart
www.blv-tech.com
Membre enregistré
193 messages
Posté le 04 novembre 2017 - 19:18
Loic a écrit :
Bonjour

Les acteurs majeurs dans ce domaine font évoluer sans cesse leurs solutions (Google, Apple, Microsoft, Firefox, etc…). Nous nous efforçons à PC SOFT d'intégrer ses évolutions pour vous rendre transparent tous ces soucis de compatibilité. Tous les jours nos équipes mettent en place des corrections et des contournements pour que malgré les changements de comportement des outils externes, vous n’ayez pas à reprendre vos projets.

Malheureusement, il est devenu impossible pour nous de reporter systématiquement les modifications dans les versions antérieures de WINDEV ou WEBDEV et WINDEV Mobile.

Il est important d’être à jour de nos produits pour bénéficier de cette veille technologique.

--
Loïc HAMEL (Twitter : @HAMELLoic)
Support Technique PC SOFT


c'est une véritable honte pour PCsoft de ne pas rectifier ses dll sur des versions 19,20,21 au minimum ce qu'ils ont fait pour windows 10 creator (l'apercu avant impression qui plantait l'exe)
quand on utilise des vieilles source en c# pour envoyer des mails , cela fonctionne , pourquoi la leur déconne ? c'est abusé de dire que c'est une évolution des opérateurs .... c'est un oubli intolérable ....
il faut arrêté de programmer dans ce langage , c'est la preuve ,sinon : un cheque par an minimum et les nouveaux bug en +
Membre enregistré
23 messages
Popularité : +1 (1 vote)
Posté le 05 novembre 2017 - 10:40
Malheureusement, tous le monde ne maitrise pas le C. Windev est pour moi un langage semi professionnel conçu pour des personnes qui n'ont pa eu la base necessaire ou des developpeurs du dimanche, ce qui fait d'ailleurs sa force et sa faiblesse.. Un developpeur qui se respecte passera son chemin.

--
otto.matic@outlook.fr
Membre enregistré
472 messages
Popularité : +2 (4 votes)
Posté le 05 novembre 2017 - 22:58
Bonsoir,

Quelque soit le language, il n'est pas tolérable d'avoir à payer ( chèrement ) les dernières versions afin d'assurer le bon fonctionnement des applications écrites dans des versions antérieures ! Business is business! Pigeon is pigeon. }:(

--
Christian - kick71
Membre enregistré
1 367 messages
Popularité : +9 (11 votes)
Posté le 16 novembre 2017 - 15:38
Bonjour,

J'envoie des emails par Gmail avec une ancienne version d'un produit Wx (la 18). Cela fonctionne bien à ce jour...

Je rajoute simplement cette ligne :

HTTP.IgnoreErreur = httpIgnoreCertificatExpiré

EmailChangeTimeOut(10) // 10 secondes pour le time out
SI EmailOuvreSessionSMTP(...)


Pour Mailjet (exemple):
RESMAIL = EmailOuvreSessionSMTP("566487afbe4.....", "7a8513e4e8c....." , "in.mailjet.com" )
SI RESMAIL = Vrai ALORS
Email.NbAttache = 0
Email.NbDestinataire = 1 //
Email.Destinataire[1] = URLEncode(...)
Email.Expéditeur =
Email.Sujet =
Email.Message =
SI EmailEnvoieMessage("566487afbe4.....") = Faux ALORS ...
fin

--
Cordialement
François

http://intra.fr http://intrasoftware.fr
Membre enregistré
88 messages
Posté le 16 novembre 2017 - 17:35
Bonjour François

En W19, je n'arrive pas à me connecter à une session IMAP pour un compte gmail.

Aurais tu une solution ?

Cdl
Membre enregistré
247 messages
Posté le 17 novembre 2017 - 07:58
Quelqu'un sait il utilisé les API Gmail avec Windev ?

Voici où j'en suis actuellement :

https://forum.pcsoft.fr/fr-FR/pcsoft.fr.windev/211594-windev-mailgun-211725/read.awp

--
Baptiste CLOART
Freelance
b.cloart@blv-tech.com
06.88.74.80.65
www.linkedin.com/in/cloart
www.blv-tech.com
Membre enregistré
1 367 messages
Popularité : +9 (11 votes)
Posté le 17 novembre 2017 - 08:06
Désolé je n'ai pas d'expérience dans les API Gmail ni dans le protocole IMAP...

--
Cordialement
François

http://intra.fr http://intrasoftware.fr
Posté le 23 décembre 2017 - 15:09
Bonjours,
La solution c'est tout simplement commenter la ligne suivante:
//gSessionSMTP..Option = emailOptionSécuriséTLS

////
// Session SMTP non Sécurisée
gSessionSMTP est une EmailSessionSMTP
gSessionSMTP..AdresseServeur = "smtp.gmail.com"
gSessionSMTP..Nom = "compte@gmail.com"
gSessionSMTP..MotDePasse = " "
gSessionSMTP..Port = 587
//gSessionSMTP..Option = emailOptionSécuriséTLS
cordialement
Posté le 26 janvier 2018 - 14:36
Bonjour,

J'ai, pour ma part, développé une dll en C# .NET pour relever les emails sur Gmail en utilisant l'API, cela fonctionne très bien. Utiliser l'API directement Windev par contre pose certains inconvénients insolvables (d'après mon expérience...), notamment avec les types avec interface, IList<Object> par exemple.

Courage ! :)

PS : oui, Windev ça pose des problèmes majeurs dès qu'on veut développer vraiment. Mais parfois, le choix stratégique n’appartient pas aux développeurs... Il ne reste qu'à s'adapter. ^^
Posté le 26 janvier 2018 - 18:36
Romain D a écrit :
Bonjour,

J'ai, pour ma part, développé une dll en C# .NET pour relever les emails sur Gmail en utilisant l'API, cela fonctionne très bien. Utiliser l'API directement Windev par contre pose certains inconvénients insolvables (d'après mon expérience...), notamment avec les types avec interface, IList<Object> par exemple.

Courage ! :)

PS : oui, Windev ça pose des problèmes majeurs dès qu'on veut développer vraiment. Mais parfois, le choix stratégique n’appartient pas aux développeurs... Il ne reste qu'à s'adapter. ^^


Bonjour Romain
Est il possible de voir ta dll et comment tu as fait pour l'utiliser dans WD
Membre enregistré
3 messages
Posté le 30 janvier 2019 - 08:48
OttoMatic a écrit :
Bonjour,
Pour ceux que ça peut intéresser, je vous partage ma petite bibliothèque .net (explications dans le lisezmoi.txt)

https://www.dropbox.com/sh/3piw5900ip91n5n/AADvsFevDvnk2FKq0n6LGhWVa…

--
otto.matic@outlook.fr


Bonjour OttoMatic,

Est-ce que vous avez encore votre source à disposition ?

Merci d'avance