PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 25 → IMAP avec Gmail : Erreur FETCH UID
IMAP avec Gmail : Erreur FETCH UID
Débuté par Benjamin G, 19 oct. 2017 12:47 - 7 réponses
Membre enregistré
3 messages
Posté le 19 octobre 2017 - 12:47
Bonjour,

Depuis quelques semaines nous avons un problème aléatoire en IMAP avec Gmail. La connexion s'effectue bien, mais au moment de parcourir les emails (boucle POUR TOUT) nous avons une erreur fatale UID FETCH :

Erreur à la ligne 21 du traitement Clic sur BTN_Test.
La dernière réponse du serveur IMAP est : 
<* 1 FETCH (UID 94967 BODY[] {5619}


Le code de test concerné :

sessionIMAPest un emailSessionIMAP
sessionIMAP.Nom="monemail"
sessionIMAP.MotDePasse="monpassword"
sessionIMAP.AdresseServeur="imap.gmail.com"
sessionIMAP.Port=993
sessionIMAP.Option=optionSSL

EmailParamètre(emailParamètreMode,1)

SIEmailOuvreSession(sessionIMAP) =FauxALORS
Erreur(ErreurInfo(errMessage))
RETOUR
FIN

SIEmailChangeDossier(sessionIMAP,"INBOX") =FauxALORS
Erreur(ErreurInfo(errMessage))
RETOUR
FIN


POURTOUTmonEmaildesessionIMAP// ICI ERREUR FATALE FETCH UID
sSujetest une chaîne=monEmail.Sujet
FIN



>À noter qu'il s'agit d'un traitement en place depuis des années et qui n'avait posé de problèmes jusqu'à présent.
Posté le 20 novembre 2017 - 09:48
Bonjour,
Nous avons le meme probleme, avez vous une solution ?
salutations,
>Marc
Posté le 23 novembre 2017 - 14:51
Bonjour,

J'ai le même soucis avec la version 22 et dernière mise à jour
Connexion ok
Lecteur des messages ECHEC

>Salutation
Membre enregistré
37 messages
Posté le 08 décembre 2017 - 11:09
Meme pb
Posté le 08 décembre 2017 - 16:00
Bonjour à tous,

>J'ai fait un retour support, je suis en attente d'une réponse.
Membre enregistré
18 messages
Posté le 10 janvier 2018 - 16:09
EmailRécupèreTout(sessionIMAP,ertNonLus)

before

POUR TOUT monEmail de sessionIMAP// ICI ERREUR FATALE FETCH UID
sSujetest une chaîne=monEmail.Sujet
FIN

--
>Issa Bej
Posté le 20 août 2018 - 17:07
Bonjour, j'ai le même souci qui semble aléatoire (projet en WD22). Avez-vous une solution à celui-ci ? Cordialement
Membre enregistré
299 messages
Posté le 20 août 2018 - 19:38
Bonjour,

Je pense avoir eu le même souci.
J'avais par exemple 50 mails en attente.
Je faisais une boucle Pour Tout j'en lisais 10.

J'ai tourné en rond pendant des jours.
Le problème provenait du fait qu'un mail (dans mon cas le 11) posait problème et bloquait la suite.

Je m'en suis sorti en écrivant un Web Service en PHP qui lit TOUS les mails et récupère les ID.
WinDev lit ensuite le tableau d'ID récupéré
>Si un n'est pas lisible (donc EmailEnDehors = true) je ferme la connexion, je la réouvre et je poursuis.