PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 25 → Dégradation des performances des applications et de Windev lui-même
Dégradation des performances des applications et de Windev lui-même
Débuté par Thibault, 26 jan. 2018 09:27 - 8 réponses
Membre enregistré
5 messages
Posté le 26 janvier 2018 - 09:27
Bonjour,

Depuis maintenant plusieurs semaines je constate sur mes applications et sur Windev lui-même une dégradation des performances. Je m'explique : Les apps / Windev se met à ramer après un lancement prolongé (>24h). Seul le redémarrage du PC réinitialise le problème. Le pc que j'utilise pour le dev est un monstre de perf, donc pas à chercher de ce côté là.

En enquêtant plus précisément je retrouve des comportements tout simplement dingue. Par ex, je laisse Windev lancé le soir en partant, je reviens le lendemain matin et il a pris 1Go de ram en plus, sans aucune raison ! Et il ne s'arrête pas là, il continu à grignoter consciencieusement... 400Mo à l'ouverture de mon projet, 1,5Go le lendemain matin ! De même, s'il n'est pas afficher, il consomme 0% de proc, dès sont affichage, il monte à 20%. Soit. Il redescend aussi sec après, ce qui e parait normal, mais le simple fait de passer la souris sur l'explorateur de projet ou d'afficher une bulle sur un champ, on monte à 30% !

Il en résulte une lenteur générale de Windev, lenteur qui s'accentue avec le temps, jusqu'à devenir gênante et nécessite un redémarrage du PC. Les fenêtres mettent 4-5sec à s'afficher, le double-clic sur une fenêtre dans l'interface de dev met également 5sec à afficher la fenêtre de description... Je précise que seul Windev est impacté, toutes mes autres app n'ont aucun soucis (Firefox, Chrome, Photoshop, divers apps...). J'ai déjà essayé plein de truc : réinstall de Windev sur un autre poste, désactivation de l'AV, execution en local des app/bdd...

Et ce comportement se retrouve dans mes applications ! J'ai des app qui tournent en tâche de fond, en v22 et en v23, même combat. Les app des utilisateurs en viennent même à clignoter (dû à l'absence de réponse de la fenêtre) dans tous les sens sur certains postes... Toutes les versions Workstation de Windows sont touchés (Xp, 7 et 10) mais pas les versions Server (2008, 2012 et 2016 !!!). Gestion de domaine AD, serveur WSUS (tous mes Windows sont ultra à jour). Rapport avec Meltdown/Spectre ?!

Tout ça pour en venir au fait que cela ne concerne que Windev et ses applications. Pour l'instant on contourne le problème en redémarrant le pc une fois par jours, mais ce n'est pas une solution. Est-ce que quelqu'un rencontre ce problème ? Au delà de l'aspect de la rame qui se rempli doucement (mais qui n'est pas forcément un problème handicapant en soit), c'est surtout l'installation d'une lenteur généralisée au fur et à mesure de l'utilisation qui est vraiment dommageable.

Si quelqu'un à une piste...
Message modifié, 26 janvier 2018 - 09:29
Membre enregistré
95 messages
Posté le 26 janvier 2018 - 12:41
Bonjour

En quel version de Windows êtes vous ?
Si vous êtes en Fall Creator Update (1709), il y a de forte chance que vous soyez victime du double bug de microsoft :
- le Control Flow Guard (CFG) a été activé
- Un bug d'allocation dans la DLL GDI provoque des allocations abusive qui active la protection du CFG et plombe les performances (de pas mal d'applis d'editeur tiers)

Microsoft doit corriger en théorie via le Patch du mardi (mardi prochain ???)

En attendant, vous pouvez désactiver le CFG : (de mémoire)
- Démarrer puis taper "Defender" pour afficher le "Centre de Sécurité Windows Defender"
- Dans le centre de sécurité : clic sur Control des applications et du navigateur
- Dans la liste, il doit y avoir une option parlant se la "protection du flux de control" ou "PFC" en bon français et qu'il faut désactiver

Ensuite, un reboot et les perf devrait revenir

En espérant que M$ corrige bien dans le prochain patch comme prévu

--
Si vous appréciez ma réponse, levez le pouce.
Membre enregistré
5 messages
Posté le 26 janvier 2018 - 13:53
Effectivement tous les postes sont en 1709.
Je teste votre solution et je reviens vous en informer.

Merci de cette réponse rapide et détaillé !

EDIT : Je viens d'effectuer la manipulation et de me renseigner sur ce double bug. C'est absolument hallucinant. Je vous confirme que seul mes machines Windows 10 (1709) sont touchées. Pas au point de certains comme ici :
https://www.tenforums.com/performance-maintenance/96792-fall-creators-update-poor-performance-lagginess-fix.html

Mais au bout de 24h l'effet se fait sentir. Et c'est proportionnel au nombre d'écrans !! Dans notre cas, des postes à 3 écrans...
Pourquoi Microsoft ou PCsoft ne communiquent-ils pas sur un soucis aussi grave ?! C'est quand même dingue !

DOUBLE EDIT : Bon bah le ST ne devait pas être au courant alors. merci M. Bayle d'en faire un article sur votre blog !
Message modifié, 26 janvier 2018 - 14:37
Membre enregistré
409 messages
Popularité : +3 (3 votes)
Posté le 26 janvier 2018 - 14:18
Bonjour

@David : merci pour ce retour très précis.

J'ai également ajouté l'information sur le blog du support afin que l'information circule, en attendant un retour à la normale du système.

http://blogs.pcsoft.fr/fr/ralentissement-station-windows-10-apres-application-update-fall-creators-update/281474976710719/read.awp

Bons développements !

--
Guillaume Bayle (Twitter : @GuillaumeBayle)
Support Technique PC SOFT
http://www.pcsoft.fr/st/index.html
Membre enregistré
5 messages
Posté le 26 janvier 2018 - 14:39
Guillaume BAYLE a écrit :
Bonjour

@David : merci pour ce retour très précis.

J'ai également ajouté l'information sur le blog du support afin que l'information circule, en attendant un retour à la normale du système.

http://blogs.pcsoft.fr/fr/ralentissement-station-windows-10-apres-application-update-fall-creators-update/281474976710719/read.awp

Bons développements !

--
Guillaume Bayle (Twitter : @GuillaumeBayle)
Support Technique PC SOFT
http://www.pcsoft.fr/st/index.html


A priori un patch devait sortir en décembre, repoussé au 23 janvier 2018. Et repousser de nouveau au 30/01/2018.
A voir à partir de mercredi prochain !
Posté le 26 janvier 2018 - 18:25
Bonjour,

Quant à moi, je rencontre des problèmes de lenteur chez un client avec une application utilisée en bureau à distance mais sur Windows 2012 Serveur R2 X64. Y aurait-il aussi une explication du même style ?
Posté le 29 janvier 2018 - 10:59
Merci pour l'information,
Je tente d'appliquer cette procédure et revient vous donner des nouvelles
Membre enregistré
409 messages
Popularité : +3 (3 votes)
Posté le 05 février 2018 - 17:45
Thibault a écrit :
A priori un patch devait sortir en décembre, repoussé au 23 janvier 2018. Et repousser de nouveau au 30/01/2018.
A voir à partir de mercredi prochain !


Bonjour,

Une mise à jour pour Windows 10 (1709 - Fall Creators Update) a été publiée par Microsoft le 31/1/2018 avec la référence KB4058258.

Les retours sur cette mise à jour de Windows 10 par Microsoft sont positifs. Elle est accessible directement pas Windows Update.

J'ai complété le billet du blog avec l'info.

Bons développements !

--
Guillaume Bayle (Twitter : @GuillaumeBayle)
Support Technique PC SOFT
http://www.pcsoft.fr/st/index.html
Membre enregistré
3 messages
Posté le 02 septembre 2018 - 16:44
Jean-Luc Eggimann:

Bonjour Jean-Luc,
As-tu mis le doigt sur la cause du problème?
Merci.

--

Cordialement,
Domsheldon1 / Belgique