PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 23 → Problème de connexion à HFSQL avec windows 10 version 1803
Problème de connexion à HFSQL avec windows 10 version 1803
Débuté par Roda, 02 mai 2018 22:08 - 22 réponses
Membre enregistré
4 messages
Posté le 02 mai 2018 - 22:08
Bonjour,

Suite à une mise à jour d'un PC vers la version 1803 de Windows 10, une application générée
sous WinDev version 01F180062h installée sur le PC en question refuse désormais de se connecter
à un serveur HFSQL version 90F230050g, installé sur un windows server 2012 R2.

L'erreur HF renvoyée par l'application est 74000.

Cette application fonctionnait parfaitement bien sur le même PC lorsqu'il était sous Windows 10 version 1709.

Je vous remercie d'avance pour vos contributions.
Posté le 02 mai 2018 - 22:55
Bonjour,
nous avons remarqué le meme problème, le soucis c est pour la modification des données avec WDModfic ne se connecte pas au serveur
Membre enregistré
683 messages
Popularité : +3 (3 votes)
Posté le 03 mai 2018 - 10:00
Si le centre de controle est installé sur ce pc (sinon installez le), arrivez vous a vous connecter au serveur HFSQL avec ?
Membre enregistré
4 messages
Posté le 03 mai 2018 - 11:30
Bonjour François,

Je vous remercie pour la réaction. Le centre de contrôle installé sur le PC qui a windows 10 version 1803
ne se connecte pas non plus au serveur hyperfile v.23.

Il s'agit manifestement d'un problème lié à windows 10 version 1803, car les autres PC du parc qui ont
des versions de windows 10 antérieures à la version 1803 se connectent sans problème sur le même
serveur hyperfile v.23 avec la même application générée en windev 18.

Si vous avez d'autres idées, elles sont les bienvenues
Posté le 03 mai 2018 - 13:27
Bonjour,

La communication entre une application WINDEV (ou WINDEV Mobile) et le moteur HFSQL se fait via du TCP on ne peut plus standard, par défaut sur le port 4900.

Comme toute mise à jour, cette "April Update" a du avoir des interactions sur la sécurité (firewall, antivirus...).

Regardez en premier lieu de ce côté, en commençant par un Telnet sur le port auquel répond votre moteur ...

A+
Alex
Membre enregistré
4 messages
Posté le 03 mai 2018 - 14:47
Bonjour Alex,

Je vous remercie de votre contribution.

J'ai fait une série de tests qui m'ont permis de cerner le problème de manière plus précise:

Test n°1 : PC windows 10 v.1803 ne se connecte pas au serveur HFSQL installé sur windows server 2012 R2
Test n°2 : PC windows 10 v.1803 se connecte au serveur HFSL installé sur un windows 10 v.1803
Test n°3 : PC windows 10 v.1709 se connecte au serveur HFSQL installé sur windows server 2012 R2
Test n°4 : PC windows 10 v.1709 se connecte au serveur HFSL installé sur un windows 10 v.1803

Donc seul le test n°1 reste infructueux.
Posté le 03 mai 2018 - 15:51
re-bonjour,

Un test depuis l'invité de commande du PC windows 10 v.1803 avec :
Telnet <adresse serveur 2012> <4900 ou autre si vous l'avez changé>

serait un bon test complémentaire.

A+,
Alex
Posté le 03 mai 2018 - 17:15
J'ai exactement le même probleme de connexion vers un serveur sql 2014 connexion oledb ou odbc.

ERROR [08001] [Microsoft][ODBC SQL Server Driver][DBNETLIB]Ce serveur SQL n'existe pas ou son accès est refusé.
ERROR [01000] [Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Connect()).

Suite a la mise a jour vers windows 10 1803.
Membre enregistré
4 messages
Posté le 03 mai 2018 - 17:18
La commande Telnet <adresse serveur 2012> <4900
envoyée à partir du PC windows 10 v.1803
passe sans problème.
Posté le 11 mai 2018 - 10:30
Bonjour,

nous rencontrons actuellement le même problème chez un de nos clients.
Le responsable informatique a fait la mise à jour Windows 10 1803 pour des corrections de problèmes et de lenteurs liés à Windows 10 1709 (qui sont effectivement corrigés en 1803) mais du coup ces postes n'ont plus accès au serveur HFSQL (qui est sur un Windows Server).
Il est revenu en arrière suite à cette mise à jour en version 1709 et cela fonctionne à nouveau, mais les problèmes liés à cette mise à jour de Windows 10 sont revenus, il souhaite donc rapidement remettre la 1803.
Est-ce qu'il faut attendre un patch de PCSoft comme pour le problème des impressions avec la 1709 ?
Ou est-ce qu'une modification de la base de registre ou autre hotfix permettrait de corriger cela ?

Merci
Posté le 11 mai 2018 - 11:24
Bonjour,
j'ai trouvé des éléments de réponse.
Est-ce que vous lancez ces exécutables depuis un partage Windows ?
Il semble que depuis la 1803, Windows bloque les accès réseau à un exécutable qui est lancé depuis un partage en Samba version 1.
Donc essayez de lancer ce même exécutable depuis un chemin local pour voir si cela marche.
Dans le cas où le Samba v1 est en cause, il faut tenter de monter le lecteur réseau via un Samba v2 ou v3.
Posté le 14 mai 2018 - 11:55
Le 11/05/2018 à 09:24, Simon a écrit :
Bonjour,
j'ai trouvé des éléments de réponse.
Est-ce que vous lancez ces exécutables depuis un partage Windows ?
Il semble que depuis la 1803, Windows bloque les accès réseau à un
exécutable qui est lancé depuis un partage en Samba version 1.
Donc essayez de lancer ce même exécutable depuis un chemin local pour
voir si cela marche.
Dans le cas où le Samba v1 est en cause, il faut tenter de monter le
lecteur réseau via un Samba v2 ou v3.


Bonjour,

En effet, rencontrant le même problème chez plusieurs clients, des tests
m'ont mené à une conclusion similaire :
- exécutable lancé en local cherchant à se connecter au server : OK
- exécutable lancé depuis un dossier partagé en réseau : KO

Votre poste m'a permis d'aller vérifier ces paramètres SMB sur le
serveur (2008 ici), et SMB2 était désactivé ! La réactivation suivie
d'un redémarrage a permis de rétablir le bon fonctionnement .

Cordialement,
Stéphane
Membre enregistré
353 messages
Popularité : +3 (3 votes)
Posté le 17 mai 2018 - 14:41
Bonjour,

L'information sur la nécessité d'utiliser des partages SMBv2 pour utiliser une application lancée depuis "Windows 10 April 2018 Update" mais placée sur un partage réseau, a été relayée dans les FAQ et le blogs.

http://faq.pcsoft.fr/16657-windows_10_april_update_connexion_hfsql_emailouvresession-read.awp

https://blogs.pcsoft.fr/fr/windows-10-april-2018-update-1803-attention-executables-windev-lances-ressource-partagee-serveur-peuvent-limites/281474976710738/read.awp

--
Guillaume Bayle (Twitter : @GuillaumeBayle)
Support Technique PC SOFT
http://www.pcsoft.fr/st/index.html
Posté le 18 mai 2018 - 00:01
Bonsoir à tous,

Le problème se produit également lorsque l'on veut se connecter depuis le centre de contrôle depuis un poste sous windows 10 version 1803 …

Pourtant rien n'est lancé depuis un partage, merci Microsoft :-(

Je ne trouve pas de solutions depuis les KB Microsoft ou pcsoft.
Posté le 18 mai 2018 - 10:53
Nous avons eu le même problème et mon collègue à trouvé une solution toute simple
le paramètre "Serveur" de la fonction HOuvreConnexion doit être passé en Majuscule :merci:
Posté le 24 mai 2018 - 09:01
L'astuce des majuscules a marché chez un de nos clients avec domaine

Chez un autre sans domaine, rien à faire, la dernière piste que j'ai c'est de passer le type de réseau en privé (mais nous avons fait un revert de la mise à jour depuis).
Quelqu'un aurait eu le même souci ?
Membre enregistré
25 messages
Posté le 24 mai 2018 - 10:13
J'ai le même genre de soucis. Sur certains postes qui ont fait la mise à jour ça fonctionne sur d'autres non.
Sur les postes qui ne fonctionnaient pas J'ai essayé les majuscules sans succès.

Finalement j'ai mis directement l'IP de mon serveur HFSQL et là ça refonctionne !
Posté le 25 mai 2018 - 10:53
J'avais le même soucis suite au passage d'un PC client en Windows 10 version 1803 : impossible de se connecter au moteur de BDD HFSQL alors que les autres PC du réseau fonctionnent bien.

Pour moi c'est de passer le nom du serveur en minuscule à HOuvreConnexion() qui a résolu le problème. :)

Peut-être faut-il à tout prix passer le nom du serveur tel qu'il a été écrit à l'origine sur la machine au moment de son installation (avec différenciation précise majuscule/minuscule)?

Merci pour cette astuce en tout cas. :merci:
Posté le 08 juin 2018 - 15:44
Je confirme que même en lançant depuis un dossier non partagé une application en client/serveur, le problème se produit chez certains clients.

Certes le client se connecte sur un répertoire partagé pour voir s'il y a une mise à jour.

Dans l'attente d'une solution
Posté le 11 juin 2018 - 10:28
Bonjour,
Chez de nombreux clients, nous avons le même soucis!
Sur les postes clients, le chemin de la BDD était le suivant :

[SERVEUR]
NomSource=NOMSERVEUR
CheminExeServeur=\\NOMSERVEUR\C\REPLOGICIEL
NomBase=MaBdd
NomUtilisateur=Toto
PassWord=Pass

En remplaçant NOMSERVEUR par l'adresse IP du Serveur, tout remarche!

Bonne journée
Membre enregistré
33 messages
Posté le 11 juin 2018 - 16:57
Bonjour, J'avais aussi remplacé le nom de la source et le chemin par l'adresse IP et ça fonctionnait par contre je n'avais plus de mise à jour
Depuis, J'ai indiqué le "nomserveur" en minuscule et maintenant tout remarche !

--
Julien
Membre enregistré
9 messages
Posté le 11 juin 2018 - 18:24
@julien
avez vous résolu ce prolème ?

--
https://fekwx.com | La meilleur communauté WX
Membre enregistré
33 messages
Posté le 12 juin 2018 - 08:10
Manim ANWAOU a écrit :
@julien
avez vous résolu ce prolème ?

--
https://fekwx.com | La meilleur communauté WX


Oui, je n'ai plus de problème de connexion . Mon serveur est sur un Windows 10 pro 1803 et les postes clients sont sur Windows 1803 et 1709 et ils se connectent tous sans problème maintenant, et le live update fonctionne aussi.

--
Julien