PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 23 → import base mysql windev 23 ne trouve pas mes table mais les trouve avec WD20
import base mysql windev 23 ne trouve pas mes table mais les trouve avec WD20
Débuté par karimou, 11 juil. 2018 13:02 - 9 réponses
Membre enregistré
22 messages
Posté le 11 juillet 2018 - 13:02
Bonjour,

Je viens de créer un nouveau projet avec WD23
Et j'aimerai importer une table de ma base mysql
donc lors de la création je mets bien base mysql je rentre bien toutes les données nécessaires et correct à la connexion serveur.
et dès que j'arrive à la création d'analyse "accéder directement...." les deux colonnes sont vide et normalement je suis censé retrouvé toutes mes tables que je veux sélectionner et les mètres sur l'autre colonne.

Si je reproduit exactement le même procédé avec ma version 20, ça marche, donc aujourd'hui pour que sa marche je dois le créer avec la version 20 et l'upgradé avec la 23.

Évidement je ne le fait pas car sa doit marché avec la 23, es-ce quelqu'un voit d'ou pourrait venir l'erreur?
prk sa marche en WD20 et pas WD23?

Merci d'avance pour votre aide
Membre enregistré
1 458 messages
Posté le 11 juillet 2018 - 13:52
Bonjour,

Je viens d'avoir exactement le même problème avec une base PostgreSQL. J'ai rajouté le répertoire bin dans le PATH, sinon impossible de se connecter alors que ça fonctionne en WD20.

J'ai redémarré mon poste et relancé WD, et là miracle ça fonctionne. Il doit bien y avoir un bug sur la dernière version de WD mais je pense qu'il est impossible de reproduire le problème et encore moins de créer un projet test. Donc c'est à mon avis peine perdue avec le ST.

--
Cordialement,

Philippe SAINT-BERTIN
Membre enregistré
22 messages
Posté le 11 juillet 2018 - 14:38
Merci Philippe SB,

Je viens de redémarrer mon pc et tjrs le même problème.
le plus fou c'est que si je le créer maintenant avec WD20 ça marche, mais pas avec WD23 }:(
Membre enregistré
1 458 messages
Posté le 11 juillet 2018 - 15:05
Si tu arrives à le reproduire, fais un projet à envoyer au ST pour correction de bug.

--
Cordialement,

Philippe SAINT-BERTIN
Membre enregistré
1 458 messages
Posté le 11 juillet 2018 - 15:08
Moi étonnamment depuis que j'ai intégré le chemin du répertoire bin dans le path ça à l'air de fonctionner...

--
Cordialement,

Philippe SAINT-BERTIN
Membre enregistré
14 messages
Posté le 11 juillet 2018 - 15:43
Bonjour,

Même souci avec une base oracle et oracle natif. Le fait d'avoir mis le répertoire dans le path n'a rien changé.
Membre enregistré
22 messages
Posté le 11 juillet 2018 - 16:23
Là je regarde si c'est pas une erreur de libmysql.dll comme mentionné dans ce poste

https://forum.pcsoft.fr/fr-FR/pcsoft.fr.windev/209402-libmysql-64-bits/read.awp

testé mais pas marché :(
Membre enregistré
22 messages
Posté le 11 juillet 2018 - 16:36
C'est bon j'ai trouvé pour l'accès natif MYSQL

J'ai rajouté une vieille libmysql.dll ce que j'avais mis étais celle de 2016
donc sur le lien ci-dessous elles sont bonne

http://download.process-id.com/Connecteur-natif-MySQL.zip

donc pour résoudre le problème c'est :
installer les deux ddl dans Windev/Programmes/Framework/winxxX86 (64/32)bits

Ce que je comprend pas par contre, c'est d'avoir perdu une journée à avoir cherché la solution à ce problème alors qu'il ne devrait pas exister.

Merci à vous en tous cas :merci:
Message modifié, 11 juillet 2018 - 16:37
Membre enregistré
1 458 messages
Posté le 11 juillet 2018 - 22:31
Eh bien je dirais qu'il y a un joli bug

--
Cordialement,

Philippe SAINT-BERTIN
Membre enregistré
353 messages
Popularité : +3 (3 votes)
Posté le 12 juillet 2018 - 10:27
Bonjour,

Il y a effectivement une anomalie dans l'éditeur d'analyses de la version "update 3", je suis désolé pour le contretemps occasionné.

Le défaut vient du test des connexions en accès natif ou OLE DB. Même si les paramètres de connexion sont faux, ou si le client de la base de données est manquant, l'éditeur d'analyses indique que la connexion est valide. Une des conséquences est que lors d'une importation la liste des tables à importer reste vide.

Un correctif de l'éditeur d'analyses vient d'être publié dans les ressources pratiques :
https://stg.webdev.info/publicationSt_WEB/FR/miseajourst.awp

Une fois le correctif en place, il est possible de tester les connexions comme dans les versions antérieures. Donc l'importation n'est possible que lorsque la connexion est valide.

Rappel : pour permettre une connexion à une base de données, il faut toujours avoir le client de la base de données dans le répertoire du framework de WINDEV, WEBDEV ou WINDEV Mobile. Par exemple pour MySQL, si l'éditeur est en 64 bits, il faut libmysql.dll et ses dépendances dans le dossier \Programmes\Framework\Win64x86 (cf https://doc.pcsoft.fr/fr-FR/?5517001).

--
Guillaume Bayle (Twitter : @GuillaumeBayle)
Support Technique PC SOFT
http://www.pcsoft.fr/st/index.html