PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 25 → erreur Parse JSON avec RESTENVOIE méthode DELETE
erreur Parse JSON avec RESTENVOIE méthode DELETE
Débuté par Eric TORCIA, 07 avr. 2020 20:15 - 1 réponse
Posté le 07 avril 2020 - 20:15
Bonjour

est ce que l'on pourrait m'expliquer cette erreur , à partir de cette requête "REST httpdelete"
{
"DeleteShipmentRequest": {
"ref_shp": "CREFEXP3ENVOI" ,
"ref_haw": "A004670100462" ,
"ref_dos": "B4730011720623" ,
"custid_blx": "D41100ESS01"
}
}



le processus "RESTENVOIE GET" est nickel , le POST aussi et le DELETE me sort une erreur systématique
>>>>>> erreur de parse JSON J001 comme si le machaine..contenu était vide !!! <<<<<<
hors mon fournisseur de WBS tient à fonctionner avec un BODY et non avec le paramètre dans l'URL
mais j'ai l’impression que Windev efface systématiquement le contenu du CONTENU en méthode "httpdelete "
est ce qu'il y a une solution pour contourner cela ?

Merci d'avance
Eric


mon code WINDEV ci-dessous :

mareq est restRequête
Machaine est un Buffer

SI SAI_Delete <> "" ALORS
Machaine = SAI_Delete
FIN
Machaine=ChaîneVersUTF8(Machaine)
mareq..Contenu=Machaine

laréponse est un restRéponse
mareq.URL = "http://cergy3.sdv.com:8018/v1/preprod/shipments/"
mareq..Méthode= httpDelete
mareq..ContentType="application/json"

Info(mareq.URL + mareq..Contenu + mareq..Méthode)

laréponse=RESTEnvoie(mareq)

SI ErreurDétectée ALORS
Erreur(UTF8VersChaîne(ErreurInfo(errComplet)))

SINON
Info(UTF8VersChaîne(laréponse..Contenu))

FIN
Membre enregistré
42 messages
Posté le 28 septembre 2020 - 18:02
Salut ,
j'ai le même problème sur la version 24
Lorsque j'utilise la méthode httpdelete avec les fonctions Restenvoi (), l'application envoie le message sans le contenu (corps) au WebService:




Merci d'avance

--
La vérité est une, le mensonge est multiple.