PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 25 → Gestion erreur après recherche utilisateurs dans Groupware Utilisateurs
Gestion erreur après recherche utilisateurs dans Groupware Utilisateurs
Débuté par Christian ROUTIER, 29 avr. 2020 11:56 - 6 réponses
Membre enregistré
3 messages
Posté le 29 avril 2020 - 11:56
Bonjour à toutes et et tous,

J'ai un petit problème que je ne comprends pas !
Mais ça doit être rien du tout.

J'utilise le Groupware Utilisateurs dans une application. Cela fonctionne parfaitement suivant mes attentes.

Dans cette application, j'ai une interface ou j'enregistre les informations utilisateurs qui ne se trouve pas dans lu GPW.
Ne voulant pas enregistrer la même information a 2 endroits, je veux récupérer le mail de l'utilisateur qui est dans le GPW.
Jusque là pas de problème.

Mon soucis se situe lorsque je veux rechercher un utilisateur créer dans l'appli mais absent du GPW. J'ai un message d'erreur alors que pour moi l'erreur est gérée.
Voici mon code :
FichierVersEcran()
SI Utilisateurs..NouvelEnregistrement ALORS
RETOUR
SINON
Var_utilisateur est un gpwUtilisateur = gpwRechercheUtilisateur(SAI_ID_Login)
SI ErreurDétectée ALORS
Info("L'utilisateur n'est pas créé dans le Groupware Utilisateur" + RC + "Veuillez prévenir l'Administrateur")
RETOUR
FIN
SAI_Email = Var_utilisateur..Email
FIN


C'est surement rien mais je ne suis pas expert.

Si quelqu'un a une idée.

Merci d'avance

Bien à vous et prenez soin de vous.

Christian

--
Bien à vous
Christian
Membre enregistré
1 429 messages
Posté le 29 avril 2020 - 13:10
Bonjour,
1-Le login de ton utilisateur dans ton appli est il le même que le login du gpw.
Sans le message d'erreur, c'est difficile de faire quelque chose, mais à vue de nez :
2-gpwRechercheUtilisateur ne renvoie pas d'erreur, au pire une variable de type gpwUtilisateur non initialisée donc, Var_utilisateur..Email référence quelque chose qui n'existe pas. En décortiquant le message d'erreur, tu vois que l'erreur doit être au niveau de la ligne :
SAI_Email = Var_utilisateur..Email


--
Il y a peut être plus simple, mais, ça tourne
Membre enregistré
3 messages
Posté le 29 avril 2020 - 13:59
Bonjour Voroltinquo,

Merci pour ta réponse.
Quand l'utilisateur est créé dans le GPW, je n'ai pas de problème, l'appli me remonte bien l'email voulu.
Mon problème se situe quand le login du GPW n'est pas créé. Alors que celui dans l'Appli Oui.
L'erreur se situe sur la ligne :
Var_utilisateur est un gpwUtilisateur = gpwRechercheUtilisateur(SAI_ID_Login)

Voici le message :
Une erreur fatale s'est produite sur l'élément de type 'gpwUtilisateur' et empêche son utilisation.
Cette erreur s'est produite à la ligne 5 du traitement 'Fin d'initialisation de FEN_Saisie_ADM_Utilisateur'.
Utilisateur non trouvé.

Ce qui est normal car l'utilisateur n'est pas créé dans le GPW. Je veux juste indiquer à l'utilisateur d'avertir l'admin pour la création.

J'ai suivi les indications suivantes dans l'exemple : https://doc.pcsoft.fr/?1000021087
et rajouté le code suivant :

SI ErreurDétectée ALORS
Info("L'utilisateur n'est pas créé dans le Groupware Utilisateur" + RC + "Veuillez prévenir l'Administrateur")
RETOUR
FIN



Merci pour ton attention.

--
Bien à vous
Christian
Membre enregistré
1 569 messages
Popularité : +9 (9 votes)
Posté le 29 avril 2020 - 15:04
Bonjour,

Essaye d'utiliser la fonction … ;(
https://doc.pcsoft.fr/fr-FR/?1000021104&name=gpwverifieutilisateur_fonction

--
Bon dev,
Jean-Pierre
Membre enregistré
1 429 messages
Posté le 29 avril 2020 - 15:10
Une erreur fatale, c'est une exception, pas une erreur.

--
Il y a peut être plus simple, mais, ça tourne
Membre enregistré
3 messages
Posté le 19 mai 2020 - 15:32
Bonjour,
Bon mon problème est résolu.
Bug dans la version de l'application. J'ai effectué la MAJ en 83h et c'est tout bon.
Désolé pour le dérangement

Bien à vous

--
Bien à vous
Christian
Membre enregistré
2 messages
Posté le 24 mai 2020 - 01:25
Heureux de savoir que votre problème a été résolu :D

https://shareit.onl/ https://mxplayer.pro/