PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 28 → Connection automatique au site zeturf
Connection automatique au site zeturf
Débuté par PIerrot, 10 avr. 2021 11:25 - 1 réponse
Posté le 10 avril 2021 - 11:25
Bonjour,

Je voudrais automatiser la connexion au site web zeturf avec windev.
J'ai réalisé cette procédure ci-dessous. Il me remplit bien mes zones Identifiant et mot de passe.
Mais le click ne fonctionne pas.
Je me demande même si cette procédure est encore valable, car internet explorer ne semble plus supporté.
Mais comment faire alors pour automatiser la connexion sur EDGE ou FIREFOX par exemple ?
Je suis en windev 16.

Merci


ResHandle est entier système
ie est un objet automation "internetexplorer.application"
ZonesSaisies est une chaîne
tIndustriel est un objet automation dynamique
Boutons est un objet automation dynamique
i est un entier

//oForm est un objet Automation dynamique
ie>>Visible = True

ResHandle=ie>>hwnd

sUrl="https://www.zeturf.fr/fr"
LIB_SansNom1="Chargement de "+sUrl+"..."
ie>>navigate(sUrl)
TANTQUE ie>>Busy OR ie>>readyState <> 4
Multitâche(100)
FIN
LIB_SansNom1="Page Chargée.."
Multitâche(300)

//Récupération des zones de saisie
tIndustriel = ie>>Document>>GetElementsByTagName("input")
tIndustriel>>Item(0)>>value = "MonIDentifiant" //ID
tIndustriel>>Item(1)>>value = "MonMotdepasse" //MDP

//Validation Saisie
//On charge la collection "Boutons"
Boutons = ie>>Document>>getElementsByTagName("button")
FOR i = 0 TO Boutons>>Length - 1
IF Boutons>>Item(i)>>ID = "connection_submit" THEN
SORTIR
FIN
FIN
Boutons>>Item(i)>>Click
Membre enregistré
953 messages
Popularité : +183 (185 votes)